Latest beta not working at all? (as at 9th May 2011)

Is there something wrong with the very latest version of the code?  Following Jason's post a few hours ago (where he says that a new version has been uploaded) I tried loading the latest 1280 version and although the Missin Planner reports that it has loaded okay, the code doesn't appear to be actually running at all (there are no ABC lights on power-up and the PWM outputs to the ESCs are completely dead and I can't contact it with CLI).


I have loaded new code many times with the latest Mission Planner so I'm sure I haven't done anything wrong.  Any ideas?

You need to be a member of diydrones to add comments!

Join diydrones

Email me when people reply –


  • Ok, many thanks, this problem seems to have been fixed.  I have successfully downloaded the latest version and it connects to the Mission Planner terminal properly.


    Many thanks!

  • Same issue, download (missionPlanner) looks to have worked, but no comm's opening terminal gives a "opened com port" then hangs.

    No attached parts
    using 1280 code.

    OK, reload mission planner everything now works. ( The interface is very clean).
  • Developer

    This problem is now fixed, please try again. there was an issue with the roms uploaded by apm planner.

  • same problem : loading the 1280 code via MiPl seems to work, but i never get contact via serial port afterwards.
  • Standard fault finding procedure then please.

    APM version

    IMU version

    Attached parts (xbee magneto, etc)

    I would say firmware version but thats pretty obvious :D


    Last but not least you did sure you put the sketchbook to the inside of them ACM folder, right? (So ACM folder and libraries folder are the only visible things in the sketchbook menu).

  • I can't get it to work either. Initially The code appeared to load and I had some cli function, but I could never make it totally through the setup.  I tried to relay the code and now nothing works.
  •   So it's not just me,  I have the same troubles,  It won't load via ArduinoIDE or missionPlanner.  I tried finding what was wrong but haven't found it yet.  I let Jason know.


This reply was deleted.