A strange thing happens with my ArduPilot board (new 328 version) with shield and LD20031 GPS (uses NMEA parsing). I would describe it as follows:- Once in a while, everything runs fine: GPS fix locks blue, serial yellow led blinks.- Sometimes, I had no lock and no blinking yellow led- When I grabbed the board touching random pins, everything went ok again (blue lock, yellow blinking).- When I put the board down, blinking may stop after few second or immediately, blue lock too.- I found out that when I touch the signal pin (or its solder point) of Rx channel Input Number 3, it runs perfectly and doesn't stop working- I remelted every single solder point to be sure to have good contact, but problem is the same- For now, I found a way out: I grounded this specific pin to the GND (-) of Rx channel 5 which is unused with a little piece of wire. And it works flawlessly (GPS locks blue, serial stream not stopping).Now I wonder if the problem would resolve itself when the servo input is connected to the Rx, which is not the case yet.Would someone have an hypothesis about that peculiar phenomenon and how I could resolve it without the grounding of this signal pin? That would be helpful and I would be grateful.

You need to be a member of diydrones to add comments!

Join diydrones

Email me when people reply –

Replies

  • I took off my signal pin grounding. It seemed at first that with the input connected from Rx, the problem was solved. But it seems it is only solved when in "manual" mode. As soon as I switch to "autopilot" or to "RTL", the serial stream gets stuck again!!! This means that there must be something wrong in the board around this signal pin and/or down the line. I'll try to investigate that tomorrow evening.
    If Chris or Jordi read this, you may have an idea how I could investigate that further. Thanks much.
  • Admin
    Reto,

    Without a receiver input on Rx channel #3 it is just floating and that is probably causing the Atmega 328 to become confused as to the input signal that it is trying to process. It is expecting a pulse train and it is just getting random noise most likely.

    Connecting the servo output from the Receiver to that input will most likely correct the problem.

    Regards,
    TCIII
This reply was deleted.

Activity

DIY Robocars via Twitter
RT @donkey_car: Human-scale Donkey Car! Hope this makes it to a @diyrobocars race https://www.youtube.com/watch?v=ZMaf031U8jg
Saturday
DIY Robocars via Twitter
Saturday
DIY Robocars via Twitter
Jun 16
DIY Robocars via Twitter
RT @GrantEMoe: I won my first @diyrobocars @donkey_car virtual race! Many thanks to @chr1sa @EllerbachMaxime @tawnkramer and everyone who m…
Jun 13
DIY Robocars via Twitter
RT @gclue_akira: JetRacerで自動走行したコースを、InstantNeRFで再構築。データセットは別々に収集 #jetracer #instantNeRT https://t.co/T8zjg3MFyO
Jun 13
DIY Robocars via Twitter
RT @SmallpixelCar: SPC 3.0 Now the motor also works. This car is doable. I just need to design a deck to mount my compute and sensors. http…
Jun 13
DIY Robocars via Twitter
RT @SmallpixelCar: My new car SPC 3.0. https://t.co/CKtkZOxeNQ
Jun 7
DIY Robocars via Twitter
RT @SmallpixelCar: High speed at @diyrobocars thanks @EdwardM26321707 for sharing the video https://t.co/o4317Y2U1S
Jun 7
DIY Robocars via Twitter
RT @SmallpixelCar: Today at @RAMS_RC_Club for @diyrobocars. Used @emlid RTK GPS and @adafruit @BoschGlobal IMU. Lap time 28s https://t.co/R…
May 28
DIY Robocars via Twitter
May 15
DIY Robocars via Twitter
May 14
DIY Robocars via Twitter
May 13
DIY Robocars via Twitter
RT @f1tenth: Say hi to our newest #F1TENTH creation for @ieee_ras_icra next week in Philly. It’s going to be huge! 😎 🔥 @AutowareFdn @PennEn…
May 13
DIY Robocars via Twitter
May 11
DIY Robocars via Twitter
May 8
DIY Robocars via Twitter
RT @SmallpixelCar: Noticed my car zigzagged in last run. It turned out to be the grass stuck in the wheel and made the odometry less accura…
May 8
More…