MediaTek GPS - Blue LED Lock, No-Lock IMU RED (C) LED



This issue seems to be prevalent across the forum so I ponder if a FAQ or some steps to sort through this issue. I bought a new MediaTek GPS from the DIYDRONES store. My thought was this thing should be ready to go and plug in. Anything that ships would have whatever latest firmware needed especially for a part such as this.


Anyway, whether this is firmware related or not I do not know as I have not fully exhausted all analysis. I wanted to post a fresh thread that made it clear what the symptoms were so that others could lend advice, solution, or plausible explanation for others who are having this issue as well.


The issue is as follows:


I have the AdruPilot Mega board and the ArduPioletMega IMU Rev-H. The boards are mated as per all instructions and the MTEK GPS connected. I power up via USB, load the software and check things out in CLI mode. Likewise, have tested the other sensors with the Calibration tool.


What I noticed is that the GPS blue LED locks. However, the RED LED (C) never flickers, never locks. I also noticed that GPS data when I run some other coded test I snubbed in report all zeros (0).


Can someone tell me what is the logical next step to get this issue resolved or do I just send the GPS back and request a new one. I assume it is working and that the issue is in the communications between the GPS and ArduPilot Mega board.


Is there new firmware that for some reason is not on the GPS boards being shipped from DIYDRONES?


Thanks in advance for any input and steps to resolve. I am certain others can benefit from a definitive solution as well.



You need to be a member of diydrones to add comments!

Join diydrones

Email me when people reply –


  • I must have chosen the wrong firmware. I will try again.

  • Hi,

    I'm running ArduPiratesNG.  Originally, my MTK GPS was version 1.4, and it worked OK.  Then I made the mistake (?) of updating the f/w to 1.6.  Now the APM does not indicate a lock when selecting position hold.  The red LED on the APM blinks even though the GPS itself indicates a lock (blue LED on).

    Any advice?  Are there any debug prints in the code that I could turn on?


  • Does the editing of transmitter trims affect the APM/IMU to attain GPS lock?



  • 3D Robotics

    Gary, as we've discussed here before there was a glitch in our shipping schedule last month where we were sending out MediaTek modules with 1.6 firmware before the software supports it. We've apologized and explained this and taken corrective action. We have now released APM software that supports it and the ArduPirates are adapting ArduCopter code to do so as well.

    Assuming you have a MediaTek with the 1.6 firmware, which is why your ArduCopter code is not showing lock, you have three options:

    1. If you have a FTDI cable, you can downgrade the firmware yourself
    2. You can return your MediaTek module for a replacement with downgraded firmware
    3. You can wait a week or so for the Pirates to release ArduCopter code that supports the 1.6 firmware
    The MediaTek modules are back in stock and shipping with 1.6 now.


  • what have you commented/ uncommented in code?
This reply was deleted.


David Hori liked Isabella Domi's profile
gotham liked gotham's profile
Dec 3, 2020