MinimOSD issue- No on screen overlay


I've set up my minimOSD as per the diagram below, and, my Transmitter, Camera all work fine, however, there is no overlay data from the APM through the minimOSD board.

When I first set up the configuration below, the minimOSD board showed a progress 'booting up" bar on my screen, then paused and would stay at "Update Char Set".

  I purchased a FTDI serial converter, and using the OSD_Config software, I updated the firmware, the character set, and saved the current 'tab' to the OSD board. Done.

When I plugged the minimOSD back in to my setup, there's no telemetry overlay.

I've tested my 3DR radio and it sends all my telemetry data to the mission planner fine, so the 3DR Radio and cable are working.

I've even set up the 3DR radio and minimOSD in parallel, (making sure the tx is not connected), and, still no joy.

  • The only thing I haven't done is solder the D GND and A GND, and the D VDD and A VDD, because I have a secondary battery powering up the FVP camera and Transmitter, as in the diagram.
  • And, the telemetry cable from the APM has an extra GND wire going to the 6th pin from the top, (as in the diagram), and, I've left it there as I don't think an extra GND would hurt or help.
  • Bad board? How would I know?

Anybody have any ideas?

What am I missing?



You need to be a member of diydrones to add comments!

Join diydrones


  • I was having the same problem with no overlay on the display and saw a post that said if he unplugged the camera, he got overlay on a gray screen, then plug it back in and get good picture, but no overlay. I tried this and saw the same, so I tried my old camera and I got picture with overlay finally. I think the problem is that it works with my Sony TVL600, but not with my Sony TVL960. The 960 must have too much data. That only took me 3 weeks to figure out. I hope this helps someone else.
  • Can I use a remzibi osd instead of the minimosd?
    • No, RenzibiOSD is not Mavlink compatible as PNP, you need some separate adapter. Search on DIYDrones, you will find many discussion

    • Hey Guys,

       I fixed my Miniosd issue months ago.

      Refer to my diagram above.

      I have no idea about the remzibi.

      "the dance" is the hours one spends trying to figure this stuff out.

      Sorry I couldn't be of more help.


  • I've been trying to fix my problem with this, and it's interesting to note that I have *exactly* the same problem, and *exactly* the same camera (PZ0420). Only difference is I use a 5V BEC for the APM circuit, and a 12V BEC for the video and gimbal circuit.

    Without having to dismantle my quad to get to the minim, is there a way I get check the crystal frequency via software? And what is "the dance"?

  • Hi,

    Thought I might share this.  I had the same dilemma, video picture but no overlay, or overlay but no video, never video or overlay together.  

    I had setup my OSD by utilising the 12V feed through the OSD to the VTx as per "David Strassman's" diagram.  The VTx, then supplied power to the camera.

    I ditched this setup, and powered the VTx and camera directly from the battery, bypassing the OSD all together.  Vin & Vout & GNDs still configured as per "David Strassman's" diagram.  You have to solder the pads across on the front and back of the OSD in order for this to work.  Soldering points/pads shown in red in attached photo/file.

    Hope that sorts this issue out.

  • Hi David, I have the same setup as you and had the same problem... Then I found out that the following "pre flight procedure" solved my problem:

    1. Connect APM to its Lipo --> the 5V stage of MinimOSD gets power.

    2. Connect the second Lipo which powers the Camera and the VTx --> the 12V stage of MinimOSD gets power, but at this time no OSD overlay appears.

    3. Press the reset button of the MinimOSD once or twice --> still no overlay.

    4. Disconnect the second Lipo (the "Cam Lipo")

    5. Reconnect it. --> And - yes! - I get overlay data. This works every time, I don't know why...

    • It worked for me.

      What a headache ! My board is minimosd V0.1 from hobbyking (got it a monthes ago.).

  • Just for the sake of review - Have you ever checked the board for the properly installed MAX7456 27MHz crystal? I know you told me you have the REAL 3DR but, I can get my non-operational clone to work without my Sony 600 camera attached too. My fake3DR has a wrongly installed 24MHz crystal which, is not in specifications for the MAX IC. Possibly check for the onboard 16MHz also.

    I would believe it is possible that the timing on your OSD will not properly sync to the camera video feed if the MAX chip is not properly timed. Which is because of inaccurate voltage (power supply) or wrong electronic timing (electronic components).

    I have hand soldered a DF DIY OSD w/MAX7456 and it works great with the Sony camera. This DIY OSD has the correct crystals. The MinimOSD really shouldn't be a mystic science. There are very few connections required and Because the things are flying in many machines for more than a year.

    For my situation I will either - install the proper 27MHz crystal, use my DIY OSD w/MAX7456 or buy another MinimOSD. Not sure.....

  • Moderator

    Hi David,

    1) Which Version MinimOSD do you have?

    2) Which Version of the CT tool are you using to upload the firmware/panels?

    3) Which Version of Firmware are you using?

    4) Which character set are you uploading?

    5) Using the CT tool, can you read the panel data successfully?

    6) What voltage is being supplied to the VTx side of the MinimOSD?

    7) I assume you are using the MP with the telemetry, are you receiving heartbeats in the MP?

    8) Do you have both SR3 AND SR0 parameters configured as seen here?

    I've even set up the 3DR radio and minimOSD in parallel, (making sure the tx is not connected), and, still no joy.

    When you have the parallel cable installed you have the Tx connected to the telemetry radio right? You won't get any mavlink messages until the telemetry radio requests them.

    I know it's a lot of questions but there are a number of possible issues that can cause this. Have you checked out the thread 'Adding Extra Functions to the MinimOSD'? It's a very active group that has a lot of experience with the MinimOSD; if you continue to have trouble try asking your question there.


    Nathaniel ~KD2DEY

This reply was deleted.