I have APM2, XBee Pro 900, connected to MinimOSD without TX line as advised.  When I power up the system, the MinimOSD always shows Booting, then "Update Charset" and goes no further.  If I press the hard reset it works fine again, but never on initial bootup.  It also does this if I unplug the XBee and connect the MinimOSD directly to the APM with all pins connected.

Is anyone else having this problem?  This does not seem like normal behavior.

I have also re-updated the firmware and charset with the MinimOSD software and nothing changed.

Please help!

You need to be a member of diydrones to add comments!

Join diydrones

Email me when people reply –

Replies

  • I'm having the same issue as described. I have the latest OSD firmware and Character set installed. I've tried various TELEM_DELAY times from 0 to 10 and the problem still insists. The default time was set to 0. By the way, I have the Pixhawk with Aruduplane 3.2 loaded. 

    • this problem started for me today.was working fine then now this!

      any ideas?

      • Recently when I wired up my Iris+ to do OSD, i notice that when I first power on my Iris+, I do not power the gimbal until the OSD board boots up. Once it boots I can then plug in my 2d gimbal. 

        When I have the gimbal power cord plugged in when I plug in the Iris+ I get the update character set. This usually indicates that I have powered on the Iris+ with the gimbal plugged in. I then restart the Iris+ with the gimbal unplugged.

  • APM 2.6 and new MinimumOSD all from the shop here and Same issue. I ordered a USB to the MinimumOSD cable so I can  update the OSD. I hope that will solve this!

  • I am having this issue UPDATE CHARSET
    PX4 2.76 plane
    OSD fw 2.0


    I have tried various TELEM_DELAY as recommended (default was 0) at no avail.
    Initially the two supply jumpers on the minimOSD was connected (supplying from 12V).
    I removed the solder jumpers and problem persists.

    Would this not justify a OSD firmware fix?!
    It is quite frustrating...
    / Tom

  • hi all, 

    I have a problem, 

    after updating the firmware with the latest relase and subsequently updated the character set with Latest_Charset.mcm

    but always visualize these writings:

    ykt1.jpg

    can anyone help me? please

  • OK, in the latest MinimOSD release, you can avoid the "Charset Update" problem on power/boot by simply setting the TELEM_DELAY to be 4 seconds or less.  Setting it to 5 seconds or more will cause it every time.  Enjoy!

  • I'm seeing this issue again after upgrading to the latest minimOSD firmware (2.0) with APM 2 using 2.8.1.  Is there a good way to correct this that doesn't require code tweaking?

    It seems terrible that the standard procedure after powering up is to hard reset the OSD before it is actually usable.

  • Hi,have you already solved the problem? I met the same problem as yours. If you know how to finish it ,can you help me?Thanks!

  • Hey David, thanks for that :-)

This reply was deleted.

Activity

gotham liked gotham's profile
6 hours ago
DIY Robocars via Twitter
RT @RoboticMasters: Monaco GP Circuit in the Donkey Sim (coming soon). Including buildings, tunnel and all! https://github.com/robotics-masters/sim-donkeycar-f1/tree/f1-tracks @diyr…
yesterday
DIY Robocars via Twitter
RT @breadcentric: Here are the details of #AWSDeepRacer finals: https://blog.deepracing.io/2020/12/01/aws-deepracer-league-finals-2020-round-1-schedule/ #awsreinvent2020 #AWSreInvent https://t.co/ovqsjp8V…
yesterday
DIY Robocars via Twitter
RT @breadcentric: #AWSDeepRacer League #awsreinvent2020 Open race is on Dec 1st - Dec 31st in three categories, 15 DeepRacer Evo (with LIDA…
yesterday
DIY Robocars via Twitter
RT @a1k0n: @SmallpixelCar @diyrobocars It's just something that's easy to track with chroma keying. I ended up using different colors on th…
Monday
DIY Robocars via Twitter
Monday
DIY Robocars via Twitter
RT @TinkerGen_: "The Tinkergen MARK ($199) is my new favorite starter robocar. It’s got everything — computer vision, deep learning, sensor…
Nov 23
DIY Robocars via Twitter
Nov 23
DIY Robocars via Twitter
RT @roboton_io: Join our FREE Sumo Competition 🤖🏆 👉 https://roboton.io/ranking/vsc2020 #sumo #robot #edtech #competition #games4ed https://t.co/WOx…
Nov 16
DIY Drones via Twitter
First impressions of Tinkergen MARK robocar https://ift.tt/36IeZHc
Nov 16
DIY Robocars via Twitter
Our review of the @TinkerGen_ MARK robocar, which is the best on the market right now https://diyrobocars.com/2020/11/15/first-impressions-of-tinkergen-mark-robocar/ https://t.co/ENIlU5SfZ2
Nov 15
DIY Robocars via Twitter
RT @Ingmar_Stapel: I have now explained the OpenBot project in great detail on my blog with 12 articles step by step. I hope you enjoy read…
Nov 15
DIY Robocars via Twitter
RT @DAVGtech: This is a must attend. Click the link, follow link to read the story, sign up. #chaos2020 #digitalconnection #digitalworld ht…
Nov 15
DIY Robocars via Twitter
RT @a1k0n: Got a new chassis for outdoor races (hobbyking Quantum Vandal) but I totally didn't expect that it might cause problems for my g…
Nov 11
DIY Drones via Twitter
First impressions of the Intel OpenBot https://ift.tt/36qkVV4
Nov 10
DIY Robocars via Twitter
Nov 9
More…