Missing overlay on GoPro Hero2 signal with MinimOSD

Hi guys,

I'm really sorry if this subject has been asked before but I cannot find the answer.

There goes.

If I connect my cheap china cam  (PAL) to the MinimOSD (v.1.1) everything is fine, the signal is overlayed by the data, but if I do the same with my GoPro Hero2's analog signal only the video is transmitted. No overlay at all. If I remove my video source the overlay appears on the gray background.

Any help?

Best regards

Michael

Views: 6073

Reply to This

Replies to This Discussion

My first thought is that it could be because the GoPro default output is NTSC and it appears that a PAL camera in your case works fine. This might be a setting which needs to be changed on the minimOSD. First though, try changing the GoPro to output PAL instead. In the GoPro settings menu, choose the "more" option. Then scroll to the NTSC/PAL setting and switch it there.

That's the only idea I have for now. Good luck!

Hi Eric,

The GoPro was already on PAL (I've just tried both) Still no success :(

I was afraid of that. I've never used the MinimOSD so far, so I have no experience with what does and doesn't work. My other thought was resolution. The cheapo cam obviously has a lower resolution, so I wonder if lowering the GoPro resolution might work..

I've just been through all the resolution settings with no luck.

As far as I can read on the internet the composite output is always the same resolution (standard PAL/NTSC).

First thing that you should do is reset the MinimOSD board (using its hardware reset button) whenever you plug in the camera. This will usually make the overlay appear.

 

If that doesn't work, check all your connections. If it is still not working, it is possibly a resolution issue, but others have the OSD working with their GoPro's.

 

Ensure that the board is set to PAL, solder the jumper to be sure.

I've pressed reset after every try of the different settings, still no luck.

I've tested with another MinimOSD, same result.

With another Hero2, same result.

With the cheap Chinese camera, same result as mentioned before.

I've soldered the PAL jumper on one of the MinimOSDs, same result.

I don't understand why it the OSD isn't shown :S

I'll go to bed now (it's 03:27AM here in Denmark now, national holiday tomorrow ;) ), and try to solve this tomorrow with a fresh pair of eyes.

Thank you for your help so far :)

 

Okay,

now I tried every combination I could think of again with the same results.

Any suggestions are more than welcome.

First power on your GoPro then connect the live feed.

I have no probem with Minimosd + GoPro 2 combination.

A short video of my setup:

http://youtu.be/sX85lXuccEY

Ace

Watching your video, I see you did a few modifications to your Miniosd software. Would you mind sharing the changes? Is it just the Miniosd software or both the AMP and Miniosd? I noticed you have RSSI X 2 do you have 2 receivers? I also like the Alt arrow and the home arrow. Last thing is the blinking batt, do you have it set to blink at a low voltage or all the time?

Sorry just readed the caption on the your tube page that answers a lot of my questions.

Thanks

Burt Green

 

Michael,

i had the same issue - it isn't an issue.

May be you solved your problem in the meantime - if not here my solution which works instandly for me:

I think you updated your ARDUPLANE-Software to the newest which is using Mavlink 1.0,

Your MinimOSD works with Mavlink 0.9, therefore it almost waiting for the Heartbeat.

Solution:

1. Update your  MinimOSD to 1.0-Firmware " MinimOSD_19_MAV10.hex" (Download-Section OSD) using the described special FDTI-6-Pin Cable.

2. Fit together all cables and Power on all, EXEPT your MinimOSD. After Power on, wait about 15-20 sec. and then Power the MinimOSD-Board (connect to APM). Now it is able to reconfig it self, including your GoPro or other Camera.

I hope, i could help you, pls. post if its working for you.

Best regards Rolf

Hi Michael,

The "problem" is that When MinimOSD boots up and can see  no video, than it can't decide between the standards, so it defaults to NTSC. Than you connect, or turn on your cam and as MinimOSD can only change standards on boot, flight data  "goes away". So you reset it with the cam working, than it does finds out about your cams standard, and works. Soldier jumper did nothing for me, so i started to look for this in the source code of MinimOSD. I have found this in the code, and fixed it to PAL. It is in ArduCam_Max7456.cpp

No more problems. I can turn my cam on anytime i want now.

Hope it helps. ;)

Reply to Discussion

RSS

© 2019   Created by Chris Anderson.   Powered by

Badges  |  Report an Issue  |  Terms of Service