Mission Planner 1.2.63 and Arducopter 3.0.1  is flying mission fine until I add a waypoint to Loiter with 3 turns.

Some mission WPs with delays etc..  all work then goto WP 4

WP 4   just a normal way point altitude 100 feet

Loiter with Turns     set turns to 3    


The first time I did this mission it went to WP 4 then landed at WP 4.

Remove the Loiter with 3 turns - Mission completed as expected with RTL at default alt.

Then I investigated the original mission.

OK,  so I forgot to set the Altitude for the Loiter with 3 turns WP

I set the altitude for that entry to 100 feet.

Flew Mission again.  Copter landed at the WP 4.

The copter is arriving at WP 4 with the correct altitude but just continues to descend

Can anyone tell me what I am doing wrong or is this a bug   Thanks


Views: 1468

Reply to This

Replies to This Discussion

It sounds similar to a previous bug in that the command had to followed by a waypoint or it was ignored.

I guess through this experience it has become habit to use a final waypoint/land combination instead of RTL.

Would be interested to hear if that combination works in this instance.

I have been having that weired behaviour too using the loiter_turns.

This is a bug in the firmware and it is actually mentioned on Randy mackay 3.01 release notes.

it is warning number 4


so i guess it is just a matter of time for it to be fixed on 3.02

Oh,  I read that warning but thought it applied to turns made by the radio (operator) while in Loiter.  I did not make the connection to loiter_turns mission action.  Did you try Mike's suggestion, adding a WP after loiter_turns?

Wind and rain here today so will not be able to test his suggestion for a while.

Wops, I just read Randy's post in http://www.diydrones.com/forum/topics/arducopter-3-0-1-released 11 hrs ago and he answered the question.  The issue is in the mission loiter_turns, not while doing turns manually while in Loiter mode.  So,,,  I will wait for 3.0.2 to use the loiter_turns in mission.  I think perhaps circle with radius of 0 may do what I want. Will investigate that.

Thanks for the help

Yes i tried adding waypints after the lioter and it went to the way point without doing the loiter.

the loiter turn did work with me on version 2.6 but at that time I had too many problems which are solved now by version 3

I will try to fly this week end and investigate more about the loiter process. I need my quad to yaw 360 on the auto mode too. 

Turning manually on loiter mode works like a charm by the way. I used it to capture panorama images and it came out really nice

Reply to Discussion


© 2018   Created by Chris Anderson.   Powered by

Badges  |  Report an Issue  |  Terms of Service