Replies

  • I am running MP on a win10 tablet, and when I select an alpha numeric field to edit, the keypad interface does not come up, so I cannot edit the field. It does work right in any other program on the tablet. Is there a tablet mode in MP that I haven't found yet?

    • I have kind of figured this out. I can select the space to edit, then manually bring up the keyboard, then edit the space blindly, hit enter, close the keyboard, then see if my edit was correct, or had any effect at all.

  • I still cannot get MP to quit hanging on start up.

    My notebook is an 11"  convertible and the main C: drive is SSD in the screen, and only if the hard drive in the detachable keyboard is connected will MP run.

    On W8 I had no problems with ejecting that drive.

    I have tried all the suggestions on this thread and none of them have worked. Including installing drivers from other sources as listed in this thread. Each time I have uninstalled the current drivers before installing new ones using the ignore signatures start up option.

    MP simply hangs on start up each time.

    The program works perfectly on my desktop after the upgrade to W10.

    • So I figured it out.

      MP does work on my tablet under W10

      The reason the program locked up on mine is because I had removed an SD card which was the location of the log files.

      MP expected it to be in a location which no longer existed.

      I would expect MP to tell me about that, but it did not. Instead it just locked up.

      I also came to realise that uninstalling MP did not remove all previous files, or references.

      I found the solution by reading the start up log files in MP's exe dir.

      Well all works well now : - )

  • Just a small point for those who don't know to avoid further posts, the option "run as administrator" only applies to executables, not .msi files. Only way to run as admin in that case is to enable the admin account and log in as that and reinstall.

    Incidentally one possible way round is to use the arduino dev kit as the old APM's are megas

  • Just disable driver signature enforcement.

    http://www.howtogeek.com/167723/how-to-disable-driver-signature-ver...

    The run the kit as Administrator.

  • One thing that has worked for me for some reason I cannot figure why is installing the drivers separately though this link

    http://pixhawk.org/static/px4driver.msi

    With this installer I got asked by windows with a separate pop up window I I want to install. it worked!

  • Just a note here to say I had the same (driver fail) install issue as Tony.

    I didn't "solve it" as such but found a work around. I installed the Arduino SDK which comes with drivers for the mega (which is what those particular APM boards are) and that worked fine.  Somewhere along the line the telemetry board started working too. Not sure if this was as a result of the Arduino software or not.

    re the suggestion of running from admin mode. Annoyingly the Mission Planner install is a .msi file so isn't right-click-able "run as" like .exe's are.  I tried running it from an elevated command prompt though... not sure that it made a difference. The drivers didn't install though like that either.

    So yeh... arduino software is a work around https://www.arduino.cc/en/main/software

    Arduino - Software
    Open-source electronic prototyping platform enabling users to create interactive electronic objects.
    • Thanks Johnny for the input. I will try that because I have had no luck even with a clean install of windows 10.

      • I upgraded my PC from Win 8 to Win 10 and has been trouble -free with Mission Planner for several months until 2 days ago, when I was trying to install the driver for PX4FLOW (Optical flow) for Pixhawk on my PC (without success), I got the following error message when connecting Pixhawk to Mission Planner via USB :--

            "Cannot establish a connection"

             " Index was outside the bounds of the array"

        This is the first time I see this error message. There is no problem with the driver as I can see "Pixhawk" in the connection tab. I tried uninstall and then re-install Mission Planner, but it did not help.

        Anybody has clue to what has gone wrong. ?

This reply was deleted.

Activity

DIY Robocars via Twitter
RT @chr1sa: Just a week to go before our next @DIYRobocars race at @circuitlaunch, complete with famous Brazilian BBQ. It's free, fun for k…
19 hours ago
DIY Robocars via Twitter
How to use the new @donkey_car graphical UI to edit driving data for better training https://www.youtube.com/watch?v=J5-zHNeNebQ
Nov 28
DIY Robocars via Twitter
RT @SmallpixelCar: Wrote a program to find the light positions at @circuitlaunch. Here is the hypothesis of the light locations updating ba…
Nov 26
DIY Robocars via Twitter
RT @SmallpixelCar: Broke my @HokuyoUsa Lidar today. Luckily the non-cone localization, based on @a1k0n LightSLAM idea, works. It will help…
Nov 25
DIY Robocars via Twitter
@gclue_akira CC @NVIDIAEmbedded
Nov 23
DIY Robocars via Twitter
RT @luxonis: OAK-D PoE Autonomous Vehicle (Courtesy of zonyl in our Discord: https://discord.gg/EPsZHkg9Nx) https://t.co/PNDewvJdrb
Nov 23
DIY Robocars via Twitter
RT @f1tenth: It is getting dark and rainy on the F1TENTH racetrack in the @LGSVLSimulator. Testing out the new flood lights for the racetra…
Nov 23
DIY Robocars via Twitter
RT @JoeSpeeds: Live Now! Alex of @IndyAChallenge winning @TU_Muenchen team talking about their racing strategy and open source @OpenRobotic…
Nov 20
DIY Robocars via Twitter
RT @DAVGtech: Live NOW! Alexander Wischnewski of Indy Autonomous Challenge winning TUM team talking racing @diyrobocars @Heavy02011 @Ottawa…
Nov 20
DIY Robocars via Twitter
Incredible training performance with Donkeycar https://www.youtube.com/watch?v=9yy7ASttw04
Nov 9
DIY Robocars via Twitter
RT @JoeSpeeds: Sat Nov 6 Virtual DonkeyCar (and other cars, too) Race. So bring any car? @diyrobocars @IndyAChallenge https://t.co/nZQTff5…
Oct 31
DIY Robocars via Twitter
RT @JoeSpeeds: @chr1sa awesomely scary to see in person as our $1M robot almost clipped the walls as it spun at 140mph. But it was also awe…
Oct 29
DIY Robocars via Twitter
RT @chr1sa: Hey, @a1k0n's amazing "localize by the ceiling lights" @diyrobocars made @hackaday! It's consistently been the fastest in our…
Oct 25
DIY Robocars via Twitter
RT @IMS: It’s only fitting that @BostonDynamics Spot is waving the green flag for today’s @IndyAChallenge! Watch LIVE 👉 https://t.co/NtKnO…
Oct 23
DIY Robocars via Twitter
RT @IndyAChallenge: Congratulations to @TU_Muenchen the winners of the historic @IndyAChallenge and $1M. The first autonomous racecar comp…
Oct 23
DIY Robocars via Twitter
RT @JoeSpeeds: 🏎@TU_Muenchen #ROS 2 @EclipseCyclone #DDS #Zenoh 137mph. Saturday 10am EDT @IndyAChallenge @Twitch http://indyautonomouschallenge.com/stream
Oct 23
More…