MP 1.3.23 "error receiving log list"

I've got me usb cable hooked straight into pixhawk (V3.2.1) and keep getting an "error receiving log list". I'm stuck. I tried downloading over telemerty, no luck either. 

Has anyone seen or know what is going on?

Thx,

Wes

You need to be a member of diydrones to add comments!

Join diydrones

Email me when people reply –

Replies

  • Any updates? I can not download logs either.
    • I had the same problem, and believe it or not I found a simple solution that worked for me. I copied all the logs from the microSD chip to my hard drive (C:\Program Files (x86)\Mission Planner\logs\QUADROTOR\1) then I erased all the logs on the card.  When I put it back into the pixhawk, it works perfect. You might try just clearing them from within mission planner, but i did not try it that way.    3DR indicated that having over 100 log files on my drone should not have caused a problem, but something changed after I deleted them. 

      Hope it works for you!  please let me know. 

  • I have had this problem for over a month now, and even 3DR was not sure what the issue is. they did tell me that using terminal no longer works in APM 3.2.1 or higher, and that I should used mavlink, but still no luck.  BUT I noticed that my log list is showing over 100 logs, and ever since it crossed the line I have been getting the error.  So I physically took the card out of my Pixhawk, and copied all of my logs, then I set it back in and erased all my logs.  Ever since then, I am good again. 

  • I have been having this problem for about two months now. Somewhere along the line I must have updated my firmware.   I was able to download the log using Terminal today, but that did not work in past attempts.  According to another post they stopped supporting Terminal downloads in version 3.2.1 APM, and they recommend using Mavlink via Flight data screen. 

    3DR told me to just take out the SD card and download them directly from there.  I noticed that my log files are now over 100 and I wonder if that is part of the problem.  I will try to download and erase all my logs to see if that helps. 

  • Got the same issue trying to download log via mavlink. MP 1.3.30, APM 2.5, firmware 2.x (cannot see exactly thru MP).
    Have downloaded logs week before with absolutely the same setup - successfully.

  • I was able to get them through the terminal. It took hours to get them all. next time I'll see if they can be pulled right off the ad card...not sure, but worth a shot.
    • It did end up pulling the files when hooked up via usb, but only through the terminal. Good luck!
    • used micro SD card reader and got my file by pulling the micro SD right out of the pixhawk. let's hope it will allow me to geo tag my images now...

    • wesley, were you hooked up via USB to pixhawk?

  • same issue on MP1.3.24 build 1.1.5574.33902 . any help appreciated.

This reply was deleted.

Activity

DIY Robocars via Twitter
RT @SahikaGenc: AWS DeepRacer & Hot Wheels Track https://youtu.be/4H0Ei07RdR4 via @YouTube
Monday
DIY Robocars via Twitter
Sep 8
DIY Robocars via Twitter
RT @davsca1: We are releasing the code of our Fisher Information Field, the first dedicated map for perception-aware planning that is >10x…
Sep 8
DIY Robocars via Twitter
RT @SmallpixelCar: How this works: 1)object detection to find cones in single camera image, 30 frames/sec on @NVIDIAEmbedded Xavier. 2)comp…
Sep 8
DIY Robocars via Twitter
RT @SmallpixelCar: Use two color cones to guide the robocar. No map needed, on onsite training needed. Just place the cones and it will fol…
Sep 7
DIY Robocars via Twitter
Sep 7
DIY Robocars via Twitter
RT @roboton_io: Great to see http://roboton.io running at 60fps on the cheapest #chromebook we could find! #edtech #robotics #educat…
Sep 3
DIY Robocars via Twitter
RT @openmvcam: Crazy in-depth article about using the OpenMV Cam for Astrophotography: https://github.com/frank26080115/OpemMV-Astrophotography-Gear https://t.co/BPoK9QDEwS
Sep 3
DIY Robocars via Twitter
RT @openmvcam: Hi folks, it's finally here! Our first draft of our Arduino Interface Library is out! It works over SoftwareSerial, Hardware…
Sep 3
DIY Robocars via Twitter
RT @chr1sa: Please let them have an open API. This would be perfect for @DIYRobocars races https://twitter.com/NintendoAmerica/status/1301513099707658246
Sep 3
DIY Robocars via Twitter
RT @SmallpixelCar: Lanenet pretty much used all my GPU power on @NVIDIAEmbedded Xavier since I optimized with tensorRT. I need to run anoth…
Sep 3
xemone liked Max Gilson's profile
Aug 31
DIY Robocars via Twitter
RT @LyftLevel5: Our @kaggle competition on Motion Prediction for Autonomous Vehicles is now live! Experiment with the largest-ever self-dri…
Aug 24
DIY Robocars via Twitter
RT @chr1sa: Our next @DIYRobocars virtual AI car race will be on Sept 26th. Sign up here https://www.meetup.com/DIYRobocars/events/272786977/ https://t.co/UENKGSOWO8
Aug 24
DIY Robocars via Twitter
New ready-to-run @NVIDIAEmbedded JetRacer car from Waveshare. Perfect for the next @diyrobocars race as soon as we… https://twitter.com/i/web/status/1297960223013867520
Aug 24
DIY Drones via Twitter
RT @chr1sa: The US government just approved 5 US-made drones for purchase, all based on the @Dronecode @PX4Autopilot standard. Great news f…
Aug 20
More…