I found this video and per the video and with some read up, I did tune my F450 Quad (with stock DJI motors, ESCs and props) Quad set in (X) configuration. APM 2.5 on board. I focused on 4 basic parameters initially. I used the channel 6 option to tune the values during flight. Would you please read below and make comment/answer my questions as applicable?

1.Rate_Control_P: I started with this one. I read that this is the single most important parameter. I flew in Acro mode and change this parameter while flying. I found a sweetspot; landed and permanently wrote it. It came to be 0.1420 for my taste.

This paremeter (Kp) acted just like I am adding a negative expo (positive for JR) or reducing stick travel rate. So I am pretty sure I could have gotten the same thing by just playing the Tx menus instead of this Kp value. I am not sure what the real difference is. And I am not sure if one should adjust the Tx parameters before messing with this Kp value. Any comment appreciated:)

2.Rate_Control_I: Flew in Acro mode again. I tried to use the same approach for this one too but I wasn't able to get much. No matter what I did, my quad wasn't holding the angle. I think I was changing the I value between 0.100 and 0.200 and I almost saw no change between the min. and max. values so I left it at 0.15.

I am not saying my quad was self leveling like in the Stabilize mode but it wasn't holding the angle as soon as I let go off the sticks. What should I do here?

3.Stabilize_Control_P: This time I flew in stabilize mode. My starting value was 4.5. I was thinking I would see some oscillation. I didn't. But it was twitchy to my taste. I like smooth flying machines. I reduced it down to 2.5 level and it flew okay but then I didn't want it to be unstable in gusty winds so I brought it back up to 3.3 and left it there.

4.Stabilize_Control_I: I ran out of battery by the time I get to this. I checked and my Quad was coming down okay. Not super stable but it wasn't so wobbly. The default value is 0.00 for this one. I think I will try 0.02 when I get a chance to see if it will work better.

You need to be a member of diydrones to add comments!

Join diydrones

Email me when people reply –


  • Another testflight: ACRO_BAL_PITCH=25 and ACRO_BAL_ROLL=50. 

    These parameters seem to work well to my taste in Acro mode. Though when I was flying today, I realized that when I give hard stick inputs, the copter would oscillate a little. It would keep the angle no problem but with some oscillation.

    It would also oscillate when I was hovering at level flight as well (it was slightly windy outside but not so terrible)

    What would prevent this oscillation? Should I thinker with Rate_Control_P and Rate-Control_I again?

    I think I need to reduce the Rate-Control_P. Am I right? (You can see my current settings in my first post above)

  • I testflew the Acro mode today. The parameter (ACRO_TRAINER) I changed did not work. The default was 1 and I changed it to 0. Copter wasn't holding an angle. I will set it back to 1 and play with the ACRO_BAL_XXX parameters. I think I will set both of them down to 0 and see if that gives me what I want.

  • From the man who wrote the ACRO code (Leonard Hall)

    'When AXIS_ENABLE is set to 1 ACRO is the same as STABILISE just with a different interpretation of the stick inputs. Instead of the stick angle being equal to the requested angle sent to the stab controller, the stick angle is the rate at which the requested angle is changed. All ACRO_BAL_XXX variables do is change how fast the requested angle is moved back to horizontal.

    When you set AXIS_ENABLE to 0 it simply bypasses the stab controller and you have true rate only control. So for tuning purposes you need to set AXIS_ENABLE to 0.'

  • Nobody made any comment on this. It is either so good or not interesting at all:)

    Well I did some Acro and Stabilized flights today and the only difference between the two modes were that in Acro I could tilt the copter beyond 45 degree and in Stabilize mode I could not. 

    Other than this there was no difference!!!

    Why can I not get a true Acro mode??? I do not want self leveling in Acro mode...

This reply was deleted.


Shivchand Jaysaval liked Shivchand Jaysaval's profile
Aug 25