Need help with gimbal servos

I recently purchased a jDrones GoPro gimbal.  For simplicity sake, I bought their 9g analog servos and their 5V BEC as well.  I hooked the signal lines up per the wiki to RC10 and RC11 on my APM2.5, and I built a Y cable to split the BEC output to the vdc inputs for the servos.  For testing, I have a small 3S lipo hooked up to the BEC, and am powering the APM from USB.  There's no power for the servos coming from the APM at all, only the signal line.  Basically, no matter what I do, the servos hum and get very hot.  They move but no matter what I do, I can't them to go through their full range of motion no matter how I play with the limits or the midpoint.  For example, I will get it to track when it rolls left but not right.  It seems to be actually hitting the limit of the servo while the APM is level.  It's not physically binding because it will stop turning even with the horn off.  If I hook the servo up directly to my Futbaba rx and use a knob tied to channel 6, I can center the gimbal physically at neutral  input and move the gimbal back and forth with the knob, both in the roll and pitch direction.  So it's not something physical.  There's no humming using the rx either.  I looked at the input from channel 6 to determine the endpoints that worked on the rx and it was 1100 to 1950.  I just don't see what I'm missing.  The wiki's and discussions make this seem pretty simple as long as you avoid powering from the RC rail.  I tried playing with rc_speed but that has no affect.  I can't find any tuning output that shows me what it's sending to RC10 and 11 at any given time, so I don't know what else to try.  I haven't tried any of the RC outputs because I read that only 10 and 11 support analog servos.  It really seems like it's outputting at something faster than 50hz but I don't know why that would be.  I'm running 2.9.1b. 


Any insight would be greatly appreciated.

You need to be a member of diydrones to add comments!

Join diydrones

Email me when people reply –


  • HI there, I am having exactly the same issue with the binding (locking). I have it wired exactly as you do, w the balance port red/black powering a ESC/ BEC out to the brushless gimbal motors. can't seem to get it to initialize and stabilize. any ideas? I have it powered by a 3s lipo and all the voltages check out in the proper places, can't seem to make it happen. Thanks.


    • I am running servos directly. You are using brushless gimbal motors. Are you using a gimbal controller as well?
  • Hi Dave

    Is it possible to get a picture how you did it ? 

    As the APM is not powering the Servos i'm a bit lost how to connect the 2 Servos i have to the APM 2.5+ is there a Diagram i can take a look or something like this, i have 2 Servos with a 3 wire plug, how do i connect.



  • I did not read the whole post but powering servos on own battery and not grounding that power source to the boards powersource is a no go. The signal wire won't work if there is no common ground.

  • I had a similar problem a while back which was resolved via some settings in the advanced parameter list. There was a sort of disconnect between the MP gimbal page settings and the actual parameters. I'm no longer totally clear on the details so don't want to throw stuff out here that may confuse things for anyone. I have a friend nearby who may remember how we fixed it and I'll talk with him tomorrow. Meanwhile, send me a "friends" request so I can PM you. 

This reply was deleted.


Neville Rodrigues liked Neville Rodrigues's profile
Jun 30
Santiago Perez liked Santiago Perez's profile
Jun 21