Hi,I am using an original 3dr pixhawk with a 650 frame. I have ekf enabled on AC 3.2. I have noticed one problem where I need to keep re-doing the accelerometer calibration for the first flight of the day. If not done, one or two of the motors clearly spools up a lot slower on takeoff causing the quad to flip before takeoff.Initially I did not know what the problem was however over time I realized that doing an accelerometer calibration solves the problem.There is no error or warning that shows up in mission planner.Any ideas how to fix this issue?ThanksArshish

You need to be a member of diydrones to add comments!

Join diydrones

Email me when people reply –

Replies



  • Yes it happened to me to, CX20 with APM 2.6, I would calibrate then take off, land, take off but would go sideways and crash mainly, recalibraite  and repeat all the above steps. I heard that removeing the jp1 jumper and powering the board that way would help but nothing changed, I changed APM but that was today, not tried it yet.

  • I know this is a very old thread that I started but i still face this issue occasionally. Was wondering of others are also facing this issue?

    If it happens again, Ill upload the logs here.

  • Hopefully someone from 3dr will reply here...

  • Hi,

    I think that i have the same issue, occasionally when i change the battery the quad flies, but its impossible to make a second flight and sometimes when the drone flies normal after some time flying the speed of one or two motors decreases and the drone falls.

    I sent the info and a log to the 3DR support, because i thought that there was a bad sensor, but they told me that my pixhawk is ok. Respect to the backup power im only using the 3dr power module.

    My config is Pixhawk, dji E300 (motor, esc, props) and Turnigy 9x with a 3DR ppm encoder.

  • I read somewhere in another post that having a backup power source connected to the output rail (I have a backup bec connects there) causes issues with the accelerometer.

    Hope someone can help us out here.
  • Very interesting I think I have the same issue but on APM 2.6 with 3.2 firmware flying a big 810 frame in Y6B.

    I added a new camera today and had a test flight that went ok but had some glitchy video so I landed to look for bad connections. Then when I tried to take off again the friggin machine went nuts. One of the motors spooled up really aggressively in Stabilize and then it appeared to want to flip on slight accelleration.Tried to take off on PosHold but it seemed pretty unstable and I stopped it just short of falling over. Another attempt in Stabilize caused it to fall over forward. It was on the lawn so there wasn't any damage I could see.

    I decided to stop trying and inspect the machine but everything looks fine. Tomorrow I will try the acc calibration and see what happens. I also downloaded the firmware upgrade to 3.2.1 so hoping that helps.

    It worries me a little because I have never had any problems taking off or flying since I got the machine running 3.1.5 firmware. This is now new better firmware and nearly caused me to crash a machine that has never even tipped over.

    I hope someone has some insight into this.

This reply was deleted.

Activity

DIY Drones via Twitter
RT @chr1sa: Somehow I missed this, but last week @Nvidia released a new version of its Isaac robot development framework. Lots of new Lidar…
11 hours ago
DIY Robocars via Twitter
RT @Smartphone89: DonkeyCar Racing League Korea #donkeycar @diyrobocars https://t.co/mDlHDR1d98
Friday
Jørn Ramnæs liked VIDEO LINK's profile
Friday
Mark Harrison left a comment on Moderators
"Wow, Ning2 looks really great on mobile. I had sort of drifted away as my browse-time went more on my phone, so this is great."
Friday
Hank Deucker left a comment on PIXHAWK
"I am sure most will say not again, Pixhawk telemetry. I do need help and all can be reassured that I have spent many hours scouring the net for useful information. I am not new at quadcopter flying, I started in 2012 and have progressed through many…"
Thursday
DIY Robocars via Twitter
https://t.co/rLmFr8M2UK
Thursday
Hank Deucker left a comment on PIXHAWK
"Tomorrow, I am thinking about the wording at the moment."
Thursday
DIY Drones via Twitter
Welcome to the new DIY Drones design!. You may have noticed that DIY Drones looks a little different today. That's… https://t.co/cg2EmeDGMQ
Wednesday
DIY Drones via Twitter
New! Online Training on Drones for Disaster Response https://t.co/brqRuujjY2
May 26
DIY Robocars via Twitter
https://t.co/8EMCvYW6oz
May 25
DIY Robocars via Twitter
RT @OttawaAVGroup: We are going to try something new this week. We will be having a drop-in style meeting Wednesday @ 7-9pm EST. Pop in and…
May 25
DIY Robocars via Twitter
RT @tawnkramer: Thanks Everyone for another fun virtual race! Amazing Ai racers competing head-to-head, Virtual Makers Fair event. Catch us…
May 23
DIY Robocars via Twitter
RT @make: Find out the latest from @diyrobocars at 10am PT from @chr1sa of @3DRobotics on Virtually Make Faire! #makerfaire #maketogether #…
May 23
DIY Robocars via Twitter
RT @Heavy02011: Join us Saturday online: Virtual Race League: @DIYRobocars Race #2 - Parking Lot Nerds https://t.co/aJUu4sdutx #Meetup via…
May 22
DIY Robocars via Twitter
RT @donkey_car: Yay, we are part of the virtual @makerfaire with @diyrobocars. Come see our race or better yet train a model and race with…
May 21
DIY Robocars via Twitter
RT @chr1sa: The @DIYRobocars Virtual AI Race is going to be part of the virtual @makerfaire on Sat! https://t.co/wnMDAboLID
May 20
More…