Neo M8N and Pixhawk, No GPS fix

Good afternoon everyone.
I recently finished my 3D-Printed X4 frame, and have installed all required (Pixhawk) electronics. Everything is working great, and I have done a successful test flight; But.. The GPS seems to be unwilling to work with the Pixhawk unit.
I am getting the "No GPS Fix" message on Mission Planner, even after leaving the unit outside for nearly an hour in an attempt to acquire GPS satellites. I have followed the manuals instruction, and I am certain I have proper connection between the M8N and the Pixhawk.
In the Mission Planner program terminal, I'm seeing a repeating "Need 3D fix" followed by code. I've also tried connecting via u-Center 8.2 and there is no GPS information whatsoever. I really am lost, and have been researching this since 8AM today. (Almost 12 hours..)
Does anyone have any idea what's going on?
Any help would be greatly appreciated.

You need to be a member of diydrones to add comments!

Join diydrones

Email me when people reply –


  • Did you try, on an open sky area see, moving your gps as far as you can from the copter? can you share a photo how is installed on your frame?

    • As stated in my initial post, I left the unit outside for over an hour. The positioning of the GPS in relativity to the frame is not the cause of the issue..

  • GPS_3.jpg



  • Do you see any lights flashing on the GPS? If so the RX and TX wires may be crossed in the connector. Finally you may just have a bum gps. I've spent most of my day troubleshooting GPS and telemetry issues just to come down to one wire in the connector not working.

    • There is a solid blue light displayed on the GPS.
      I've tried connecting via u-Blox's u-Center program, and the Packet Console tells me something alone the lines of, "Unknown", within lines of code. I would tell you exactly, but now it seems as if there is no information being relayed via the u-Center consoles..
      I've also talked to u-Blox directly, and he's just as lost as I am.
      The "processor" on the GPS is u-Blox, but the circuit board is unknown from some company in China. This is where it's difficult for him to asses what the issue is.
      In regards to the wire (plug) setup where it plugs into the Pixhawk, it looks identical to images I've seen online.
      It's difficult to see the connection on the circuit board itself, as for it's covered with glue. I'm about to take off that glue though, and check to see if there's anything suspicious.
      From what I've read, the M8N GPS unit is simply plug-n-play with the Pixhawk. I have no idea why this one isn't working, well, I do have somewhat of an idea; It's from China, and there's no quality control. They pump that shit out of the factory like pancakes, and not every board is perfect. Unfortunately, the Chinaman I purchased the whole bundle from has been unresponsive since I've given him the complaint about the GPS. The money really isn't a huge issue, seeing as these M8N's sell for $20-$50 on eBay.. But it's still irritating.
      I really appreciate your response Rob, and I would love to solve this problem.
      I've attached an image below, maybe it'll give you an idea with what I'm working with..


This reply was deleted.


Neville Rodrigues liked Neville Rodrigues's profile
Jun 30
Santiago Perez liked Santiago Perez's profile
Jun 21