Hi all,

New to the forum and quad building.

Recently finished my APM2 quadcopter build, with a 550 frame from one of those cheapo chinese sites.

Build went ok, got everything wired up, followed the instructions as best i could, manually calibrated each esc, set the quadcopter as level inside the house, house slab should be pretty good, so maybe not absolutely 100% level. Test flight outside in Stabilize(simple) mode, and it wants to fly back to the right.

I waited for GPS lock before trying. also tried without gps lock. I think my centre of gravity is pretty good, leveling was pretty good, as im new to this im unsure of where to start troubleshooting this.

Can someone please give me a bit of guidance as to where to go from here?

The only thing i noticed which may be out of the ordinary or not, with all 3 esc's manually calibrated, 3 of them seem to spin up and are in sync, the front left motor i think is in sync but when i turn the motors off the front left seems to stop spinning much quicker than the others. All motors are turnigy 2217 are have the same settings via the turnigy tuning card, no esc brake or anything, so not sure why that particular motor is different. Needs a recalibrate?

Hopefully someone can help!

Thanks in advance

You need to be a member of diydrones to add comments!

Join diydrones

Email me when people reply –


  • Ok, well I automatically recalibrated the esc's. Tried it out in the backyard with various results.

    There are glimmers of hope, hovers ok for a few seconds, then will start to drift. Tried auto trim mode but couldnt keep it within an area without hitting obsticles for long enough for it to autotrim properly. Windless night btw.


    I will try again tomorrow night out in the paddock so I have more room.


    Still not sure of the best way to get it 100% level.

  • Sorry for the typo.

    Yeah its a quadcopter, i meant to say 3 motors seem to spin up and spin down at the same rate, the 4th motor seems so spin up at the same pace, but stops a lot earlier than the other 3, so maybe its not running at the same speed.

    I will try and recalibrate that esc.

    I havent done the hand held test, I'll have a go at it tonight and see how it goes.

    I have read to cut the + & - wires to all but one of the esc's, to stop a ground loop, this is a pain to to calibrate the esc's again because i have to resolder the wires back together, Any better ways of doing this?

    Just to clarify, I don't need to worry about GPS lock to simply get it to hover in stabilise mode?

    Thanks heaps for your assistance, complete newbie here, but having a blast working it all out :)

  • Can I ask first... are you speaking about a Quad or a Tri copter, you mention only 3 esc's? If you are speaking of a quad (4 motor) and it is pulling in the opposite direction of where that motor is located, motor F.L. and pulling B.R., then that ESC may be un-calibrated. Have you done the handheld test to see if it trys to stabilize?

  • Bump, was hoping this would be simple enough for someone to give some guidance.

    Thx heaps!

This reply was deleted.