"No Heartbeat Packets Received" on Mission Planner

When I try to connect using mission planner versions 1.1.51 & 1.1.52 I get a "No Heartbeat Packets Received" box after the time out.

I don't have this problem with 1.1.50, have I missed something.

I am using Windows Xp if that makes a difference.

You need to be a member of diydrones to add comments!

Join diydrones

Email me when people reply –


  • Im having the same problem. It blinks 6 blue and 2 quick red. Anyone knows what the code means?
  • I just received my APM 2.5 and 3DR radio and I'm having the same error...In MP 1.2.5 mav 1.0, in "Configuration/3DR radio", I can "load the settings" and I get data for the "Local" and the "Remote" but can not connect. I'm selecting the right port and rate. What am I missing...


  • I am not too sure what the problem is but i would connect the receiver and the PDB. Power these too first, and then plug in the USB. Try to connect this way. What do you need terminal for though?
  • I am still trying to use the latest version of Mission planner (now 1.2.1 Mav 1.0) with my 1.4 board as the 1.50 version is a bit less polished. Here's what happened


    - Mission planner 1.2.1 Mav 1.0 (from July 29)

    - I have the SM2 slider set away from the pins (toward position 1).

    - I am connected through USB connection on comouter to mini USB on board

    - I am running Windows7 (64 bits). The radio and PDB are not connected to the APM board. The GPS is connected.

    - connected at 115200 baud and com3

    1) I can go to firmware, and upload Arducopter V2.7 Quad (I have a quadcopter). This works fine

    2) when I go to Terminal, it shows in the top right corner that there is a connection (connectors connected, and "disconnect" under this). In the terminal window it then shows

    0pened com port

    Init Arducopter V2.7

    Free RAM: 1501

    FW Ver: 118


    load_all took 524 us

    3) whatever  I type in this terminal window, I get no response

    4) if (in this window) I disconnect, and then connect again, I get the connection timeout message (no heartbeat)

    5) If I go to Configuration -> Planner and toggle "Reset APM on USB connect" this does not make any difference (I tried with and without this on


    I'm really stuck here & any tips will be appreciated



  • in my case what worked is unbricking the xbees

  • Moderator

    I've successessfully used a FTDI cable[1] to install Simulation Quad HIL to APM 1.4. But when I try to connect, I'm also getting "No Heartbeat Packet Received". 

    Now when I use a IMU + mini USB cable to connect to the same APM 1.4 it works fine. 

    Would this be a result of a bad FTDI cable? I'm puzzled since same FTDI cable installs firmware without an issue. 



    [1] http://www.sparkfun.com/products/9717

  • We have a 1.4 board, and have the same issue with mission planner 1.92 not working (ie not connecting and giving a No Heartbeat Packets received after the connection timeout). I downloaded and used mission planner 1.50, and this seems to be doing fine (but I just barely got this going). I am wondering if there are any patches/solutions which I can use so I can use 1.92 and future upgrades

    Thanks in advance - my son and I  really appreciate the mission planner code and all the work put in to this


  • 3D Robotics

    Tom, the MP is now at 1.1.58. It should be updating automatically when you load. Is that not working?

  • hello,

    this is happening to me as well, if i restore back to version 1.1.50 it works fine any version after that i cannot connect.




  • You just need to download the old version from this link and extract it on your desktop. However, if you click upgrade it will replace the files in that folder only. You can different versions of the software. However if you upgrade the program the folder will still show the old version. But when you start the program you see the latest version. So when you redownload 1.1.50 or 1 don't upgrade. http://code.google.com/p/ardupilot-mega/source/browse/Tools/Ardupil...
This reply was deleted.


Gremsy liked Gremsy's profile
Mar 12
DIY Robocars via Twitter
RT @chr1sa: Donkeycar 4.4 released with tons of new features, including path learning (useful with GPS outdoors), better Web and Lidar supp…
Nov 27, 2022
DIY Robocars via Twitter
RT @NXP: We are already biting our nails in anticipation of the #NXPCupEMEA challenge! 😉 Did you know there are great cash prizes to be won…
Nov 24, 2022
DIY Robocars via Twitter
RT @gclue_akira: レースまであと3日。今回のコースは激ムズかも。あと一歩 #jetracer https://t.co/GKcEjImQ3t
Nov 24, 2022
DIY Robocars via Twitter
UC Berkeley's DIY robocar program https://roar.berkeley.edu/
Nov 24, 2022
DIY Robocars via Twitter
RT @chr1sa: The next @DIYRobocars autonomous car race at @circuitlaunch will be on Sat, Dec 10. Thrills, spills and a Brazilian BBQ. Fun…
Nov 24, 2022
DIY Robocars via Twitter
RT @arthiak_tc: Donkey car platform ... Still training uses behavioral cloning #TCXpo #diyrobocar @OttawaAVGroup https://t.co/PHBYwlFlnE
Nov 20, 2022
DIY Robocars via Twitter
RT @emurmur77: Points for style. @donkeycar racing in @diyrobocars at @UCSDJacobs thanks @chr1sa for taking the video. https://t.co/Y2hMyj1…
Nov 20, 2022
DIY Robocars via Twitter
RT @SmallpixelCar: Going to @diyrobocars race at @UCSDJacobs https://t.co/Rrf9vDJ8TJ
Nov 8, 2022
DIY Robocars via Twitter
RT @SmallpixelCar: Race @diyrobocars at @UCSDJacobs thanks @chr1sa for taking the video. https://t.co/kK686Hb9Ej
Nov 8, 2022
DIY Robocars via Twitter
RT @PiWarsRobotics: Presenting: the Hacky Racers Robotic Racing Series in collaboration with #PiWars. Find out more and register your inter…
Oct 23, 2022
DIY Robocars via Twitter
RT @Hacky_Racers: There will be three classes at this event: A4, A2, and Hacky Racer! A4 and A2 are based around UK paper sizing and existi…
Oct 23, 2022
DIY Robocars via Twitter
Oct 23, 2022
DIY Robocars via Twitter
Oct 19, 2022
DIY Robocars via Twitter
Oct 18, 2022
DIY Robocars via Twitter
RT @NeaveEng: Calling all UK based folks interested in @diyrobocars, @f1tenth, @donkey_car, and similar robot racing competitions! @hacky_r…
Oct 13, 2022