Not entering long failsafe

Hey guys, been searching but I haven't found the answer yet. 

I have the latest (to date) firmware of arduplane. I have the failsafe throttle point at 800 PWM. OpenLRSNG Rx is set to stop sending PPM on failsafe (going to adjust that soon and make it send 0 and also send the RTL mode PWM on the mode channel, not sure which will take precedent).

When I power off the Tx, the throttle goes to 0 as it's supposed to APM goes into short failsafe.. Loiter mode. I can wait forever and it never changes into RTL for long failsafe. I set the long failsafe to 10 sec just to speed things up. I have not yet gotten it to go into long failsafe, from any mode. 

Does it have to be armed for faisafe to work properly? I am trying to bench test here and can't necessarily arm throttle. 



...Also this board has way too many categories for way too few posts, wasn't sure where to put this.

Thanks for your help guys!

You need to be a member of diydrones to add comments!

Join diydrones

Email me when people reply –


  • Ok not 100% sure what I did to make it work, but I did. now it goes into CIRCLE instead of LOITER on short failsafe and then goes into RTL. 

    Originally I had the Rx set to stop sending PPM on failsafe, and all the individual channel failsafes were just disabled. I suspect the APM was seeing the mode channel go to minimum and changing the mode to Loiter. 

    What I did was set my mode channel to go to RTL PWM, which happens to be max PWM for that channel, then I set my Throttle channel to go to 908us PWM, the lowest OpenlrsNG would let me. 

    I set the THR_FS_VALUE to 1000, then just eased the throttle down, sure enough it went into CIRCLE then RTL

    I powered off the Tx, same result, CIRCLE, RTL

    Then I unplugged the Rx from power, same result, CIRCLE, RTL. 

    I am pretty sure the real problem is the Rx was setting PPM to 0 or stopping it (can't remember), but not PWM, I probably should have checked that box too. Either way, it was changing the mode and not doing what it was supposed to. Working now.

  • Hi, it is same issue i had on my craft with 3.2 on apm fc. I set failsafe to simple land command. I turn off transmitter and bird keeps hovering.

    What exact options combination is required for a reaction to throttle cut off to be instantiated?
    • hovering ? , ArduPilot does not do plane hover yet  :)  post in arducopter forum, with a short log where you reproduce.

      Also , ArcuCopter hovers for 10s at 10mAGL before starting LAND, but you know that ?

  • What about GPS fix ? You can't expect RTL without
    • hmm, good call, I think it had a gps fix when I was testing but I'll try again!. I was definitely disarmed though, but since it went into short failsafe I figured being disarmed wasn't the issue. 

      • Ok just tried it again and had 3D fix but still just hung in Loiter mode and never went to RTL.

        • for what it's worth:

          Today I were fine-calibrating current sensor on a new plane, tried it - and it worked fine - 20s after "short" , mode changes to RTL, no arming required, (current stable ArduPlane build)

          BTW, I checked out the code, it will set mode RTL anyway, if GPS is no good, it will do something else, but mode will be set to, and displayed as RTL.

          • Hey thanks, that helps! At least I know it should work. 

            One thing that's a new odd behavior is when I power the entire system up, with the LRS Tx on, the APM goes straight into RTL mode, even thought the mode switch is on Manual position. I toggle the mode to Stabilize and back to Manual and it goes into Manual. I don't think this is related, but it's odd for sure. 

            What are your settings for 

            FS_SHORT_ACTN, and FS_LONG_ACTN? I haven't experimented with changing them yet because, according to the documentation, I have them set correctly.

            I'm definitely going to set an Rx failsafe to put the mode channel to the RTL PWM, that will at least save me if signal is lost, but if the Rx browns out, I'm still getting a plane loitering until the battery dies.

            • both were at default (1)

              also, make sure your PPM actually disappears, (all rc goes to zero)  - in case it's maybe in a failsafe position. (even I've read you set it to do so.)

This reply was deleted.