Only 1m range with 433Mhz telemetry set REOPENED!

Hi, i just read a topic about this which was closed.

I have the same issues, 1 meter range with the 433MHz telemetry and it only connects intermittently. I am using the 3DR radio absolutely stock.

Ground station is a Acer Aspire One with an Intel Atom processor.

Any ideas? Its really annoying my quad keeps falling from the sky as i have no idea on what my batt voltage is!

Thanks!

Views: 9941

Reply to This

Replies to This Discussion

Hi Dean,

post a tlog showing the 1m range test, plus post the settings shown for your radios in the mission planner.

The tlog should tell us if the problem is noise or signal strength.

Cheers, Tridge

Andrew, thanks for your reply.

Here is a log attached. I just imitated it in my room and there was NO loss in communication this time (typical).

And heres thee screenshot

Thanks!

Attachments:

Why not be belt and braces about battery life, use your TX timer if you have one or watch. I use one of these http://www.pyramidmodels.com/shop/product.php/979/2_in1_lipo_batter... when flying whirley things.

Relying on data links is perhaps not best practice.

I know, and i have fitted a very similar audible battery indicator but had LEDs instead of the LCD.

But, when im flying at distance, with FPV etc, i cant hear it ;)

Thanks!

Hi Dean,

The problem is the noise levels on the ground radio. Have a look at this graph of your log:

The ground noise (blue line) is much higher than the air radio noise (yellow line). So what you need to concentrate on is why your PC is generating so much noise in the 433MHz band. This noise is swamping the signal from your radio.

The most likely cause is the USB bus, which (depending on what it is doing) often operates at 480MHz.

There are a few ways of reducing the impact:

  • try a different PC or laptop
  • try running the radio via a USB hub, preferably an older hub that only does the older USB 1.1 "full speed" (which runs at 12MHz)
  • try changing your PCs USB bus settings to select USB 1.1 full speed only (I have managed to do this under Linux on one laptop, but I don't know how to do it on Windows)

Note that the 3DR radio only uses the 12MHz "full speed" mode, so it doesn't need the newer 480MHz "high speed" USB bus, but if the bus is enabled for high speed it can produce a lot of noise near the 433MHz frequency of the radio.

Cheers, Tridge

Thanks Andrew, i check the BIOS for reducing the USB power and possibly try another laptop if possible.

Ill post back with results.

Thanks!

Hi Dean,

Any update on this? I have the same issue, my 433MHz connects intermitent and range is short also.

What solution did you adopt?

Tx, Chris

I got a new 915 telemetry. There was a failty batch of 433 that came out

Tx for reply. I can not use 915 Telemetry, since I have my VideoTX at same frequency.

What do you mean by " failty batch"? 

Hi Tridge,

I have same issue with a very short range on my 433MHz telemetry, like 8-9m.

Comparing to Dean, my ground noise (green "noise") is not higher than air noise (violet "remnoise").

But it looks the "remnoise" is comparable with "rssi" or "remrssi".

Do you know what would be the reason for that?

I did try different TX Power, from 11 to 20 (on both 433 modules), but range is like 9m, not more.

Thanks,

Chris

Improved noise level on  rctimer 433 Mhz USB ground radio

In general it worked for me but I could not accept that the 433 MHz USB Radio is worse than the 915 MHz.

The picture before improvement:

 

Accidently I removed the antenna during testing and saw how the noise went down. My conclusion was the noise coming from the USB chip will be inserted through the receive path. I covered the whole device with aluminum and reduced the noise.

After the improvement:

 

The Ground Radio:

 

The Copter:

Good tip, thanks.

Why did you replace your 433 stock antennas with a wire?

What is the length of the new 433 antenna?

Reply to Discussion

RSS

© 2019   Created by Chris Anderson.   Powered by

Badges  |  Report an Issue  |  Terms of Service