Hey Everyone,

I'm just looking for some help on a problem I recently stumbled upon. I have been using a Pixhawk 1 with ArduCopter v3.3.3 and a Futaba R7008SB RC receiver for some time now with no issues.

I recently purchased a Pixhawk 2.1 and have not been successful configuring it for flight yet because I cannot perform an RC radio calibration with the R7008SB. I have tried AC v3.4.2, 3.4.5, and 3.4.6. When I open the radio calibrator in mission planner (I have tried Mission Planner v1.3.36 and v1.3.48), the channel bars have no green at all, as if they are not getting a signal from the receiver.

To me this hints that the Pixhawk 2.1 and listed firmwares are not compatible with the Futaba R7008SB. I have verified that the transmitter and receiver are both working. I am plugging the receiver into the RC servo port on the Pixhawk 2.1.

Has anyone run into this issue? My next step is to try a Spektrum receiver but I would really like to stick with the Futaba if possible.

Thanks for any help or insights you guys might have!

Views: 190

Reply to This

Replies to This Discussion

Here's an update.

I scrounged up a Spektrum satellite receiver and it works without a hitch. It definitely seems to me like the Futaba receiver isn't supported by the Pixhawk 2.1 and the newer firmwares.

Can anyone help me confirm this?

Thanks

Paul,

Thats an sbus rx, right? plug into the sbus port. Ive been using a spektrum satellite rx on my PH2.1 with no problems. Range may be an issue though.

     -Jon

Reply to Discussion

RSS

© 2018   Created by Chris Anderson.   Powered by

Badges  |  Report an Issue  |  Terms of Service