Pixhawk doesn't lift

Hi!

I have a tricopter that was flying just great last week. After i mounted a 2 axis gimbal it didn't want to fly. The motors were spinning ok. It's not too heavy, the motors can lift much more than that. The estimated motor+prop thrust for my tricopter is somewhere around 2.6 kg and mine is just 1.7 kg with the gimbal.

It seems it just lost power, it just doesn't want to lift off the ground.

Is it just me who has this problem? Has anyone solved it?

thanks!

You need to be a member of diydrones to add comments!

Join diydrones

Email me when people reply –

Replies

  • Might be a stupid question but are the props the right way round and the motors still spinning the right direction?

    • Joseph E. Monroe, sorry but I don't have an easy fix. I ended up changing the flight controller to hkpilot micro and the escs. Now it flies fine again. I still don't know why it did that...
      • Sorry to hear that. I think I'm almost at that point also. Thanks for the quick reply.

    • Yes. It lifts itself about 20-30 cm but that's all. If the battery is full it lifts itself 1-1.5 m for about 1 min but then the motors get hot and it starts to lose altitude. Now i'm thinking it's the esc timing. I recalibrated the escs but nothing changed. I'll reflash them later today, if i have enough time.
      • Did you ever solve this problem? I'm have the exactly the same issues. Please let me know how you solve this.

  • You're too heavy.

    2:1 thrust/weight ratio is the barely minimum acceptable for safe hover.With 3:1 ratio you can fly OK, with some sluggish recovery from sporty maneouvers when the LiPo is almost empty.

    • Not quite, even with this ratio it should still fly, not for long, but it should...

      I removed the gimball, still doesn't fly. I repeat, without the gimbal it flew a week ago...

      Checked THR_MAX and it's ok, it's at 1000, everything is ok.

      I don't know why it just doesn't want to fly. I'll try a factory reset and see what happens...

      i'll upload a log photo...

      Screenshot 2014-08-05 16.16.26.png

      https://storage.ning.com/topology/rest/1.0/file/get/3702509255?profile=original
This reply was deleted.

Activity

Liam left a comment on Agricultural UAVs
"Hi
I'm Liam from T-MOTOR. I would like to reach out to see if there is any possibility for us to work together.
We are a propulsion system manufacturer who offers motors, propellers and ESCs for all kinds of drone applications which vary from secur…"
Jun 30
Richard Cox left a comment on Australia
"Anyone in the DIYDRONES Australian subgroup based in Alice Springs, NT?
I am experimenting with Ardupilot (standard Arduplane), Pixhawk 4 FC in a 4-ch
RC "AXN Floater Jet" foamy plane..."
Jun 29
Omar Sykes left a comment on Australia
"Hi everyone, I am looking for someone who is good at drone building, repair and software in Adelaide. Please give me a call on 0477 319 219."
Jun 29
More…