Pixhawk esc calibration and low avionics voltage

Hello drone experts!I'm building a x500 readytosky kit.Lots of small issues getting started but finally attached esc and motors to autopilot to do all in one calibration.The ESCs are cheap readytosky simonk 30A.Firstly I couldn't follow the throttle up- disconnect+reconnect battery-safety switch-throttle down instructions from many videos and manuals.It seems I am not getting my pixhawk into calibration mode, maybe transmitter signal is not a high enough max or pixhawk is not getting the message.I did succeed with one by one calibration with the TX and RX straight to esc, and used qgroundcontrol usb calibration setting.I can arm the copter with safety switch and TX arming switch, and the motors all turn fine (maybe not turning quickly but I don't know until I install the props)However qgroundcontrol gives a low avionics warning message: 4.81v so it appears the pixhawk is not getting enough from the power module.Power module was supplied as part of the readytosky kit, xt60 to 3s battery, 6pin cable from regulator to pixhawk, xt60 to pdb.When I power the pixhawk from an ESC the voltage is lower, about 4.4v, and the Rx confirmed 4.4v while calibrating escs.When I power from usb cable the pixhawk also complains about low voltage.I have calibrated the battery but not had a serious attempt to change amps per volt setting ( I did enter some other values to see if I could affect to avionics voltage but it didn't change and that's probably cheating!)Anyway, I think I might be able to fly on 4.8v but it's worrying me.Should I try to reset pixhawk by holding safety switch while powering then recalibrate while powering off a battery rather than usb?

You need to be a member of diydrones to add comments!

Join diydrones

Email me when people reply –


  • 4.8V are pretty enough to have a stable operation of pixhawk. See here: 


    i run one of my Copters with stable 4.6V without any issues (i.e. brownout).

    powering the cheap China Pixhawk clones from the output rail is difficult as there is a voltage drop of around 0.7V because of different construction compared to original 3dr pixhawk ( cost savings :-) ). They isolate the power input via a diode. That is the reason why you only see 4.4V.

    Powering the Pixhawk — Copter documentation
  • 1.5.5 did not work, so I tried changing firmware to Ardupilot and had a result!
    I think the px4 interface in qgroundcontrol was a little more user friendly, that's why I was focused on that.
  • Thanks for the reply, I couldn't contact the pins on the power module with my probe but I tested the esc's bec at 5.01V

    I am trying to downgrade my ps4 firmware to 1.5.5 because there is a post that says it fixed the problem.
  • Do not fly on 4.8v , it would be dangerous.
    Use a multimeter to verify that you have good voltage on both 5v supply.
This reply was deleted.