PixHawk failed startup

Been flying my quad with the 3.1.4 firmware without any problems but today I had a failed startup

#1 Failed startup sound

#2 Safety switch LED is blinking fast

#3 Large LED is off

#4 Right bottom green LED is on steady

#5 Lower left red and blue LED is flashing

#6 MavLink will not connect

I tried both reset buttons with no luck and then tried to install an earlier firmware version but got the cannot connect message with no heartbeat, Tried the Force PX4 Bootloader with no luck and also could not connect with the terminal. I tried removing the SD card and that did not work but I did a fat32 format and that worked, I'm thinking that there may be a problem with the pixhawk writing data to the card as the battery is unplugged so part of the data is missing that will cause the failed startup, I'm replacing the stock SD card with a class 10 SD so maybe data can be written faster.

I'm new to all of this so I maybe way off course to the real problem but this is about as far as my brain can go and would like any advice 

You need to be a member of diydrones to add comments!

Join diydrones

Email me when people reply –


  • Did you ever figure this out? I have the same issue. I formatted the SD  card and it kind of came back except I still can't connect via the usb port I can only connect via radios

    • Never have, now I keep a formated card in my pocket while flying, To keep the micro sd card from being lost I have it taped in a SD card adapter and that taped to mini needle nose that I use to change the card with.

      Try connecting the USB cable without the pixhawk being powered up, if you still can't connect and if you are running windows 7 go to your device manager and under com ports go to the top of the screen and click on scan for new hardware, unplug and then plug your USB cable back in while its scanning, it should see it in a few secs and give you a new port


    • Admin


      Have you tried holding the arming switch down at start up to force the IO firmware to be loaded?

      Also, how are you powering the Pixhawk? It is best to use a powered USB Hub if you have a full up Pixhawk with the telemetry radio attached.


      TCIII AVD 

      • The first time this happened I tried everything and then did everything 3DR suggested, they thought I had a bad PixHawk and was going to send me a new one, Something told me to try a new sd card, I did and that fixed the problem for about a month and same thing happened, this time I formated the card and all went well. This has not happened but maybe 4 or 5 times in close to a year so I have not bothered trying to figure this out 

      • @Thomas thanks for replying.

        It was working fine. I took it out for a flight to gather logs and when I came back in and plugged it into my PC it wasn't even detected. Safety switch was blinking like mad. I removed the SD Card and formatted it and then plugged it back in holding the arm switch. I let it sit forever and then it made some like Morse code sound out of the buzzer and about 3 minutes later it came back to life sort of. I can't connect to it at all with no radio connected and can only connect to it via radios now :( Right now nothing is connected to it except the speaker/safety switch/radio.

        If I disconnect the radio then mission planner will not connect. Hangs forever and then times out.

        I've tried powered hubs. Different Cables and Different computers and a combination of all 3 and the same results on all :(

This reply was deleted.