Apologies if this has been asked before.

I am trying to setup a new pixhawk via Mission Planner 1.2.97 . I have a FrSky Taranis radio  with the  8XR receiver and followed an online video to setup the flight modes.

The radio signal is recognised and calibration works fine with the 3 position SG switch on channel 5 and the SF 2 position switch on channel 7.  When I then go to flight modes nothing happens when I move either of these switches.

I noticed on the video that the output above the modes appears to look at channel 5 ( as expected), on my readout it appears to be looking at channel 8 ( so there is no surprise that nothing happens!).

Did I miss something?  Have the default channels changed for pixhawk?

I am completely new to this and the quick start guide is pretty useless.

Thanks in anticipation of your help.


You need to be a member of diydrones to add comments!

Join diydrones

Email me when people reply –


  • Hi there, I am having the same issue, i am trying to set up the flight modes but i can not get it to work. 

    I have a calmato trainer (fixed wing aircraft) with pixhawk. I went through radio calibration but i do not know how to set up auto-manual switch on my transmitter. 

    I am using a spectrum 2.4 receiver bound to JR DSX 11 transmitter. During radio calibration; i have movements on roll, pitch, yaw, throttle, radio 5 ( moves in two positions 1046 and 1849),  radio 6 (moves in 3 positions i highly suspect it is flaps; i have connected ailerons seperate with one connected to main port 1 and other to port 6) 

    No movement on radio 8 (but full green bar is there) and on radio 7 (half green and no movement) 

    any help on this please. 


  • Ahah - that would do it. I am setting up a plane. Many thanks, I will give that a go tomorrow (it is nearly midnight here and I am not at my best when I am tired!)

    Where was I supposed to see that information? Surely this should be in the quick start guide. The video I found via this site does not indicate whether they are setting up a plane or copter.

    Does this also effect the channel for the RTL switch?

    • 3D Robotics

      Are you following the instructions here?

      • Thanks Chris, the information at that location needs a little work, especially now we have the pixhawk (I do realise these things take time, so that is not intended as a criticism). I don't have a copter, so I do not understand why these would need to be different and it did not occur to me that they would be!

        Anyhow I have everything working now with the flight modes switching on ch8 (mixed in with a ch7 switch) and have added appropriate vocal notifications. I will play with this until it becomes second nature to get what I want.

        Next I guess will be the tuning for my Finwing Penguin (my interest lies with stereo aerial photography for mapping purposes).

        Despite these teething problems, I am enjoying the experience. 

      • How do I arm the pixhawk for with arduplane firmware ?

        I am using Pixhawk for Skyhunter 1800 mm plane. I have installed latest Arduplane 2.78b firmware. I am using Spectrum DX7s transmitter and connected to Pixhawk via DSMx. I could see all stick movements when I caliberated my Radio, but I couldn't figure out how to arm it and get the motor and servo working.

        • 3D Robotics

          Have you installed and pressed the Safety Button (so that it's solid red)?

          • Yes, I did. I pressed the safety switch and then I tried to arm by moving Throttle stick to bottom right but the red light on safety switch didn't go solid.  

             This also depends on the firmaware as well, right ? because when I used Arduplane firmware on APM 2.5, there wasn't any need to ARM. The Arming/Disarming was required only in Arducopter, I belive.

  • 3D Robotics

    Are you doing a plane or copter? Mode switching is typically CH 5 on a copter and CH 8 on plane

This reply was deleted.


Laurie J. Troy liked Jasper Kueppers's profile
Apr 1
Timothy Miller liked Joseph Udofia's profile
Mar 18