Pixhawk Left roll

After calibrating the gps and accel several times I still have a left roll on my quad, I run a Taranis tx with a X8R rx on 4S battery. I was told that my compassmot was not set correctly but after several resets it still moves left with the right stick centered. And I have re-calibrated my radio many times over. Any other suggestions before i smash this crappy thing.

You need to be a member of diydrones to add comments!

Join diydrones

Email me when people reply –

Replies

  • Hi Bobby, I have been looking at your log and other that not being tuned well, I don't see a problem. I did notice that you only flew in stab or althold. I also see that you heading was constant. If you are constantly applying stick input more or less in one direction, its just you fighting the wind. Have you tried loiter mode yet ?

    APMCopter is not a crappy thing. Thousands of users are totally happy with its performance and I am one of them. Go to a large open area on a calm day and try loiter mode. I think you will be supersized. You will get there, don't give up. Also there is no such thing as a GPS calibration, do you mean magnetometer ?

    • I meant the compass calibration. And yes I have tried loiter mode and it did hold pretty nice. I think that some of my problems are from vibrations and I have a pixhawk anti-vibration mounting base on order now. I"m going to remove the pixhawk and mount it onto the new base mount. Then I'm going to re-calibrate everything over again from start. And if my stable and altitude hold modes are as good as this time around I will take it out and do an auto tune flight and see if thing get even better. But it does hold fairly nice in loiter.

      • I just checked your vibes (accel noise band with) and it is excellent. It's better than my quad and I have very carefully balanced props. If you used the foam mounts that came with the PH then your fine. I wouldn't change a thing. Open your .bin file with Mission Planer with the "Data Flash Logs" button and click the "Review a Log" button and you should see the logs you have downloaded. When the file opens you will see all the various data to choose on the right. Click the box for what you want to graph. Play with it and you'll figure it out. I don't think you have any problems. Do an autotune on a calm day. Read the wiki again before auto tune. It can take a while so just do roll pitch first and then do yaw. Every thing you need to know is in there. Be patient and be prepared. Don't be in a hurry. I have been flying my first quad (650 Tarot with 15" props) for almost a year now and have never had a crash. Be safe and have fun :)

        • I am using a piece of memory foam I got from an upholstery shop. And I thought that I was getting too much vibration from it off the frame. But I guess its better than the foam from 3DR then. Yea I did not get to do an auto tune the first time around but I will do one this time. I was really trying to get the first 3 modes down pat before moving on to another mode. Then if the vibrations are good I will keep the foam in place.

  • Ok, from the logs I didn't see anywhere where you had the sticks level.  I do see that motor 3 is running a little harder than the rest which should cause the copter to lean right.  You say it goes left so it could mean that the copter is heaver on the left or the wind is blowing against it.  In either case I don't see the issue.

    • Thanks for the help and your reply

  • That sounds good.  Will need a log of the flight then to check a few parameters for issues.

    • Not sure how to get a flight log but I will try and see what I can do. I have just completely reinstalled everything from MP to the latest FW and I hope to get a good test flight today.

      • I have an 9XR Pro radio with X8R receiver and it works great on my quad copter.

        To get the log you need to connect using a USB cable and then from Mission Planner on the HUB menu select Data Flash Logs from the buttons in the bottom section.  Then select Download Data Flash log via Mavlink.

        • Yes I have done that and I get a bunch of files that say 1.BIN thru 65.BIN that I can't open of upload to this site.

This reply was deleted.

Activity

DIY Robocars via Twitter
RT @_JonMyer: 🚨Attention DeepRacer's including #UndergroundDeepRacer🚨 Check our our LIVE stream that including @IAM_dbro Take a few moments…
Wednesday
DIY Drones via Twitter
RT @MarvelmindMaxim: Extreme precision for 60 swarming robots. #marvelmind #autonomousrobotics #robotics #swarmrobotics #rtls #ips #indoor…
Aug 3
DIY Drones via Twitter
RT @MarvelmindMaxim: Precise (±2cm) tracking for racing boats and autonomous boats. Works outdoor and indoor. #autonomous #AutonomousVehic…
Aug 3
DIY Drones via Twitter
RT @MarvelmindMaxim: Helping PixHawk folks to fly autonomous quadcopters using PX4 and ArduPilot. https://marvelmind.com/drones/ Equally suitab…
Aug 3
DIY Robocars via Twitter
RT @chr1sa: The @DIYRobocars @donkey_car virtual AI car race is starting in 15 minutes! Watch it live on Twitch https://www.twitch.tv/mossmann3333 htt…
Aug 1
DIY Robocars via Twitter
RT @chr1sa: Don't miss our monthly @DIYRobocars @donkey_car virtual AI car race tomorrow at 10:00am PT live on Twitch. Head-to-head racing…
Jul 31
DIY Robocars via Twitter
RT @sparkfun: Our completed tutorial on building an @NVIDIA Jetson Nano-powered @Sphero RVR gets your bot up and running via teleoperation…
Jul 30
DIY Robocars via Twitter
RT @SmallpixelCar: Freeway test https://t.co/4V5tV9lhIP
Jul 29
DIY Robocars via Twitter
Very small autonomous cars racing, thanks to an overhead camera: https://control.ee.ethz.ch/research/team-projects/autonomous-rc-car-racing.html
Jul 29
DIY Robocars via Twitter
Jul 29
DIY Robocars via Twitter
Jul 29
DIY Robocars via Twitter
RT @chr1sa: Don't miss our virtual AI car race this Saturday! Real developers + virtual cars =🏎️🏎️🏎️ Head-to-head battles with thrills, sp…
Jul 28
DIY Robocars via Twitter
Jul 27
DIY Robocars via Twitter
RT @usashirou1: Jetson nano by Isaac Kaya #jetson https://t.co/Mu1N0CyQkN
Jul 23
DIY Robocars via Twitter
RT @GPUsolution: JetRacer mady by Iflytek company #JetsonNANO #Nvidia https://t.co/MimTymIwge
Jul 23
DIY Robocars via Twitter
RT @openmvcam: I love this: Mega or Mini? Image Classification on the 1MB OpenMV Cam H7 by Ish Ot Jr. in OpenMV, Edge Impulse, Internet of…
Jul 23
More…