Hello All,

I have a Pixhawk, a Taranis X9D, and a FrSky X8R and my question is has anyone made this combination work?

My second question would be that if you have made this combination work on your Pixhawk, how did you make it work specifically?

I have a 3DR Y6 and I've been flying it with an APM and a Futaba Tx/Rx combination but decided to upgrade and have nothing but trouble with this setup.

I have installed all of the hardware and have connected the Pixhawk to the Rx using either the regular method and via the SBUS/RC slot input but haven't gotten it to work yet.  The Tx/Rx binds successfully but when I got to do a radio calibration either all of the inputs are blank (no green bars) or there are green bars but they don't move when I attempt to calibrate.

Can somebody please explain to me exactly what I need to do to make this combination of parts work?

Thanks!

-Mike

Views: 19870

Reply to This

Replies to This Discussion

Mike, I'm using this combination EXCEPT for a slightly different FrSky Rx (D8R-XP), but I think the basics will be similar. What you may be missing - as I did for a while a short time ago - is the need for a jumper across two of the signal pins of the Rx outputs, probably channels 7-8 or 3-4. Check the sheet that came with the Rx (and a jumper should have come with it too, if not you can make one by moving one pin of a binding plug over to the middle). Meanwhile, your cppm out from the Rx is probably channel 1 (not the S-Bus) and the other end of that goes into the Pixhawk slot on the far left, marked RC. Mind the polarities. You may also need to change the "Mode" setting in the Taranis radio setup menu, I think it should be D8 but if not just experiment. Use the Mission Planner radio calibration page as you've been doing to see when you've got this all right. Hope this helps.

Oliver,

 

Thanks for posting! 

I had been messing around with the jumpers and the settings in the radio and kept coming back to the thought that I'm over complicating it. :)  Thanks for the reassurance that I was doing the right things but just have to keep plugging away at it.

I also posted over on the APM forums and picked up some more tips there.

I haven't gotten it working yet but I also haven't had much time to play around with it since I posted. 

Thanks again!

 

-Mike

I've got my X8r connected to my Pixhawk from the SBus out port on the X8r to the RC Port on the Pixhawk. I've got the Taranis in D16 mode with Channel Range 1-8. (I hope to utilize channels 1-16 but I've not figured out how to configure that on the arducopter side of things yet. CH16 utilization would be nice. )

I'd also really like to know if the Pixhawk is really sending data back to the Taranis over the single sbus connection, or if I need to connect some output on the pixhawk to one of the other ports on the X8r to get true telemetry and battery condition sent back.

Stone. Get the Taranis in D16 mode and bind with the X8R in either Mode 4 or Mode 5 (instructions in the X8R leaflet or pdf). Get to the mixing table and start defining CH1-4 as AETR and add a switch or mix of two swithes to CH5, a pot on CH6 and a couple more switches to CH7&8.

Then install a cable between the SBUS output of the X8R and the RC port of the Pixhawk, making sure the pins are in the right order and go do the calibration. The setup is plug'n'play. Make sure to use the RC port on the 'hawk and not the SB one, because that's an output. Also SBUS on X8R and not S-Port because that's the telemetry port on the receiver. Pretty annoying naming on both the receiver and FC if you ask me :)

 

William, thare's a Pixhawk Mavlink to FrSky S-Port converter using a Teensy 3.1 board being developed by Rolf. See this thread:

http://www.diydrones.com/forum/topics/amp-to-frsky-x8r-sport-conver...

Hi... i have exactely the same setup and it works flawlessly. Check the radio mode (D16) in the radio menu, rebind the receiver using the jumpers provided with it (only in binding procedure, after that they can be removed) to set it in D16 mode, i use the mode in which i have 16ch on sbus and ch 9-16 on the 8 pwm pins, this way the pixhawk willl take the first 8 channels and everything you might want to add can be connected directely to the pwm pins of the receiver for channels 9-16. Also be careful that the sbus cable coming from the receiver (sbus port) has to be connected on the pixhawk pins labeled rc, not those labeled sbus; rc is the input port and sbus is the sbus output not yet implemented, but you can use it to connect another cable from the rssi port of your receiver to it, then in MP set the rssi pin to 103 and rssi range to 3.3 volts, then you'll have the pixhawk to also read rssi from the receiver.

Go through the manuals nd it will work!

hi, funnily I have the exact same setup (X8R, mode 4 connected to RC, Taranis in D16 using Ch1-CH8) and I have no communication at all with the Pixhawk (RX is binbded to the Taranis, and X8R works fine when connected to a Naza). For the moment I just defined AETR channels, no switches, and the pixhawk is just on my desk, no copter.
What Am I doing wrong? (even tried with Beta 3.2RC2)

Luc,

Not sure what you're doing wrong as I still haven't gotten this to work!  Works great when I replace the Pixhawk with my NAZA

I rolled back to my APM and Futaba setup and stopped using Pixhawk.

I occasionally get all of the associated PIxhawk pieces out and try but so far I have not been able to find the magic combination.  I uploaded the latest beta code as of Sunday (5/25/14) but nothing has changed.  I still get the exact same results as what you have pictured.

There is another thread here:  http://diydrones.com/group/arducopter-y6-owners-group/forum/topic/s...

It has a lot of good information but I have not yet tried walking through the steps outlined here though.

-Mike

All of the S.BUS variations should be working in plane 3.03. There are some S.BUS setups that are not supported in copter 3.1.x but they are in the current Copter beta

Also the SBUS label on the Pixhawk is a bit confusing.  The signal on that pin is S.BUS OUTPUT not INPUT and we don't have S.BUS output code written yet.  Make sure you connect the S.BUS from your receiver to the RC input pin.

Thanks for that info, so definitely I am not the only one. Why do some succeed with this config, others not?
Thanks craig,
As mentioned in my original post, i have connected the x8r mode 4 to the RC port... But no talking... I have no esc connected, just a pixhawk, gps on my desk.....
What does this 3000 mean in channel value as max is supposed to be 1900(2000)

I know this is a bit old but be sure you go into the USB port properties of your operating system and set the port speed to 115200. 

I just went through this with my new Pixhawk and Taranis X9D trying to get everything talking.

Russ

Oliver this information was super helpful thank you so much. i was stuck in the same situation. but thanks to you i figure it out. the ping or jumper has to go on 3-4. and it work for me.

know i have to figure it out how to make the radio from mode 1 to mode 2. i check the setting and is mode 2 but when i moved the throttle the air long move. i dont know why.?

any idea?

Reply to Discussion

RSS

© 2019   Created by Chris Anderson.   Powered by

Badges  |  Report an Issue  |  Terms of Service