Developer

PixRacer with Ardupilot

This is a discussion to focus the feedback and support of ardupilot on the PixRacer board from AUAV.co.

We believe that all teething problems encountered are now resolved and so we recommend people load Copter-3.3.4 which is available for all multicopters through the Mission Planner's (and other GCS's) Install Firmware screens.  Note that because regular Pixhawks are still on Copter-3.3.3 the install icon may show Copter-3.3.3 but rest assured, Copter-3.3.4 will be installed (you can check the version by looking at the very top of the Mission Planner).

3691274249?profile=original

You need to be a member of diydrones to add comments!

Join diydrones

Email me when people reply –

Replies

  • BTW it seems im reproducing all the failures one can achieve. So if you have something specific to test, let me know. The problems will show up on my setup :)

  • Ordered an ACSP5, hope that fixes my problem.

    Im connecting servos, vtx, etc using dedicated regulators, no vcc to pixracer from there.

    From pixracer i only power the RX, GPS, and buzzer. from Rx i power nothing.

    But as a workaround, i will try to use the 5v regulator to power pixracer instead of the power module. At least until ACSP arrives. Will let you know the results.

    Thanks again :)


    Nick Arsov said:

    Wow, the power supply is not good...too much noise? I hope when you apply a clean power the RC noise will be reduced too. Also do avoid connecting something noisy ( like servos ) to the receiver.

  • Wow, the power supply is not good...too much noise? I hope when you apply a clean power the RC noise will be reduced too. Also do avoid connecting something noisy ( like servos ) to the receiver.

  • Just after writing about my setup, i started to think about i may have board power issue.

    This is my VCC chart + RC in having the fluctuations. Somewhere i read pixracer needs clean 5-5.5v power, now what i see is 4.9-5v, with high noise at where the RC-in noise is observed.

    Can this cause these sympthoms? Anyway, im just ordering an ACSP5 (i need it small, and i only want to power the pixracer from it).

    3702281679?profile=original

    Nick Arsov said:

    Disconnect everything but power, ESCs, receiver and GPS.....no camera, no servos, no video Tx....

    Make a clean setup and calibration and make a fresh log.

  • Disconnect everything but power, ESCs, receiver and GPS.....no camera, no servos, no video Tx....

    Make a clean setup and calibration and make a fresh log.

  • Hi Nick,

    In this post, i attached the logs and settings: http://diydrones.com/xn/detail/705844:Comment:2294859

    About the wiring and components:

    pixracer, ublox 6h gps, 3dr power module (this is powering the pixracer, most proably this is a clone as well), PDB with 12v regulator, 5v regulator and LC filter (this is powering the VTX, one now-unconnected servo, 4x20a racerstar blheli esc, 4s 1800mah lipo, mt2204 emax II motors, zmr250 frame, 5v camera, spektrum satellite or ORX 6ch PPM sum receiver

    SW: 3.3.4, 3.4rc1, 3.4rc2

    Recently I replaced the clone pixracer with a genuine one. with the clone i havent experience this, but that had other issues starting its sensors, and did not support DSM input. so thats not a good measure.

    Than you for reply,

    M.

    Nick Arsov said:

    Hi Marcell,

    Please provide your wiring, connected devices, firmware installed, settings and log files if any.

    BR

    Nick

  • Hi Marcell,

    Please provide your wiring, connected devices, firmware installed, settings and log files if any.

    BR

    Nick

  • Guy, sorry for pushing... but.. can you please advice me on how can i proceed to get in the air with my pixracer?

    I cant decide if:

    - its my fault and im doing something wrong

    - its a software bug

    - its a hardware bug

    My quad just does not fly well. It shakes randomly, rc input chart shakes (only in air, regardless of the receiver used). Removed all the extra hardware i can (gps, wifi). It does not even hold heading :( 

    Is there a way to get customer support from AUAV? Is this the responsibility of AUAV at all? I dont want to only rely on your kindness, I'm seeking a solution.

  • Never ending Autotune,

    As with 3.4-rc1 also 3.4-rc2 never ends the autotuning within 7 min and for Roll only.

    And as I could see in the log, the values for P and D are decreased from the manual setup with good attitude below the defaults.

    With the defaults the Hexa F550, 1.8 kg was not to control.

    Here the .Log file:

    https://www.hightail.com/download/cUJVK3BETStRYSs5TE5Vag

  • Never ending Autotune,

    As with 3.4-rc1 also 3.4-rc2 never ends the autotuning within 7 min and for Roll only.

    And as I could see in the log, the values for P and D are decreased from the manual setup with good attitude below the defaults.

    With the defaults the Hexa F550, 1.8 kg was not to control.

This reply was deleted.

Activity

DIY Robocars via Twitter
RT @chr1sa: Just a week to go before our next @DIYRobocars race at @circuitlaunch, complete with famous Brazilian BBQ. It's free, fun for k…
20 hours ago
DIY Robocars via Twitter
How to use the new @donkey_car graphical UI to edit driving data for better training https://www.youtube.com/watch?v=J5-zHNeNebQ
Nov 28
DIY Robocars via Twitter
RT @SmallpixelCar: Wrote a program to find the light positions at @circuitlaunch. Here is the hypothesis of the light locations updating ba…
Nov 26
DIY Robocars via Twitter
RT @SmallpixelCar: Broke my @HokuyoUsa Lidar today. Luckily the non-cone localization, based on @a1k0n LightSLAM idea, works. It will help…
Nov 25
DIY Robocars via Twitter
@gclue_akira CC @NVIDIAEmbedded
Nov 23
DIY Robocars via Twitter
RT @luxonis: OAK-D PoE Autonomous Vehicle (Courtesy of zonyl in our Discord: https://discord.gg/EPsZHkg9Nx) https://t.co/PNDewvJdrb
Nov 23
DIY Robocars via Twitter
RT @f1tenth: It is getting dark and rainy on the F1TENTH racetrack in the @LGSVLSimulator. Testing out the new flood lights for the racetra…
Nov 23
DIY Robocars via Twitter
RT @JoeSpeeds: Live Now! Alex of @IndyAChallenge winning @TU_Muenchen team talking about their racing strategy and open source @OpenRobotic…
Nov 20
DIY Robocars via Twitter
RT @DAVGtech: Live NOW! Alexander Wischnewski of Indy Autonomous Challenge winning TUM team talking racing @diyrobocars @Heavy02011 @Ottawa…
Nov 20
DIY Robocars via Twitter
Incredible training performance with Donkeycar https://www.youtube.com/watch?v=9yy7ASttw04
Nov 9
DIY Robocars via Twitter
RT @JoeSpeeds: Sat Nov 6 Virtual DonkeyCar (and other cars, too) Race. So bring any car? @diyrobocars @IndyAChallenge https://t.co/nZQTff5…
Oct 31
DIY Robocars via Twitter
RT @JoeSpeeds: @chr1sa awesomely scary to see in person as our $1M robot almost clipped the walls as it spun at 140mph. But it was also awe…
Oct 29
DIY Robocars via Twitter
RT @chr1sa: Hey, @a1k0n's amazing "localize by the ceiling lights" @diyrobocars made @hackaday! It's consistently been the fastest in our…
Oct 25
DIY Robocars via Twitter
RT @IMS: It’s only fitting that @BostonDynamics Spot is waving the green flag for today’s @IndyAChallenge! Watch LIVE 👉 https://t.co/NtKnO…
Oct 23
DIY Robocars via Twitter
RT @IndyAChallenge: Congratulations to @TU_Muenchen the winners of the historic @IndyAChallenge and $1M. The first autonomous racecar comp…
Oct 23
DIY Robocars via Twitter
RT @JoeSpeeds: 🏎@TU_Muenchen #ROS 2 @EclipseCyclone #DDS #Zenoh 137mph. Saturday 10am EDT @IndyAChallenge @Twitch http://indyautonomouschallenge.com/stream
Oct 23
More…