Developer

PixRacer with Ardupilot

This is a discussion to focus the feedback and support of ardupilot on the PixRacer board from AUAV.co.

We believe that all teething problems encountered are now resolved and so we recommend people load Copter-3.3.4 which is available for all multicopters through the Mission Planner's (and other GCS's) Install Firmware screens.  Note that because regular Pixhawks are still on Copter-3.3.3 the install icon may show Copter-3.3.3 but rest assured, Copter-3.3.4 will be installed (you can check the version by looking at the very top of the Mission Planner).

3691274249?profile=original

You need to be a member of diydrones to add comments!

Join diydrones

Email me when people reply –

Replies

    • It's a great board if you bought the original. 
      You've decided to save $30 and give the Chinese a bigger profit than AUAV is making, and AUAV is doing the work! 
      I can't believe anyone would buy that clone board w/ it's horrible components and shitty soldering to save a few bucks. 
      If they  priced the clone for what it looks like it's worth.. About $30, I couldn't blame you.. But at $70.00 it is really just ripping off AUAV and anyone who pays for it.

      The pixracer clone is one of the worst examples of taking advantage of someone elses work, that I have ever seen..   They didn't even bother changing the silkscreen layer of the PCB, and it still says AUAV and has Philips name on it!  they literally just took the design files and ran w/ them... 
      I'm hoping AUAV did the smart thing and put obvious errors in their published schematics, so the clones won't work w/out an engineer reviewing it and finding the issue.. But I doubt it.

      • please stop to troll

        i have bought clone only because the original was not in stock for a while(and not it s not only 30usd but 40usd if you add shipping cost..and you have a nice alloy case) no stock,less expansive,nice case show me this way!!

        it s a good alternative is there are no stock and if you don t want to wait!!

        but i agree nick price is very good so no need to buy a clone...if stock are good ;)

      • Scott, I agree with you. The clones are not supporting anything just making profit off of other people's hard work. Just parasites . How long before RTFQ jumps on this.

      • Scott, sometimes not only some USS is the problem to buy a chinesse board, not all countries have the same import rules, I agree with you that 3DR first and here AUAV is doing the work so all my begining APM are 3DR and now I'm waiting an original Pixracer but, in the middle, my choice was Chinesse or nothing :( (never the clone trademark) and it's an open source so, everyone know what they want to choice; My chinesse boards works nice but I prefer to choice a board that is supporting developers because the board alone isn't usefull for me, but not easy to buy from my country, I spend a month or more trying to do it.

        This weekend finally arrives to my hands :D :D :D :D

  • A couple years ago I was having problems with the internal compass offset being too high. Using a tape head demagnetizer on the compass chip and surrounding metal screws (mainly the chip) cleared the problem.

    http://www.ebay.ca/itm/Vintage-Realistic-Tape-Head-Electric-Demagne...

  • After my crash yesterday I contacted Phil about some cables that were trashed, got an quick reply back, I placed order last knight today I received (on Sunday) USPS info today. Now that is FAST service.

  • Ok, got it to work.  Make sure you only have one compass checked.  The first one.  The code does some counting and if any of the offsets are all zeros it counts as bad.

    If you disconnect the GPS one then you will need to move the offsets from the second compass to the first one, unless you like dancing of course.

    • I guess I am doing somthing wrong, but I tried this with only one compass checked again and it did not work always says compass offset too high. I tried it checking #1 then #2 and then #3. Tried Primary Compass #1 , #2, and #3. Always the same thing Compass Offset Too High. Hook up GPS and everything works fine.

    • After many compass headhaches, I disconnect the int compass in a pixhawx (chinesse) and forgot issues with only ext one, many successfull flights now.

  • Yes, there is a few issues here that I think are being worked on.  With out the external compass connected it only sees one compass and not two since it has two internal compasses.  Second is that the fitness of the reading coming from the compass is too high for it to like it so you get the message Compass on Calibrated.

    If you push that button that says use onboard calibration and then move the copter arround it will beep when it is done and will display a fitness for what it saw.  It needs to be below 8 to be usable at this point.  Mine shows about 23.

This reply was deleted.

Activity

DIY Robocars via Twitter
RT @DanielChiaJH: Great racing against @a1k0n today at @diyrobocars! Pretty cool to both break sun-9s at the track today I think I got very…
9 hours ago
DIY Robocars via Twitter
Broadcasting the @circuitlaunch race live now at https://m.twitch.tv/diyrobocars Races begin around 2:00pm PT
14 hours ago
DIY Robocars via Twitter
RT @a1k0n: ran a huge number of hyperparameter tuning experiments yesterday; now I can train a new policy, far with better quality, in 15 m…
14 hours ago
DIY Robocars via Twitter
RT @a1k0n: Did I get rid of hand-tuned parameters? Yes. Am I still hand-tuning more parameters? Also yes. I have a few knobs to address the…
Monday
DIY Robocars via Twitter
RT @a1k0n: I'm not going to spoil it, but (after charging the battery) this works way better than it has any right to. The car is now faste…
Monday
DIY Robocars via Twitter
RT @a1k0n: Decided to just see what happens if I run the sim-trained neural net on the car, with some safety rails around max throttle slew…
Monday
DIY Robocars via Twitter
Sep 24
DIY Robocars via Twitter
RT @SmallpixelCar: @a1k0n @diyrobocars I learned from this. This is my speed profile. Looks like I am too conservative on the right side of…
Sep 24
DIY Robocars via Twitter
RT @a1k0n: @SmallpixelCar @diyrobocars Dot color is speed; brighter is faster. Yeah, it has less room to explore in the tighter part, and t…
Sep 24
DIY Robocars via Twitter
RT @a1k0n: I'm gonna try to do proper offline reinforcement learning for @diyrobocars and throw away all my manual parameter tuning for the…
Sep 23
DIY Robocars via Twitter
RT @circuitlaunch: DIY Robocars & Brazilian BBQ - Sat 10/1. Our track combines hairpin curves with an intersection for max danger. Take tha…
Sep 22
DIY Robocars via Twitter
RT @SmallpixelCar: Had an great test today on @RAMS_RC_Club track. However the car starts to drift at 40mph. Some experts recommended to ch…
Sep 11
DIY Robocars via Twitter
RT @gclue_akira: 世界最速 チームtamiyaのaiカー https://t.co/1Qq2zOeftG
Sep 10
DIY Robocars via Twitter
RT @DanielChiaJH: Always a good time working on my @diyrobocars car at @circuitlaunch. Still got some work to do if I’m to beat @a1k0n howe…
Sep 10
DIY Robocars via Twitter
RT @SmallpixelCar: My new speed profile for @RAMS_RC_Club track https://t.co/RtLb7TcgIJ
Sep 10
DIY Robocars via Twitter
RT @SmallpixelCar: Practiced at @RAMS_RC_Club today with my new @ARRMARC car https://t.co/AEu2hCx89T
Aug 28
More…