Developer

PixRacer with Ardupilot

This is a discussion to focus the feedback and support of ardupilot on the PixRacer board from AUAV.co.

We believe that all teething problems encountered are now resolved and so we recommend people load Copter-3.3.4 which is available for all multicopters through the Mission Planner's (and other GCS's) Install Firmware screens.  Note that because regular Pixhawks are still on Copter-3.3.3 the install icon may show Copter-3.3.3 but rest assured, Copter-3.3.4 will be installed (you can check the version by looking at the very top of the Mission Planner).

3691274249?profile=original

You need to be a member of diydrones to add comments!

Join diydrones

Email me when people reply –

Replies

  • Developer

    PhillipK from AUAV.co and I spent some time to narrow in on the issues with ardupilot and PixRacer, in particular the most serious issue is this "Bad Gyro Health" message that appears intermittently.  It may happen more or less with Copter-3.3.3 vs Copter-3.4-dev but it can certainly happen with either firmware.

    What we see so far is that IMU1 is appearing as unhealthy in the logs even though it is actually returning data.  So you can see in the graph below that IMU1 is reporting gyro and accel values but the GyrHlt and AcHlt column is all zeros.
    3702181590?profile=originalSo we don't have a solution yet but we're on the case and it's a very high priority to get this sorted out.

    • Developer

      Ah, I've created a couple of issues here and here to capture this problem and also a report from PhillipK that the SBUS input isn't working.

      • Not sure if this is a different issue, or same that Randy has already seen,  ( He mentioned Master having this problem), but I have not been able to get any APM software to load on my Pixracer using QGroundcontrol or Mission Planner, including using the latest  MP and Beta MP.   I have tried both “Beta” and “Default ” loads in MP, but Pixracer will not see any radio on calibration screen (Genuine Futaba SBus Tx-Rx). Other calibration setup functions seem to work OK in MP after loading.  I tried disabling all Failsafe’s in MP, but MP won’t see radio input. Bars on radio cal Screen just go blank with no movement and will throw an error if you click complete.

         

        Should I try setting the Min RC failsafe value to some minimum number-even though I already have the radio FS box disabled?  Currently it’s at 950 as that is what my other FC’s RC failsafe’s are set at, and I just copied the other APM profile to a new model on the Tx.

         

        PX4 Stack seems to load/work OK using QGroundcontroll, but haven’t flow yet due to Flight Mode selection issues. (I never used Q till now and discovered late yesterday that Mode selection is keyed only to pulse width and must follow a specific order; so I think I need to reprogram my FG8 Ch5 Mixer to get Manual/Stabilize to kick in at proper pulse width so I can arm- I think).

         

        Trying to load APM via Q seems to throw an error on some size parameters missing while downloading, but then seems to load FC, sensors calibrate Ok, but same issue – won’t see Sbus radio input with APM loaded.

        • Developer

          Joe,

          I haven't personally tested it yet but someone else has reported that SBUS isn't working with APM/Pixracer.  Getting Pixracer sorted is definitely very very high on our to-do list.. just having some troubles juggling priorities to get these niggling issues sorted out.  I really hope we can do it this week.

      • @gervais, I tested with Spektrum PPM and it was fine.

        • Found out, that the Rx bug is related to Radio Failsafe.(only FS I´m using) Independend of FS PWM level, its initializing FS,claiming no RC Receiver /RC FS, once activated.

          The sts appearing Gyro/ Compass whatever health issues, partly with funny HUD level movements, Yaw movements are going away after re-boot.

          • Btw.,although this didn´t appear with PX4 stack, I changed my Hott Rx (GR-16, very reliable) to check, if this is hardware related. But that didn´t help.I flashed twice as well.

      • wow, thanks!  It's not just me, then :) :)

This reply was deleted.

Activity

DIY Robocars via Twitter
May 15
DIY Robocars via Twitter
May 14
DIY Robocars via Twitter
May 13
DIY Robocars via Twitter
RT @f1tenth: Say hi to our newest #F1TENTH creation for @ieee_ras_icra next week in Philly. It’s going to be huge! 😎 🔥 @AutowareFdn @PennEn…
May 13
DIY Robocars via Twitter
May 11
DIY Robocars via Twitter
May 8
DIY Robocars via Twitter
RT @SmallpixelCar: Noticed my car zigzagged in last run. It turned out to be the grass stuck in the wheel and made the odometry less accura…
May 8
DIY Robocars via Twitter
RT @SmallpixelCar: Test my car. RTK GPS worked great. Thanks @emlid for their support. https://t.co/EkQ6qmjmWR
May 8
DIY Drones via Twitter
RT @chr1sa: @kane That's @diydrones circa 2009. Still have a box of those Canon cameras that we used to strap into planes, just like this.…
May 3
DIY Robocars via Twitter
RT @chr1sa: Our next @diyrobocars race is going to be outside at a real RC racetrack in Fremont on May 28. Fully autonomous racing, head-to…
Apr 30
DIY Robocars via Twitter
RT @f1tenth: Our Spring 2022 F1TENTH course @PennEngineers is coming to an end with a head-to-head race as a big finale. So proud of our st…
Apr 26
DIY Robocars via Twitter
RT @DanielChiaJH: I wrote a thing! Throughout the development of my @diyrobocars car I've been using @foxglovedev Studio to visualize and d…
Apr 23
DIY Robocars via Twitter
RT @SmallpixelCar: My new car for high speed. Low body, everything ( @NVIDIAEmbedded Jetson Xavier NX, @emlid RTK GPS, IMC) under the deck…
Apr 23
DIY Robocars via Twitter
Apr 21
DIY Robocars via Twitter
RT @f1tenth: F1TENTH Race training setup @PennEngineers for our upcoming ICRA2022 @ieee_ras_icra competition. @OpenRoboticsOrg @IndyAChalle…
Apr 21
DIY Robocars via Twitter
RT @fatcatFABLAB: Proud to be hosting a restarted DIY Robocars NYC Meetup April 26. Come by if you want to talk about and race self-driving…
Apr 17
More…