Developer

PixRacer with Ardupilot

This is a discussion to focus the feedback and support of ardupilot on the PixRacer board from AUAV.co.

We believe that all teething problems encountered are now resolved and so we recommend people load Copter-3.3.4 which is available for all multicopters through the Mission Planner's (and other GCS's) Install Firmware screens.  Note that because regular Pixhawks are still on Copter-3.3.3 the install icon may show Copter-3.3.3 but rest assured, Copter-3.3.4 will be installed (you can check the version by looking at the very top of the Mission Planner).

3691274249?profile=original

You need to be a member of diydrones to add comments!

Join diydrones

Email me when people reply –

Replies

                  • Thank's Randy, that was my concern.

                    Here an Ex, to try to explain better

                     a filter default param is 20, and I change to 18, then, in a newer firm. you decide that 16 is the better choice for that param; when I update. that param change to 16.

      • I applaud your efforts for going through all of that to figure it out. But my question is WHY did you have to in the first place? I understand this is Beta, but, this is not like CF/RF where people are using different FC's to bring another variable into the mix. Everyone who has interest in this thread has a PixRacer and has/have used MP/Copter. Shouldn't the process to get everything calibrated properly be the same for everyone and well documented? After all, these calibrations ARE needed to fly. Being new to this, I would never have thought of doing all that and would have chalked it up user error and bugged everyone (like I did) or bad hardware. I almost sent my PixRacer back because I could not get my compasses to calibrate and couldn't get passed that compass not calibrated error. And everything I read lead me to believe I had bad hardware. I personally have had no luck with MP/Copter what so ever. I gave up and went to QGC/PX4 hoping at a later date. I hope it gets sorted out because I really like the MP layout and what Copter had to offer. QGC/PX4 documentation/support wise just isn't there like MP/Copter is.

        Sorry if this seems like a rant, don't take it as one, just frustration.       

        • Personally, if I didn't have a background in IT and EE, I'd have thrown the thing on the ground and stomped on it and cussed a lot.... 
          But, I'm used to finding bugs and solving problems for people.. (it's what I do for a living). 

          From a beginners perspective, it would be impossible to know what is a bug and what is a configuration error or hardware error, etc..
          What I don't understand is why me and a couple others are saying we have these issues, and can reproduce them w/ multiple configs and different flight controllers.. then a few other people are posting saying 3.4 is all good and no problems whatsoever...  I don't understand what the difference is there..
          But from the beginning, PX4 was the only software they said worked 100%..  Everyone using APM knows they're testers.

          • for me i can t even calibrate my acc...so yes it s full buggy so i come back with my pixhawck and waiting 

          • I made just the opposite experience.

            With Pixracer I started with QGC/PX4 and never spent so much time (days) to configure a System and no succes.

            Back to MP/AC everything was done within 30 min.as usal with Pixhawk and China Clones.

            Because AC has no solution for VTOL I stopped my Project with Caipirinha Tailsitter.

            And the same here, other fly with a Tailsitter, strange...

          • Scott, I have had the same issues as you've had and have posted logs. Like  I see that others say they have not had any problems. I am not an IT or EE but I am no new comer to electronics because I have been involved in it since 1962. What I don't understand is are you and me and a couple others the only ones who can be having these problems. I am not a professional programmer but is their not a problem in EK2 or is it somewhere else.

            • Developer

              I guess you're using the onboard compass calibration on the bottom right of the MP's compass calibration screen (as opposed to the MP based calibration on the bottom left of the same screen)?

              If it's the onboard calibrator could you try increasing COMPASS_CAL_FIT parameter?  Maybe make it 20 or 30?  Actually maybe just keep increasing it until it works and then report here how high it needed to be.  This parameter controls how lenient the compass calibration needs to be to pass.

              ArduPilot/ardupilot
              ArduPlane, ArduCopter, ArduRover source. Contribute to ArduPilot/ardupilot development by creating an account on GitHub.
  • Hi, please check compass_dev_ID3 263178  default orientation settings.

    X offset -659, while compass#1 and #2 have acceptable offsets suggests wrong orientation my external compass sits right above the pixracer.

    Also, since compass_dev_id 66826 and  263178 are internal and unique to the chips used, I suggest to tie orientation settings to the specific I2C addresses instead of the way it is done right now. 

    Thanks! 

  • Developer

    If possible I think we should move the Copter-3.4 beta testing to the new ArduPilot discourse server.  This replaces the old APM-Forum but is far better to work with.

  • for me this beta doesn t working..i can t arrive to pass the first step of acc calibration..

    no problem with official version and latest mission planner.

    each time i have th same error acc failed...what wrong with this beta?

This reply was deleted.

Activity

DIY Robocars via Twitter
May 15
DIY Robocars via Twitter
May 14
DIY Robocars via Twitter
May 13
DIY Robocars via Twitter
RT @f1tenth: Say hi to our newest #F1TENTH creation for @ieee_ras_icra next week in Philly. It’s going to be huge! 😎 🔥 @AutowareFdn @PennEn…
May 13
DIY Robocars via Twitter
May 11
DIY Robocars via Twitter
May 8
DIY Robocars via Twitter
RT @SmallpixelCar: Noticed my car zigzagged in last run. It turned out to be the grass stuck in the wheel and made the odometry less accura…
May 8
DIY Robocars via Twitter
RT @SmallpixelCar: Test my car. RTK GPS worked great. Thanks @emlid for their support. https://t.co/EkQ6qmjmWR
May 8
DIY Drones via Twitter
RT @chr1sa: @kane That's @diydrones circa 2009. Still have a box of those Canon cameras that we used to strap into planes, just like this.…
May 3
DIY Robocars via Twitter
RT @chr1sa: Our next @diyrobocars race is going to be outside at a real RC racetrack in Fremont on May 28. Fully autonomous racing, head-to…
Apr 30
DIY Robocars via Twitter
RT @f1tenth: Our Spring 2022 F1TENTH course @PennEngineers is coming to an end with a head-to-head race as a big finale. So proud of our st…
Apr 26
DIY Robocars via Twitter
RT @DanielChiaJH: I wrote a thing! Throughout the development of my @diyrobocars car I've been using @foxglovedev Studio to visualize and d…
Apr 23
DIY Robocars via Twitter
RT @SmallpixelCar: My new car for high speed. Low body, everything ( @NVIDIAEmbedded Jetson Xavier NX, @emlid RTK GPS, IMC) under the deck…
Apr 23
DIY Robocars via Twitter
Apr 21
DIY Robocars via Twitter
RT @f1tenth: F1TENTH Race training setup @PennEngineers for our upcoming ICRA2022 @ieee_ras_icra competition. @OpenRoboticsOrg @IndyAChalle…
Apr 21
DIY Robocars via Twitter
RT @fatcatFABLAB: Proud to be hosting a restarted DIY Robocars NYC Meetup April 26. Come by if you want to talk about and race self-driving…
Apr 17
More…