Developer

PixRacer with Ardupilot

This is a discussion to focus the feedback and support of ardupilot on the PixRacer board from AUAV.co.

We believe that all teething problems encountered are now resolved and so we recommend people load Copter-3.3.4 which is available for all multicopters through the Mission Planner's (and other GCS's) Install Firmware screens.  Note that because regular Pixhawks are still on Copter-3.3.3 the install icon may show Copter-3.3.3 but rest assured, Copter-3.3.4 will be installed (you can check the version by looking at the very top of the Mission Planner).

3691274249?profile=original

You need to be a member of diydrones to add comments!

Join diydrones

Email me when people reply –

Replies

        • You´ll be able to measure Voltage w/o arming the motors with the ACSP4 as well :-) Voltage measurement is done by a simple resistor divider (which requires diff. setup depending on FC)

  • T3

    Hi Phillip and Nick,

    just in time with the new updates for the PixRacer in master I finished a new copter build.

    However, I am having problems connecting to the PixRacer. I tried Mission Planner (including beta) and APM Planner, different cables, USB ports, SD cards as well as AC3.3.3, AP3.5.2 as well as master. No success. I get "Error uploading firmware" or "No valid device found" or nothing is happening at all after downloading the firmware.

    It seems I cannot really connect to it. Connection basically works as it is downloading some parameters in Mission Planner but the "Standard Params" screen is empty. APM Planner says "Parameters Downloaded 0% 0/?". Anyway, both Planners say "Connected".

    All works fine with an older Pixhawk.

    Is there anything special to take care of? I never had a hardware failure on any *hawk so I hesitate to call it one :-)

    Any idea or suggestion what I should try?

    TIA,

    Thorsten

    • T3

      Hi all,

      I had some additional problems connecting to Mission Planner (apart from outdated drivers).

      But these are now all solved with the latest beta version of Mission Planner:

      https://github.com/ArduPilot/MissionPlanner/issues/1231

      So in case you are experiencing problems just download the latest beta version. It also shows the new ATC_ tuning parameters in the Extended Tuning screen.

      Best regards,

      Thorsten

      Beta cannot download Params · Issue #1231 · ArduPilot/MissionPlanner
      Hi all, the current as well as the previous beta of Mission Planner connects to the PixRacer but the seems to be in some infinite loop while "Getting…
      • T3

        Short update:

        There was another issue in Mission Planner causing problems to download the logs.

        But this was solved in minutes by Michael as well!

        So again make sure to update to the latest beta versions.

        Beta cannot download data flash logs · Issue #1233 · ArduPilot/MissionPlanner
        Hi Michael, the current beta of Mission Planner has some problems downloading data flash logs (tested on Win7 and Win10). I only have the German erro…
    • T3

      Thanks to Nick I was able to solve it!

      It must have been a driver problem on my Win7 machine. On a new Win10 laptop and an OS X MacBook flashing was no problem.

      Looking forward to my fist tests with PixRacer!

    • Thorsten

      I had exactly the same problem trying to upload v3.4 (2887e481) using Mission Planner 1.3.37 build 1.1.5949.13507

      On my Pixracer I had PX4 loaded. After unplugging and reconnecting I then tried to load v3.3 quad and this was successful. I then tried to upload v3.4 and it worked.

      Jon

      • T3

        Jon,

        thanks!

        I tried this as well. Older firmware versions, Rover, Plane as well. But unfortunately without success. 

      • Update

        I then had problems calibrating the accelerometers in both Mission Planner & QGC. Went back to v3.3 and managed to calibrate the accels in QGC. I will try again with v3.4 a bit later today.

        • Connected to Mission Planner and managed to upload v3.4 but then couldn't reconnect to Mission Planner. Opened QGC and the Pixracer automatically connected. Calibrated accelerometers and compass successfully. Went back into Mission Planner and it connected. However, I just tried connecting to Mission Planner two minutes ago and it failed to connect but with QGC no problems connecting. It may be the way I've got my Windows 10 set up.

  • I just recently did an Auto Tune to test it with the latest version and after the Auto Tune the PIDS were way off and the copter did not respond at all.  Don't know what's going on there but had to put them back to what they were.  Did notice that the I and P where set to the same after Auto Tune which to me seemed odd.

    If I get some descent weather I will try it again and post the results.

This reply was deleted.

Activity

DIY Robocars via Twitter
How to use the new @donkey_car graphical UI to edit driving data for better training https://www.youtube.com/watch?v=J5-zHNeNebQ
yesterday
DIY Robocars via Twitter
RT @SmallpixelCar: Wrote a program to find the light positions at @circuitlaunch. Here is the hypothesis of the light locations updating ba…
Saturday
DIY Robocars via Twitter
RT @SmallpixelCar: Broke my @HokuyoUsa Lidar today. Luckily the non-cone localization, based on @a1k0n LightSLAM idea, works. It will help…
Thursday
DIY Robocars via Twitter
@gclue_akira CC @NVIDIAEmbedded
Nov 23
DIY Robocars via Twitter
RT @luxonis: OAK-D PoE Autonomous Vehicle (Courtesy of zonyl in our Discord: https://discord.gg/EPsZHkg9Nx) https://t.co/PNDewvJdrb
Nov 23
DIY Robocars via Twitter
RT @f1tenth: It is getting dark and rainy on the F1TENTH racetrack in the @LGSVLSimulator. Testing out the new flood lights for the racetra…
Nov 23
DIY Robocars via Twitter
RT @JoeSpeeds: Live Now! Alex of @IndyAChallenge winning @TU_Muenchen team talking about their racing strategy and open source @OpenRobotic…
Nov 20
DIY Robocars via Twitter
RT @DAVGtech: Live NOW! Alexander Wischnewski of Indy Autonomous Challenge winning TUM team talking racing @diyrobocars @Heavy02011 @Ottawa…
Nov 20
DIY Robocars via Twitter
Incredible training performance with Donkeycar https://www.youtube.com/watch?v=9yy7ASttw04
Nov 9
DIY Robocars via Twitter
RT @JoeSpeeds: Sat Nov 6 Virtual DonkeyCar (and other cars, too) Race. So bring any car? @diyrobocars @IndyAChallenge https://t.co/nZQTff5…
Oct 31
DIY Robocars via Twitter
RT @JoeSpeeds: @chr1sa awesomely scary to see in person as our $1M robot almost clipped the walls as it spun at 140mph. But it was also awe…
Oct 29
DIY Robocars via Twitter
RT @chr1sa: Hey, @a1k0n's amazing "localize by the ceiling lights" @diyrobocars made @hackaday! It's consistently been the fastest in our…
Oct 25
DIY Robocars via Twitter
RT @IMS: It’s only fitting that @BostonDynamics Spot is waving the green flag for today’s @IndyAChallenge! Watch LIVE 👉 https://t.co/NtKnO…
Oct 23
DIY Robocars via Twitter
RT @IndyAChallenge: Congratulations to @TU_Muenchen the winners of the historic @IndyAChallenge and $1M. The first autonomous racecar comp…
Oct 23
DIY Robocars via Twitter
RT @JoeSpeeds: 🏎@TU_Muenchen #ROS 2 @EclipseCyclone #DDS #Zenoh 137mph. Saturday 10am EDT @IndyAChallenge @Twitch http://indyautonomouschallenge.com/stream
Oct 23
DIY Robocars via Twitter
RT @DAVGtech: Another incident: https://t.co/G1pTxQug6B
Oct 23
More…