Developer

PixRacer with Ardupilot

This is a discussion to focus the feedback and support of ardupilot on the PixRacer board from AUAV.co.

We believe that all teething problems encountered are now resolved and so we recommend people load Copter-3.3.4 which is available for all multicopters through the Mission Planner's (and other GCS's) Install Firmware screens.  Note that because regular Pixhawks are still on Copter-3.3.3 the install icon may show Copter-3.3.3 but rest assured, Copter-3.3.4 will be installed (you can check the version by looking at the very top of the Mission Planner).

3691274249?profile=original

You need to be a member of diydrones to add comments!

Join diydrones

Email me when people reply –

Replies

    • I just did an Accel calibration and it worked just fine.  I used latest 3.4 dev build from today.

      Several things do not work with 3.3.4.

      1) Pixracer has two internal compasses only usable with 3.4

      2) Must not have done enough dancing with the copter.

      5) Only works with 3.4 dev

      6) WiFi only works with 3.4 dev

      7) Different shunt values. 3=13.69 and 6=48.19 to start.

      8) Only if your cable is to short.

      Also write down your compass offsets after your done to make sure they don't change later.

      • Michael, you seem to be a lucky man :). I use MP 1.3.37 build 1.1.5960.18090 and latest 3.4 dev build from today. Accel calibration is not possible. Getting always "Calibration Failed" message and after that HUD display is dancing with message: "Error pos vert variance" and "Bad AHRS". EKF Status shows "Position Vert" full red. Any idea what does it mean?

        I can calibrate Accel only with stable/beta 3.3.4-pixracer version. I give up for now :(.

        • I decided to give ArduCopter a next chance. Loaded latest MP beta and latest AC 3.4dev today, then V frame selected, then compasses calibration (all axes green values), then RC calibration - RC1-4 from 100 to 1900. Then started ACC calibration: level, left, right, down, up, back and... calibration failed .... fu.......ck... again? :(

          Even more, I see "PreArm: RC not calibrated" but I did RC calibration a few times. I have FrSky X4RSB working in SBUS mode.

          • I have stated this problem before I am in the same boat as you . I have never been able to ACC calibrate in MP without a fail. Only ACC I can calibrate in MP is LEVEL. The only full ACC calibration I can do is using QGC, so this is what I have done to get the ACC calibrated. then I go back to MP. It has worked for me.

            • My problem is I cannot calibrate ACC even using QGC. But if I use AC 3.3.4 beta I can calibrate ACC in MP or QGC.

        • Just want to mention,
          I have been able to calibrate my gyros with 3.4dev in MP. 
          BUT, occasionally my HUD dances/spins around, too.   And then the EKF meter position and velocity, etc, all go up into the red.. This is while just sitting on my workbench.  It''ll be fine for several minutes, then I notice the HUD getting wobbly, then it starts spinning and EKF goes into the red..  Then it settles down again. 
          Plus the other issue where autopilot assisted modes do not work, as per my logs a page or two back.

          • Scott, I had what I think was the same issue.

            I moved my electronics around and it seems to have eliminated the problem, specifically moved my stackable ESC away from the FC using some standoffs.
            I am also using the onboard-calibration now and just external compass checked when I calibrate.

            • I should have mentioned, I think my GPS may have something to do w/ my HUD spinning issue.. 
              Not positive, but I noticed my purple track in the MP HUD jumped about 50 meters at the time it was spinning.. 
              The GPS glitching like that is not new... I'm using an RTFQ GPS at the moment, and they all have this issue for me in any version of pixhawk and APM. 
              But, the HUD spinning and EKF going red when it happens is new.

              Thanks for the interference advice..   My ESC's are away, but my telemetry modem is right on top of the pixracer.. and the power board is directly under it....

          • This is really strange. I don't suspect my board is affected because I can calibrate Accel in AC stable/beta 3.3.4 version, also PX4 stack calibration is working fine. I'm a noob user only but there is for sure something suspicious in AC 3.4dev version.

      • Thanks for suggestions Michael .

        I will give a try to 3.4 asap

This reply was deleted.

Activity

DIY Robocars via Twitter
4 hours ago
DIY Robocars via Twitter
RT @SmallpixelCar: @a1k0n @diyrobocars I learned from this. This is my speed profile. Looks like I am too conservative on the right side of…
5 hours ago
DIY Robocars via Twitter
RT @a1k0n: @SmallpixelCar @diyrobocars Dot color is speed; brighter is faster. Yeah, it has less room to explore in the tighter part, and t…
5 hours ago
DIY Robocars via Twitter
RT @a1k0n: I'm gonna try to do proper offline reinforcement learning for @diyrobocars and throw away all my manual parameter tuning for the…
yesterday
DIY Robocars via Twitter
RT @circuitlaunch: DIY Robocars & Brazilian BBQ - Sat 10/1. Our track combines hairpin curves with an intersection for max danger. Take tha…
Thursday
DIY Robocars via Twitter
RT @SmallpixelCar: Had an great test today on @RAMS_RC_Club track. However the car starts to drift at 40mph. Some experts recommended to ch…
Sep 11
DIY Robocars via Twitter
RT @gclue_akira: 世界最速 チームtamiyaのaiカー https://t.co/1Qq2zOeftG
Sep 10
DIY Robocars via Twitter
RT @DanielChiaJH: Always a good time working on my @diyrobocars car at @circuitlaunch. Still got some work to do if I’m to beat @a1k0n howe…
Sep 10
DIY Robocars via Twitter
RT @SmallpixelCar: My new speed profile for @RAMS_RC_Club track https://t.co/RtLb7TcgIJ
Sep 10
DIY Robocars via Twitter
RT @SmallpixelCar: Practiced at @RAMS_RC_Club today with my new @ARRMARC car https://t.co/AEu2hCx89T
Aug 28
DIY Robocars via Twitter
Aug 24
DIY Robocars via Twitter
RT @gclue_akira: 柏の葉で走行させてるjetracerの中身 #instantNeRF #jetracer https://t.co/giVvuE4hP7
Jul 4
DIY Robocars via Twitter
Cool web-based self-driving simulator. Click save when the AI does the right thing https://github.com/pncsoares/self-driving-car
Jul 4
DIY Robocars via Twitter
RT @donkey_car: Human-scale Donkey Car! Hope this makes it to a @diyrobocars race https://www.youtube.com/watch?v=ZMaf031U8jg
Jun 25
DIY Robocars via Twitter
Jun 25
DIY Robocars via Twitter
Jun 16
More…