PixRacer with Ardupilot

This is a discussion to focus the feedback and support of ardupilot on the PixRacer board from

We believe that all teething problems encountered are now resolved and so we recommend people load Copter-3.3.4 which is available for all multicopters through the Mission Planner's (and other GCS's) Install Firmware screens.  Note that because regular Pixhawks are still on Copter-3.3.3 the install icon may show Copter-3.3.3 but rest assured, Copter-3.3.4 will be installed (you can check the version by looking at the very top of the Mission Planner).


You need to be a member of diydrones to add comments!

Join diydrones

Email me when people reply –


        • Why build from master when you can flash 3.4Rc1 Beta direct from Mission planner?

          • I agree that getting the beta firmware from MP would be the best way, but I'd also think that building from the most recent master master would be fine as well. I guess a new commit could have broken it though...?

            I didn't do anything special that I remember to setup the satellite. 

            -Scott S

    • This was my problem Spektrum will not decode as yet on the Pixracer. Some here said it would but I could not get it to decode no matter how may things I tried.    My solution was to buy a PWM to PPM and Sbus converter. I also purchased a Lemon Spektrum DSMX receiver that outputted PPM. All theses work great.

      • Thank you for your answer.

        We have seen this solution but we wanted to try out the satellite reciever before because it is cheaper for the beginning and because every datasheet tells us it is possible.

        I guess if we can't make the satellite to work, we are going to try out this solution.

        Thank you, Nicolas.

  • Got a pixracer on a emax nighthawk. Tried in the in flight tuning by setting a Taranis X9D dial to P for roll and pitch.

    As per the instructions on the "how to" page I set the lower limit at 0.08 and the upper limit at 0.25

    Wobble gets slightly worse as I approach 0.25. So I suspect I have to go lower.

    Do people in general do auto tune THEN manual tune? Do you think coupling for the pitch and roll is OK for a nighthawk? I am thinking I should decouple it.

    • Do a manual tune first.  You'll probably need much lower values than you're trying to set - I have a larger quad than yours with PI set to 0.02 and D 0.001.  Once you've got it hovering stably without oscillation in stabilize mode, and you can do left/right/forward/backward movements without inducing oscillation, then flip your autotune on.

      • Thanks,

        Yes with lower value , It's better, takeoff but unflyable.

        • Keep going!  If you have too low value it's unflyable like a boat, like you've found.   Too high and it oscillates, as you've found.  On these small craft there's a tiny range where it's stable.

          • Hello i have applied all advice given in these page but my little quad still unflyable, lot of wobble. Tried many many pids settings, but always the same more or less wobbles. I suspect a ramp on the motor at the first rpm... Like a big filter (0,5s or more) applied on the command and cannot be set because is hardcoded inside?
            I precise again that i am not a beginner in ardupilot (drones, plane, rover on arducopter, ardupilot and ardurover over 4 years...)
            Thanks in advance for your help
            • Hello,

              Some news about pixracer:
              - ramp suspected was due to manual calibration of my esc, arducopter needs an 'auto' calibration by the fc, becareful to make this in oneshot mode mot_pwm = 1 if you use oneshot with param = 2 not working
              - with lowering drasticly Pid (P and D), no more wobble

              Regards and enjoy pixracer!
This reply was deleted.