PixRacer with Ardupilot

This is a discussion to focus the feedback and support of ardupilot on the PixRacer board from

We believe that all teething problems encountered are now resolved and so we recommend people load Copter-3.3.4 which is available for all multicopters through the Mission Planner's (and other GCS's) Install Firmware screens.  Note that because regular Pixhawks are still on Copter-3.3.3 the install icon may show Copter-3.3.3 but rest assured, Copter-3.3.4 will be installed (you can check the version by looking at the very top of the Mission Planner).


You need to be a member of diydrones to add comments!

Join diydrones

Email me when people reply –


            • Yes, i specified port 14550 and it just waits for a UDP connection. It appears that MP expects the Pixracer to already be sending to that port. I can only assume that it knows the IP address since it gave it out via DHCP. What am I missing?

              • Developer
                There no connection with UDP. It just a bucket to put data in. No data, empty bucket. When you connect to the pixracer access point. It detect the connection. Sends the ip allocated to that device and starts sending the data to that IP address.

                I think the issue is that the wifi module is not connected to data. I don't know what port it's on. I tried wiring a ESP7 to telem 2. But that also didn't work and I ran out if time to test. The same module works on a Pixhawk.

                Hopefully I get some time later to understand what's up.

                What version of ESP FW are you using?
                • 3702930944?profile=original

                • Gus should be back in a couple days. If still not worked out, ping him on qgc github channel to help out.

              • I don't think it's just you and I think their working on it.

        • I have not found that to be the case, either with Mission Planner or QGroundControl. PX4 on QGroundControl on the other hand connects consistently any time the Pixracer WiFi network is connected.

          Happy to hack deeper via console/terminal/TCP/UDP to sort out what is happening, because this has consistently been the case for me. I have switched back and forth between PX4 and ArduPilot a number of times.


      • I hope they get that ironed out because I ordered one and use ArduPilot with APM Planner and MavPilot also [ Mac ] Hopefully it will work with Tower as well. I think Bill mentioned it should work with MavPilot via wifi using UDP. 

        • Developer
          It does
          • Developer

            I thought I had it working before, but with 3.3.3 it's not. I'll post back when I figure it out.

          • I have the latest ArduPilot build for Pixracer and I am unable to connect using Tower. I will try PX4, I am guessing it will work as QGroundControl has worked consistently.

This reply was deleted.


Shivchand Jaysaval liked Shivchand Jaysaval's profile
Aug 25