PixRacer with Ardupilot

This is a discussion to focus the feedback and support of ardupilot on the PixRacer board from

We believe that all teething problems encountered are now resolved and so we recommend people load Copter-3.3.4 which is available for all multicopters through the Mission Planner's (and other GCS's) Install Firmware screens.  Note that because regular Pixhawks are still on Copter-3.3.3 the install icon may show Copter-3.3.3 but rest assured, Copter-3.3.4 will be installed (you can check the version by looking at the very top of the Mission Planner).


You need to be a member of diydrones to add comments!

Join diydrones

Email me when people reply –


  • Are hexcopters supported on pixracer? 

    I have been unable to get ArduCopter to run a hexcopter.  Motors 5 & 6 won't spin up.

    I've tried installing firmware from but it doesn't support hex mode.  The wizard only shows quad frame options.

    In desperation I went back to the PX4 flight stack and it works, so the hardware supports 6 PWM outputs.

    Sorry if this question has already been covered I only read through the last ~25 of the 58 pages in this discussion, and I don't know how to search just this discussion for keywords.

    • Developer

      hexacopters should be fine. Can you check if BRD_PWM_COUNT=6 in your setup? That would be the only reason I could think of hexacopters not working.

      If the PWM count is correct, can you give me a tlog or DF log of trying to use it and it failing? I'll then load your exact config on my test board and check the PWM outputs with a logic analyser to find the issue

      • I also checked the motor5 out and motor6 out with a cro and didn't see any pwm pulses.

        Thanks for looking at this.

      • Set BRD_PWM_COUNT=6  , saved params , rebooted pixracer  , motor 5&6 still not spinning.

        Set RC5_PARAMETERS - RC5_FUNCTION to 37 (motor 5),

        RC6_PARAMETERS - RC6_FUNCTION to 38 (motor 6) ,

        and the - RC_MIN / RC_MAX PWM values , saved params , rebooted pixracer

        motor 5&6 still not spinning.

        RCout 1-6 on flight data / status tab show a PWM value that changes consistant with throttle changes.

        2016-05-10 23-15-08.bin

        2016-05-10 23-09-24.bin

        2016-05-10 23-15-08.log

        • Developer

          Thanks Michael, I've reproduced the problem and found the bug. I've pushed a fix to master.

          It will take a few hours for the autobuild servers to finish building it. Can you try again after that? I've tested it with my logic analyser and all 3 PWM modes now work correctly on a hexacopter (normal PWM, OneShot and OneShot125)

          Cheers, Tridge

          • I can't verify it works because the connection to mission planner is unstable.
            USB connection timeout (with or without external power), and a telemetry radio connection (with external power) stops retrieving params at "get compass3_offset_y "

            The ESCs did not initialize. The safety switch light stopped flashing after a short time.
            Without mission planner I can't diagnose it any further or complete the setup.

            Thank you for your efforts I'll try Ardupilot Copter on the pixracer when the bugs have been ironed out. I wouldn't feel safe flying a large hexacopter with the dev version of AC on pixracer.
            Luckily I have 6x APM's and 3 other pixhawks to fly in other models while I wait :-)

            • Developer

              Hi Michael,

              That sounds like a bug I pushed a fix for just before I pushed the fix for the Hexacopter.

              I can understand not wanting to fly the dev version on a large vehicle. Perhaps you could try it with props off at some point just to let us know if it is behaving correctly?

              Cheers, Tridge

              • Hi Tridge, I tried AC3.4-dev (4529028c)  and AC3.4-dev built 20160513 07:41  they both work on a hexacopter.All motors run as expected.

                Telemetry was stable (USB and radio) and the safety switch functioned as expected.

                The current issue is compass calibration. The pixracer found  3x compasses and numerous compass calibration attempts couldn't reach a concensus. My preferred method, the office chair method, produces quite good torroids around  the cardinal axes albeit at different scales and offsets.

                I'm looking foreward to AC 3.4 when it goes gold.

                Thank you for your efforts. Good luck with OBC 2016.

              • Hi Andrew, Could you please notify here when the issues will be fixed. I have the same problems with ESC not starting and no COM link after few seconds.

                I will be more than happy to test it on the bench. I am not confident flying my drone with this version ether and I am too unfortunate to get broken dev versions every time I try to test them. So far PX4 beta is working for me, but I am more familiar with MP and APM and hope that it will work eventually.


              • I will try AC again in about a week with props off.  I am really keen to fly this hex, it has been a 6 month project and the recent weather has been conspiring to prevent a full test flight.

                Thanks for your efforts. It is appreciated.

This reply was deleted.