Please help! Cannot load Ardupilot firmware!

Any help really appreciated, I'm stuck!!!

 

1. I can successfully load the Ardupilot IMU software on the IMU board no problem using a Windows 7 laptop and a Cool Components FTDI cable. The test software moves the cube etc and the GPS data is picked up so RX/TX from the cable seems to be working as does the PC.

 

2. Using the same PC I can load the config file on the BLOX GPS using UBLOX.

 

3. When I try to load the Ardupilot 2.7 firmware using exactly the same setup I get the sync 0x00 error.

 

4. I've gone right through the recommended list of suggestions EXCEPT using XP mode (I cannot install that at the moment). But if XP Mode was the issue why can I load the ArduIMU????

 

5. TheArdupilot board has the SparkFun LED lightshow firmware installed from factory. As this is working, does that mean the bootloader cannot be corrupt?????? Or could the lightshow software boot but other parts of the bootloader be corrupt?

 

6. I'm powering the board off a nice fat RX battery, so power isn't he problem.

 

I don't want to go to the expense of a bootloader programmer if the bootloader is clearly working because the lightshow software works.

 

PLease please any guidance greatfully received!!!!

 

 

 

 

You need to be a member of diydrones to add comments!

Join diydrones

Email me when people reply –

Replies

  • Thanks Peter,

    That's certainyl another avenue to investigate!!!! I had assumed the Cool Components FTDI cable had come from Sparkfun/DIY Drones. I'll get a Sparkfun USB adpater ordered up!!!!!
  • Hi Raytrace Nomad, appreciate your help!

    Yep, I've been through this entire list carefully, twice!

    Still no joy.

    You do need to power up the Ardupilot seperately.

    I've just placed an order for the bootloader programmer as its the only thing I can think that's left to try! Tried the process on a totally seperate laptop and still no luck.

    Thanks again

    D
  • HI , you don't need to power unit from another battery in ardupilotmega but i'm not sure in ardupilot ?

    You can use debuggins tips page http://diydrones.com/profiles/blogs/arduino-debugging-tips

    1. Did you check the "Set RTS on close" box in the Windows Com port, as instructed in the manual?
    2. Is your FTDI cable plugged in the right way? The black wire or side marked "black" should be on ArduPilot's BLK pin.
    3. If you have the older ATmega168 board did you select "Arduino Diecimila" as the board in the Arduino Tools menu? If you have the newer ATmega328 board, did you select "Arduino Duemilanova w/ATmega328"?
    4. Are you using the DIYDrones FTDI cable? We've had trouble with other ones...
    5. Is the cable plugged into a USB hub? That can sometimes cause trouble. Try plugging it straight into your PC.
    6. Is the ArduPilot board powered on, ideally through your RC system or ESC? (You can NOT power it from the FTDI cable; this is a safety measure to avoid power conflicts.)
    7. The board is set up to auto-reset when you load a sketch with the FTDI cable, so you don't have to manually press the reset button to get the bootloader. If that's not working for you, check the RTS setting in your PC's port settings ("Set RTS on close" should be checked) as described here. [Note: if you're using Linux, there's no direct equivalent to this. Instead, you may have to unplug the USB and plug it back in every time you want to upload code]
    8. Are you using the latest FTDI drivers? Install them if not. If you're still having trouble, try reinstalling them.
    9. If you're using the Version 1 (red) shield, you should unplug you GPS module before loading code. The Version 2 (blue) shield does not require this.
    10. Other errors that have caused this problem in the past include a power source (such as your ESC) that is putting out a voltage outside the acceptable range of 4-7v, faulty FTDI cables, and corrupted FTDI drivers. When in doubt, try a different power source, a different cable or a different PC.
This reply was deleted.

Activity

DIY Robocars via Twitter
RT @masato_ka: 距離センサを3つとESP32を付けたラジコンカーをDonkeyCarライクにNNで自動走行。3層FC極小モデルをTensorFlow Lite for microcontrollerで動かしてる。機体は借り物でRumiCarって言います。Tenso…
7 hours ago
DIY Robocars via Twitter
RT @SmallpixelCar: My car was able to go all the way autonomously until the crosswalk. It was only 100 yards from the target. What should b…
yesterday
Liam left a comment on Agricultural UAVs
"Hi
I'm Liam from T-MOTOR. I would like to reach out to see if there is any possibility for us to work together.
We are a propulsion system manufacturer who offers motors, propellers and ESCs for all kinds of drone applications which vary from secur…"
Wednesday
DIY Robocars via Twitter
RT @SmallpixelCar: Smart move. The car used the shadow to guide it through the bridge. This was never in the training samples. But it learn…
Wednesday
DIY Robocars via Twitter
RT @SmallpixelCar: Getting closer to the target. Single camera. Untrained road. https://t.co/Wsr7RwDamj
Jun 29
Richard Cox left a comment on Australia
"Anyone in the DIYDRONES Australian subgroup based in Alice Springs, NT?
I am experimenting with Ardupilot (standard Arduplane), Pixhawk 4 FC in a 4-ch
RC "AXN Floater Jet" foamy plane..."
Jun 29
Omar Sykes left a comment on Australia
"Hi everyone, I am looking for someone who is good at drone building, repair and software in Adelaide. Please give me a call on 0477 319 219."
Jun 29
DIY Robocars via Twitter
RT @RoboticMasters: #donkeycar https://t.co/czuLoVRcA4
Jun 29
DIY Robocars via Twitter
https://t.co/DKQbNTbz0g
Jun 29
DIY Robocars via Twitter
RT @RoboticMasters: Donkey car, car car car car car car; Donkey car, car car car car car car; Donkey Car. Anyone like our tiny tiny donkey…
Jun 29
DIY Robocars via Twitter
RT @SmallpixelCar: After improving DBSCAN speed, I can get 11 frame per second on @NVIDIAEmbedded Jerson Xavier MAXN mode and the autonomou…
Jun 26
DIY Robocars via Twitter
RT @Heavy02011: Join us at next Virtual Race League: ⁦@diyrobocars⁩ Race #4 - Parking Lot Nerds, August 1st https://t.co/5KUpu7VGaH
Jun 25
DIY Robocars via Twitter
RT @SmallpixelCar: #CUDA implementation should be easy, because most of the time is on distance calculations berween two points and if the…
Jun 25
DIY Robocars via Twitter
RT @SmallpixelCar: This is the view from the car. Even my lanenet inference is fast on @NVIDIAEmbedded Jerson Xavier, DBSCAN clustering tak…
Jun 25
DIY Robocars via Twitter
RT @SmallpixelCar: Ran my car in the park, with single camera and @sparkfun IMU. #TensorRT on @NVIDIAEmbedded Jetson Xavier. Lanenet one fr…
Jun 24
DIY Robocars via Twitter
RT @SmallpixelCar: Making progress on drive the car autonomously in my neighborhood. This run used single camera only. No other sensors. ht…
Jun 24
More…