Power Module Failure?

Hey guys, I was working on my 3DR quad today and ran into an odd problem.

Everything was working fine when I connected the battery, motors spun, APM2.5 worked, all peachy.

Then I decided that I'd try to get the APM to stabilize the gimbal tilt. I connected via Mission Planner, attempted to set the stabilize mode and got the message: "Set MNT_STAB_TILT Failed 2"

Ok, so no go on that. No problem (for now). So I disconnected the servo from output 11 and hooked the battery back up. Now the APM won't turn on. The ESCs get power because they're chirping away to indicate that all is not well. If I connect the USB cable to APM, everything functions fine. As soon as I disconnect it the APM is dead.

I checked the voltage on the 3DR Power Module via the pads on the back of the APM connector cable and it indicated that there was only 0.7 volts going to the APM. Huh?!

This is puzzling to me, as I never intended to change any settings for the Power Module. Could it have died all of a sudden? Is there a way to configure it? I'm at a loss here, I was intending to fly this afternoon!

Thanks in advance.

You need to be a member of diydrones to add comments!

Join diydrones

Email me when people reply –


  • Is there any generic problem with the 5v regulator on the 3DR Power Module (PM). I did 4 flights with my brand new PM and operating strictly on 3 cell lipo (i.e. never attempted 4 cell at any time). After the fourth flight I tried to power up the APM 2.6 and no joy. Checked the PM output and its at 0.45 v. Can the PM suddenly die on you - I mean a normal flight and then at next power up on board regulator is dead. I removed the PM and restored the jumper to power the APM from my ESC and all normal. Flying normally again without the PM. Is the reliability of the PM so poor??

  • My PM exploded recently after connecting a freshly recharged battery.  Very strange since I was connecting everything exactly the same way without any issues for three months before it happened.  I think it fried my APM board too.


  • Humm.. Seeing a # if this recently, since, I too had a PM failure on the ground with plugging it in using a 4S pack after months of successful usage..Powering APM, RX with jumper off, telemetry and GPS+mag only..

  • Yes, unfortunately I'm another to join the club, and I wasn't as lucky to resolve this issues like the rest of you before something catastrophic happened.

    My configuration...



    PDB > GIMBAL (Note that I power my gimbal, AlexMos board directly from the PDB/battery)



    3DR PM > APM > RADIO

    I was flying the quad for an event in safe space as usual (thank the Lord), for about 15 hours over a 3 day period. Another routine flight, filming, and BAM, complete power failure and the bird fell out of the sky like a bag of bricks crashing the pavement 100+ feet below. Basically completely destroyed everything (except the APM and my ESCs). Looking at about $1k in damage at this point.

    As everybody else, diagnosing the source: connected a full batter to the PM, the PDB output read 16.60V, and the 5+V output reads 0.7V. Looks like the 3DR Power Module is completely fried, causing the crash. 

    Hopefully others see this issue and resolve it before it gets to this point. 

  • Yeah. One of my 3DR power modules died a couple of months ago after several successful flights with the almost the same output voltage now. Good thing it died during some SOP bench warming before flight. The APM board output rails were powered separately and yet it seems that it can still fail after continued use. It was powering only the APM 2.5 board, the wireless telemetry unit, and the GPS.  

  • Hi, unfortunately i can join your club now.

    i have purchased an APM2.5 with power module some weeks ago and used it on my 2 month old quad.

    it woked quite good for some weeks. hoovering, position hold, altitude hold etc working fine, some minutes ago, without changing anything i tested the quad with new props 9x5 props instead 10x6 which i used previously. there was no other change.

    i could hoover a bit over my bed in case it would fall but everything work fine except the pid were not fine tuned, but nothing that prevented from hoovering. so i decided to connect it via 3DR radio. the radio was not connected due to the testflight, so i connected it to the copter attached the power and got no connection in mission planner. that was the moment i realized the apm was not powered. only the ESCs were beeping.

    the jumper was not set. there were no servos attached. the reciever was the only module powered by the apm

    The voltage i can measure at the powermodule is 0,57V when testing the 5V pin and ground.

    there are no shorts.

    when powering the apm2.5 via one of the UBECs with jumper set the apm still works, mission planer gets connection via 3DR Radio. no further test made; finger crossed that nothing else is damaged.

    alltogether i think it's the same problem you had. did you solve your problems with the power module?

    did you have to send it back?

    since i live in germany the shipping costs are so high, so i hope you have found a solution without purchase a new power module. or sending the dead one back

    are there any problems known regarding the powermodule?

  • T3
    How are you powering the gimbal? Is it through the APM?
  • Ok, so another bit of information: When powering the APM via the USB cable, if I attach the gimbal servo cable, the APM turns off and won't start again until I disconnect the USB and battery and reconnect without the servo cable connected. So, it appears that the micro servo draw is browning out the APM. Fair enough, but even when that's not connected, the output of the Power Module is still 0.8 something volts. I can't figure this one out...

This reply was deleted.


Gremsy liked Gremsy's profile
Mar 12
DIY Robocars via Twitter
RT @chr1sa: Donkeycar 4.4 released with tons of new features, including path learning (useful with GPS outdoors), better Web and Lidar supp…
Nov 27, 2022
DIY Robocars via Twitter
RT @NXP: We are already biting our nails in anticipation of the #NXPCupEMEA challenge! 😉 Did you know there are great cash prizes to be won…
Nov 24, 2022
DIY Robocars via Twitter
RT @gclue_akira: レースまであと3日。今回のコースは激ムズかも。あと一歩 #jetracer https://t.co/GKcEjImQ3t
Nov 24, 2022
DIY Robocars via Twitter
UC Berkeley's DIY robocar program https://roar.berkeley.edu/
Nov 24, 2022
DIY Robocars via Twitter
RT @chr1sa: The next @DIYRobocars autonomous car race at @circuitlaunch will be on Sat, Dec 10. Thrills, spills and a Brazilian BBQ. Fun…
Nov 24, 2022
DIY Robocars via Twitter
RT @arthiak_tc: Donkey car platform ... Still training uses behavioral cloning #TCXpo #diyrobocar @OttawaAVGroup https://t.co/PHBYwlFlnE
Nov 20, 2022
DIY Robocars via Twitter
RT @emurmur77: Points for style. @donkeycar racing in @diyrobocars at @UCSDJacobs thanks @chr1sa for taking the video. https://t.co/Y2hMyj1…
Nov 20, 2022
DIY Robocars via Twitter
RT @SmallpixelCar: Going to @diyrobocars race at @UCSDJacobs https://t.co/Rrf9vDJ8TJ
Nov 8, 2022
DIY Robocars via Twitter
RT @SmallpixelCar: Race @diyrobocars at @UCSDJacobs thanks @chr1sa for taking the video. https://t.co/kK686Hb9Ej
Nov 8, 2022
DIY Robocars via Twitter
RT @PiWarsRobotics: Presenting: the Hacky Racers Robotic Racing Series in collaboration with #PiWars. Find out more and register your inter…
Oct 23, 2022
DIY Robocars via Twitter
RT @Hacky_Racers: There will be three classes at this event: A4, A2, and Hacky Racer! A4 and A2 are based around UK paper sizing and existi…
Oct 23, 2022
DIY Robocars via Twitter
Oct 23, 2022
DIY Robocars via Twitter
Oct 19, 2022
DIY Robocars via Twitter
Oct 18, 2022
DIY Robocars via Twitter
RT @NeaveEng: Calling all UK based folks interested in @diyrobocars, @f1tenth, @donkey_car, and similar robot racing competitions! @hacky_r…
Oct 13, 2022