Problem connecting Pixhawk and Futaba receiver


Two of my customers have trouble setting up the Pixhawk - I myself have a Pixhawk, but don't use a Futaba receiver, thereby I can't replicate the problem (I would like to find out if the problem is connected to the receiver they use, or something else).

Both use a Futaba R7008SB receiver.
Both managed to upload the Firmware to their Pixhawks - but they are not able to do the radio calibration (the Pixhawk doesn't "see" the receivers, the bars in the calibration are all grey).

They have nothing else connected to the Pixhawk, except receiver (connected to the right port / RC), buzzer, safety switch and USB cable.

The Pixhawk signals via the big LED "pre-arm check failed" (which makes sense ;)

They power the Pixhawk via USB and at the same time with a LiPo (via the Power Module).

The receiver is "found" by the remote, the LEDs are on, the setting of receiver and remote (regarding the use of the SBUS) seems to be right. They use the right port of the receiver to connect to the Pixhawk.

I am happy about any suggestions ...

Thanks a lot in advance


You need to be a member of diydrones to add comments!

Join diydrones

Email me when people reply –


  • We have a Futaba 8J and the Pixhawk in a Y6 configuration. We had similar trouble as you described while building the kit. We first wired the Futaba receiver to the Pixhawk S. bus port. The receiver and tranmitter would not link. So, we switched the connection from S. bus to RC slot right next to the S. Bus connection on the Pixhawk. The link was established immediately after pushing the almost invisible button on the Futaba receiver. The Futaba transmitter was communicating perfectly with the receiver and the Pixhawk. Perhaps this will assist.
  • To All

    Please show off the model of Futaba S-BUS receiver and firmware version.

    The reason is that FrSky S-BUS receiver may not have those communication issue.

    Later from ArduCopter 3.1.1 rc1, the firmware is told officially support Futaba S-BUS.

    Sometimes, the Futaba S-BUS may not be an industrial standard from the view of signal consistency?!

  • Just tried it with my R7008sb and same problem as everyone else here is having... doesn't work. Changed mode to Sbus, used Sbus / 8 Pin (tried SBus2 also). Strange thing is that it works fine with my R2008sb using same T14SG Tx. With 2008sb, radio calibrates perfectly and outputs good PWM signal.

    Now I'm having an issue with my ESCs not playing well with that PWM output for some reason. They won't spin even though I know PWM is coming out of the signal rail (confirmed with servo in place of ESC, and on MP ch3in ch3out readings).

  • I had an issue at first.  Labeling on the Pixhawk is a bit confusing.  I plugged my SBUS signal at first into the SBUS labeled port on the Pixhawk which is wrong.  Once I moved the signal over to RC IN everything worked fine.  I have a R6208 receiver and X8R.

    I didn't read the instructions at first - just plugging things in.  Labeling could be more clear - change SBUS to SBUS OUT on the Pixhawk.

  • Same problem here, 7008 with Futaba 18mz or Futaba 14sg, Very frustrating because

    using the APM's was a snap, no problems. I had two PixHawks and both exhibit the same

    problem no power up the Pixhawk. I have spent hours on this with  and no success.

  • Developer
    It was working for me, except an issue with the range now fixed. I'll verify again in the morning.

    Also make sure your pixhawk is making the right successful boot sound, you may need to hold the safety button and power it on the flash the PxIO board (newer FW does this automatically)

    See http://copter.ardupilot.com/wiki/common-load-firmware-px4/#Load_Fir...
    And listen to these sounds http://copter.ardupilot.com/wiki/common-apm-board-leds/#PixhawkPX4_...
  • My solution was to use a cppm frsky rx

  • I just received the pixhawk, and i am facing the same problem of getting connect with Futaba sbus receiver  7008sb, 6203sb,  ... there is no any value output at MP.  All same as subject described.

  • I would like to know the receiver model number of Futaba that is operational with Pixhawk.

    There is no S-BUS compatible servo or gyro other than Pikhawk in my hand.

  • I have same S-BUS connection problem R6303SB receiver to Pixhawk.

    ArduCopter 3.1.1-rc1 is out in the Mission Planner’s Beta Firmwares link.

    And It should be improved for Futaba SBUS receiver support. However, it looks no help for me.

    Actually, the connection of FrSky TFR4B is just fine.

This reply was deleted.


Santiago Perez liked Santiago Perez's profile
19 hours ago