Problem connecting Pixhawk and Futaba receiver


Two of my customers have trouble setting up the Pixhawk - I myself have a Pixhawk, but don't use a Futaba receiver, thereby I can't replicate the problem (I would like to find out if the problem is connected to the receiver they use, or something else).

Both use a Futaba R7008SB receiver.
Both managed to upload the Firmware to their Pixhawks - but they are not able to do the radio calibration (the Pixhawk doesn't "see" the receivers, the bars in the calibration are all grey).

They have nothing else connected to the Pixhawk, except receiver (connected to the right port / RC), buzzer, safety switch and USB cable.

The Pixhawk signals via the big LED "pre-arm check failed" (which makes sense ;)

They power the Pixhawk via USB and at the same time with a LiPo (via the Power Module).

The receiver is "found" by the remote, the LEDs are on, the setting of receiver and remote (regarding the use of the SBUS) seems to be right. They use the right port of the receiver to connect to the Pixhawk.

I am happy about any suggestions ...

Thanks a lot in advance


You need to be a member of diydrones to add comments!

Join diydrones

Email me when people reply –


        • Wish I knew. What I understood from the documentation is that if you go to the screen where you can set it up and flip switches on the transmitter then the correct row will highlight and you can choose

          Either my transmitter isn't sending anything though the channels or the Pixhawk isn't picking up anything or maybe it just doesn't work and the documentation is wrong

          Going to remove the Pixhawk from the equation tomorrow and see if the switches move a servo connected to the receiver. If this doesn't work at least I know the transmitter isn't set up to send anything yet and I need to figure out how to do that. Been reading the Futaba book, but couldn't get a picture to translate the names they give s1, j1 and so on to the switches and dials on the transmitter.
  • Hey guys, noob here with futaba 14sg and 6303sb on its way for a 3dr diy quad. Will the 6303 sb work with pixhawk? This thread is quite confusing. Wiki says 6303 works users is this thread says it does not. Can someone please clarify? Thank you.
  • SBus doesn't seem to be working at the moment.  I would say best option is just to buy the PPM Encoder and use that for now

    I went back to SBus, because I couldn't just leave the problem alone just to try things again after it was working with the PPM Encoder

    This is what I did

    Reverse throttle on the transmitter

    Plug a battery into the Pixhawk

    Flash 3.1.4 of any firmware

    Plug the GPS in correctly as shown in the picture.  Note, there are more pins on the Pixhawk than on the cable


    Leave the Pixhawk outside for a couple of minutes until it can find the GPS

    Plug it back into your machine

    Connect using Mission Planner

    Can't see the transmitter

    • 3.2-rc1 support R7008SB.

      Download : MP beta firmware.

      • I will try that again tonight, but last time I couldn't get past the RC failsafe with the beta firmware.

        • Failsafe check mode changed in 3.2.

          Only activate when ARMED so you can test it without battery only usb.

  • Does anyone have a step by step guide on how to overcome this problem? After reading all the comments I am not sure what does and doesn't work.

    I have received my pixhawk today and have a T14SG radio and R7008SB receiver. I have set the receiver to mode B and plugged the servo cable into channel 8 on the receiver and RC in on the pixhawk. Is there anything I need to do on the Tx? It is currently set to FASSTest-14CH.

  • I decided to buy the PPM Encoder because of the issues I have been having.  I was able to even arm the Pixhawk using the PPM Encoder.  So I am able to use the current release.  I found a video online to show how to arm the Pixhawk (https://www.youtube.com/watch?v=8u9DUDT2Ovg)  I don't remember seeing anywhere that you need to pull the two control sticks down and together of the transmitter to arm, but it works so I am happy.  Now I just need to get the servo connected to the Pixhawk

  • Developer

    @Kobus: The servo is not supposed to move (this would be quite dangerous during calibration, imagine you have an electric motor connected). Its also unpowered - the power supply is for the avionics exclusively, you need to provide servo power from a different source. It would be unsafe (in general, there are setups where it would be fine) to solely rely on the servo power for the autopilot.

    You need to arm the autopilot probably first - in general, I recommend to spend some time with the documentation to familiarise yourself with the system.

    • Thank you.  Been reading so much the past couple of week and all the information is scrambled by now.  I will start from the beginning again and work through now that I know the Sbus is working.  Been learning Pixhawk, Futaba SBus, Futaba receivers and transmitters, ESC, BEC, UBEC and and and.  When I worked with RC many years ago the transmitters still needed crystals and ESC's didn't exist so I have been catching up on probably 20 years of RC in the past couple of weeks

      I was about 70% sure the servo wouldn't work, but since the message on the screen always said to make sure things are disconnected I thought maybe, just maybe.  Didn't hurt to test.  Al least I didn't burn out any ports like I normally do with Arduino's :)

      I see the flashing I have is that RC failsafe has been activated so I will look at that tomorrow.  Also going to try the current firmware again just to double check that it is working with SBus since I know the new firmware now works with SBus

      Hopefully these posts will also help other guys now to get their Futaba SBus up and running

This reply was deleted.


DIY Robocars via Twitter
DIY Robocars via Twitter
DIY Robocars via Twitter
DIY Robocars via Twitter
RT @f1tenth: Say hi to our newest #F1TENTH creation for @ieee_ras_icra next week in Philly. It’s going to be huge! 😎 🔥 @AutowareFdn @PennEn…
DIY Robocars via Twitter
DIY Robocars via Twitter
May 8
DIY Robocars via Twitter
RT @SmallpixelCar: Noticed my car zigzagged in last run. It turned out to be the grass stuck in the wheel and made the odometry less accura…
May 8
DIY Robocars via Twitter
RT @SmallpixelCar: Test my car. RTK GPS worked great. Thanks @emlid for their support. https://t.co/EkQ6qmjmWR
May 8
DIY Drones via Twitter
RT @chr1sa: @kane That's @diydrones circa 2009. Still have a box of those Canon cameras that we used to strap into planes, just like this.…
May 3
DIY Robocars via Twitter
RT @chr1sa: Our next @diyrobocars race is going to be outside at a real RC racetrack in Fremont on May 28. Fully autonomous racing, head-to…
Apr 30
DIY Robocars via Twitter
RT @f1tenth: Our Spring 2022 F1TENTH course @PennEngineers is coming to an end with a head-to-head race as a big finale. So proud of our st…
Apr 26
DIY Robocars via Twitter
RT @DanielChiaJH: I wrote a thing! Throughout the development of my @diyrobocars car I've been using @foxglovedev Studio to visualize and d…
Apr 23
DIY Robocars via Twitter
RT @SmallpixelCar: My new car for high speed. Low body, everything ( @NVIDIAEmbedded Jetson Xavier NX, @emlid RTK GPS, IMC) under the deck…
Apr 23
DIY Robocars via Twitter
Apr 21
DIY Robocars via Twitter
RT @f1tenth: F1TENTH Race training setup @PennEngineers for our upcoming ICRA2022 @ieee_ras_icra competition. @OpenRoboticsOrg @IndyAChalle…
Apr 21
DIY Robocars via Twitter
RT @fatcatFABLAB: Proud to be hosting a restarted DIY Robocars NYC Meetup April 26. Come by if you want to talk about and race self-driving…
Apr 17