Distributor

Problem connecting Pixhawk and Futaba receiver

Hi

Two of my customers have trouble setting up the Pixhawk - I myself have a Pixhawk, but don't use a Futaba receiver, thereby I can't replicate the problem (I would like to find out if the problem is connected to the receiver they use, or something else).

Both use a Futaba R7008SB receiver.
Both managed to upload the Firmware to their Pixhawks - but they are not able to do the radio calibration (the Pixhawk doesn't "see" the receivers, the bars in the calibration are all grey).

They have nothing else connected to the Pixhawk, except receiver (connected to the right port / RC), buzzer, safety switch and USB cable.

The Pixhawk signals via the big LED "pre-arm check failed" (which makes sense ;)

They power the Pixhawk via USB and at the same time with a LiPo (via the Power Module).

The receiver is "found" by the remote, the LEDs are on, the setting of receiver and remote (regarding the use of the SBUS) seems to be right. They use the right port of the receiver to connect to the Pixhawk.

I am happy about any suggestions ...

Thanks a lot in advance

Felix

You need to be a member of diydrones to add comments!

Join diydrones

Email me when people reply –

Replies

      • Moderator
        Thanks for all the info guys, I had it running for a while ( throttle needed reversing but all else was good). Strangely after 5 or so minutes it all went wrong. The roll now also does throttle and yaw, the throttle only does channel six and everything else is inop- I swear I did nothing! I'm sure this is a personal issue, kobus is right- it's a lot of new tech to get on top of quickly. Happy days!
        • Moderator
          Hmm, ran with qcontrol to check-same issues. Reflashed back with mission planner and it all works again. Think I will wait for stable version, just incase - the machine is too valuable......
  • Is this currently working for everybody?  I read all the comments before I bought my receiver and the Pixhawk and assumed since this was a couple months ago it should be in the current firmware by now

    I setup my R7008SB receiver to SBus (led flashes red twice)

    The transmitter (T14SG) has been setup in the link menu as FASSTest-14CH Single G

    I am able to link my receiver to my transmitter and connect a servo on the receiver and the servo moves when I move one of the sticks on the transmitter so I know the messages are coming through to the receiver

    I have the cable plugged into channel 8 on the receiver and on RC on the Pixhawk.  The receiver is powered from the Pixhawk so I know the connection is the correct way around.  The Pixhawk flashes yellow twice and then off so it has an issue

    I installed Mission planner and used the Wizard to setup the Pixhawk.  I installed Quad 3.1.3 on the Pixhawk.  When I get to the point where the Pixhawk should detect the messages from the receiver it doesn't show any messages on the screen

    I also tried using the manual setup and it doesn't see anything

    Here are some videos I recorded to give more information.  The videos of the Pixhawk are a bit dark, because the world is dark at the moment :)

    http://youtu.be/Dmk2AQAVQK0

    http://youtu.be/pxg_DLKRMWA

    http://youtu.be/0Aawev2i6RY

    http://youtu.be/Z-YAByRrKls (busy uploading as I am writing this)

    • Developer

      In this video here:

      http://youtu.be/0Aawev2i6RY

      You have not actually connected the receiver correctly with its S.Bus output port. You need to plug into a different slot on the receiver. That's the one port which is rotated 90 degrees from the other ports. The R7008SB definitely works.

      -Lorenz

      • I tried now also in the slot that I read was the SBus 2 slot.  Still nothing.  Not sure what I am missing, probably something small somewhere as these things always are.  Is there some way I can see if messages are actually arriving on the Pixhawk?

        I will try the D slot, so channels 9 to 14 tonight and see if that makes a difference.

        • Hi Kobus,

          Please wait for APM 3.2 release. The R7008SB will not work with T14SG, AC3.1.x and Pixhawk.

          My R300SB and T10J is just work fine with APM3.2 Dev.

          • Where can I download the 3.2 DEV version already built?  I tried to build the latest packages last night, but when I arrived at my PC this morning I had alot of errors saying it couldn't rename files and things like that.  Probably security issues on the machine

            • http://firmware.diydrones.com/Copter/latest/

              Select your mode type and download ArduCopter-v2.px4 file version.

              In mission planner select load custom firmware.

              (If you cant see this menu switch on advanced view in config/tuning-planner menu)

              • I believe I am closer.

                I flashed the latest firmware in Mission Planner then I went to QGroundControl to calibrate RC.  The female voice keeps on going on about RC not calibrated while I am trying to calibrate it.  I was able to move throttle, yaw and roll, but nothing else.  I could do it for maybe 30 seconds and then I lost connection and couldn't get connection back again.  None of the switches are detected.  Not sure if they are supposed to be detected.  The throttle and pitch don't reach min or max, they are always a bit higher than min and a bit lower than max

                • Cause, you are not connected to Pixhawk.

This reply was deleted.

Activity

DIY Robocars via Twitter
RT @Heavy02011: #VirtualRaceLeague: @DIYRobocars Race #14 - #ParkingLotNerds join us January 15th for #AutonomousRacing #RoboRace ⁦@DAVGtec…
Monday
DIY Robocars via Twitter
RT @chr1sa: And after that came our races, 50 in all. This battle between these two Russians was the best we've ever seen -- incredible fig…
Monday
DIY Robocars via Twitter
RT @chr1sa: Before our @DIYRobocars virtual race this weekend, we had a presentation from the team that won the Indy Autonomous Challenge i…
Monday
DIY Drones via Twitter
Dec 12, 2021
DIY Robocars via Twitter
Dec 12, 2021
DIY Robocars via Twitter
RT @chr1sa: Just a week to go before our next @DIYRobocars race at @circuitlaunch, complete with famous Brazilian BBQ. It's free, fun for k…
Dec 4, 2021
DIY Robocars via Twitter
How to use the new @donkey_car graphical UI to edit driving data for better training https://www.youtube.com/watch?v=J5-zHNeNebQ
Nov 28, 2021
DIY Robocars via Twitter
RT @SmallpixelCar: Wrote a program to find the light positions at @circuitlaunch. Here is the hypothesis of the light locations updating ba…
Nov 26, 2021
DIY Robocars via Twitter
RT @SmallpixelCar: Broke my @HokuyoUsa Lidar today. Luckily the non-cone localization, based on @a1k0n LightSLAM idea, works. It will help…
Nov 25, 2021
DIY Robocars via Twitter
@gclue_akira CC @NVIDIAEmbedded
Nov 23, 2021
DIY Robocars via Twitter
RT @luxonis: OAK-D PoE Autonomous Vehicle (Courtesy of zonyl in our Discord: https://discord.gg/EPsZHkg9Nx) https://t.co/PNDewvJdrb
Nov 23, 2021
DIY Robocars via Twitter
RT @f1tenth: It is getting dark and rainy on the F1TENTH racetrack in the @LGSVLSimulator. Testing out the new flood lights for the racetra…
Nov 23, 2021
DIY Robocars via Twitter
RT @JoeSpeeds: Live Now! Alex of @IndyAChallenge winning @TU_Muenchen team talking about their racing strategy and open source @OpenRobotic…
Nov 20, 2021
DIY Robocars via Twitter
RT @DAVGtech: Live NOW! Alexander Wischnewski of Indy Autonomous Challenge winning TUM team talking racing @diyrobocars @Heavy02011 @Ottawa…
Nov 20, 2021
DIY Robocars via Twitter
Incredible training performance with Donkeycar https://www.youtube.com/watch?v=9yy7ASttw04
Nov 9, 2021
DIY Robocars via Twitter
RT @JoeSpeeds: Sat Nov 6 Virtual DonkeyCar (and other cars, too) Race. So bring any car? @diyrobocars @IndyAChallenge https://t.co/nZQTff5…
Oct 31, 2021
More…