I currently run my Mission Planner on my netbook with no real issues, but have managed to repair my . laptop that has a much bigger screen and faster processor . I have been trying to install Mission Planner on it but keep getting the same error. It says I need .net framework 3.5. I remember it said this on my XP netbook so I just downloaded the latest version o it and its worked well ever since. I have tried to do the same thing with this (Vista) laptop and it still gives me the same message every time,even though it has .net framework 4.5 installed.

My question is has anyone had this issue or knows a way round this please.

My laptop is running a fresh install of Vista so don't know what else to try really. If all else fails I am happy to keep using my netbook but the bigger screen would have been nice even if its running a horrible OS lol

You need to be a member of diydrones to add comments!

Join diydrones

Email me when people reply –


  • Probably no need to mention that Windows 7 and Windows 8 will both run much better on that laptop, if you can manage to acquire either.

  • Developer

    Please install .net 3.5 More than one version can exist at one time.

  • Moderator

    Are we positive the .Net install succeeded?

    Go to Programs And Features in Control Panel and take a look to see if Framework is up to date.

    I hope its not like Java, where you need the actual specific version the program asks for, even if you have a newer one.

    Also, is your version really 4.5?

    I do not believe that ver. is pushed through MS Update yet, I think 4 is the latest auto-update, ver 4.5 being available on the MS dev site.



    .NET Framework 4.5
    .NET Framework 4.5 is a highly compatible, in-place update to .NET Framework 4.
This reply was deleted.