Problem with APM2 powering up - my investigation...

Hey everyone,

Ive seen a few posts on the forum about power issues with the APM2.

 

http://diydrones.com/forum/topics/apm2-only-powered-over-input-rail-usb-not-output-rail

http://diydrones.com/forum/topics/apm2-will-not-power-from-output-rail

 

I just had mine to the same thing when I was swapping input connections to a RX.

 

Ive looked into the schematics and the board and it looks as if there is a problem with the D1 diode that connects the power jumper / 5V Rail on the input connectors / board to the 5V rail on the output pins...

 

I think I have tracked down the specific device used and I have a concern... I believe this is the data sheet...

 

http://www.onsemi.com/pub_link/Collateral/RB751S40T1-D.PDF

 

The problem is that the device is only rated at 30mA continuous forward current. Therefore if you are powering the unit via the output rail, the whole system cannot draw more than this (or a peak "surge" current of more than 500mA).

 

Has anyone else looked into or are aware this issue?

 

The other thing that Im now seeing is if I attach a standalone BEC to the 5V rail (via the input connections), the unit does not seem to boot up correctly.  I have measured the output from the BEC and it seems to be 5.5V. 

 

Does anyone know if this larger supply voltage (5.5V vs 5V) cause the unit not to operate correctly for some reason?

 

Thanks

 

Adrian

You need to be a member of diydrones to add comments!

Join diydrones

Email me when people reply –

Replies

  • Hello

    I´m not sure. Can i use this
    http://www.produktinfo.conrad.com/datenblaetter/175000-199999/18011...
    Diode (6v2) instant of the 1N5233 cause its difficault to get them here.

    thanks in advanced

    mfg milz

    http://www.produktinfo.conrad.com/datenblaetter/175000-199999/180114-da-01-en-BZX55_ZPD_6_2_V.pdf
  • I'm having issues with my APM2 board that I don't understand.

    • For a quad frame I am using a DJI flamewheel 450 kit with dji escs and motors.

    • I have a external CCBec for powering the output rail since these particular DJI escs don't have builtin bec capabilities. I still removed the positive leads from each esc control wire however, leaving just the signal and ground leads.

    • For a radio I am using a DX7 transmitter and a dsmx 7000 receiver

    • I can power up the APM2 thru the USB connection and completely configure my unit with the Mission Planner successfully without issues. Everything functional.
    vers GCS 1.19, firmware 2.6 mav10
    Flight modes set to stabilize across the board

    • When connecting the APM2 to a usb power source The POWER ON led turns on, the blue 3Dfix led flashes waiting for a fix, the gps lock led flashes. The armed led flashes waiting for me to arm the escs. This boot sequence takes a couple of seconds at most.

    • If I connect a flight battery while powering the APM2 board via usb ( irrespective of a running GCS session connection)
    I can arm and disarm and run the motors from my transmitter without issues.

    • Now if I try to boot the APM2 from the output rail with my CCBec set to the recommended 5.3v.
    My receiver powers on and binds on the input rail, I get the happy ESCs initalizing tones, the POWER ON led lights up, and the blue 3DFix led on the daughter board starts flashing but I don't get any ABC leds flashing ????

    • If I measure the voltage on the input rail I see the proper .3 volt drop with the jumper in place. I am using the same flight battery as a power source for both the CCBec and Escs sharing a common ground through the battery.

    Any ideas, why I can't seem to get the board to boot properly from the output rail? It just seems to sit there. I've gone through the wiki and there is nothing describing my problem. It would seem my diode is fine. I've tried reapplying the firmware and going through the config again, resetting the board via the reset button etc.

    No luck. Any ideas?

  • Developer

    Hi Adrian

    I have been investigating the power supply to the APM2 for the last couple of weeks and I appreciate you taking the time to look into this as well.

    What you have actually identified is an error on the schematic rather than the PCB.

    Diode D1 is listed as a RB751S40T1-D on the schematic, but it is actually a MBR0520LT1G.

    The RB751S40T1-D has the same footprint as the MBR0520LT1G, but it has a 500mA continuous current rating and thus has an appropriate current rating for the powering the APM2 which is ~200mA. 

    That is not to say the circuit is perfect.

    We see three common failure modes with the APM2:

    1. Unlike the APM1, the APM2 requires an external fuse when it is powered via the output rail.  The failure mode we see is that people are off by one pin when they connect something to the input rail and they short the +5V rail to the ground rail.    Because there is no fuse, diode D1 blows.
    2. Overvoltage on the +5V input damages the serial multiplexer.  There is good evidence to suggest that transients (perhaps from the motors and the ESCs) are causing an overvoltage situation and damaging the TSA23157, U7.
    3. Connecting the power supply to the APM2 backwards also damages the APM2, and generally it is the multiplexer that blows.

     

    We have made some changes to the input circuit and will be incorporating those changes in the next revision of the board, however in the meantime I recommend you reference the 

    Alternative ways to power your board 

    section of

    http://code.google.com/p/arducopter/wiki/APM2board

     

    What are we doing about it before the next release?

     

    1. As of last week, the MBR0520LT1G has been replaced with a MBR120VLSFT1 Schottky  diode which has a 1.0A  current rating.
    2. Starting this week, APM2s are shipping with an external 500mA Pico fuse to install between the power distribution board and the APM2, and also a 6.0V Zener diode to be installed in a reverse bias arrangement across the +5V rail to prevent damage in the case of over voltage or reverse voltage.
    3. The Pico fuse and the Zener diode will be made available from to anybody with a current APM2 who asks for them.

     

    If you want to save yourself some time and get these components yourself, you can find them here:

     

    http://www.digikey.com/product-detail/en/0251.500MRT1L/F3167TR-ND/7...

     

    and here

     

    http://www.digikey.com/product-detail/en/1N5233B-T/1N5233BDITR-ND/616

    Cheers,

    Craig

  • 3D Robotics

    Adrian,

    Yes, we are upgrading that diode, and new boards will be using a higher capacity one. It hasn't been an issue for most people, but there have been a significant number of cases where it burned out (about 50 of the first 1,000 boards) and had to be replaced, so your diagnosis is correct. 

    Chris

  • I've powered mine with a variety of different sources - UBEC, ESC BEC, etc, and haven't had noticeable trouble. Also, I've flown my Align TRex 600 with my APM board. This means that the board is powering 3 analog servos and a digital servo. Together these draw much more than 500mA peak (and I assume significantly high even continuous).

    I have had power-up issues with my board, but it seems those bugs have worked themselves out. I haven't had power issues in quite a while. I hope someone can shine some light on this topic a bit, because the power capabilities of the APM have always been a question of mine.

    Cheers!

  • More Info:

    After powering the unit up via the BEC (with 5.5V output), the unit does nothing for a quite a few seconds, then goes through the start-up LED sequence (rapid flashing alternatively red / blue then a slower alternatively flashing red/blue) then just gives me a single RED flashing LED which remains.

    I grabbed another ESC with BEC (5V output) removed the signal wire from the connector and attached this to the input pins / rail.  The unit then did the start up sequence flowed by the flashing red  and blue as if it has started up correctly.

     

    Is the APM2 that sensistive to the 5V supply rail? in firmware issue?

     

    WIth either supply (ESC w/BEC or just the standalone BEC) the 3DFIX light was flashing which would seem to mean that the GPS unit is up and working and seeking sats.

     

    Adrian

This reply was deleted.

Activity

DIY Drones via Twitter
RT @chr1sa: After more than a year of only virtual races, @DIYRobocars returns to the newly renovated @circuitlaunch on May 22 for the resu…
Sunday
DIY Robocars via Twitter
RT @DAVGtech: And now available with LiDAR 🔥 https://twitter.com/Heavy02011/status/1381137016381964293
Sunday
DIY Robocars via Twitter
RT @Heavy02011: #VirtualRaceLeague: @DIYRobocars Race #9 - #ParkingLotNerds #thunderhillracetrack, CA Join us for the next race April 24th,…
Sunday
DIY Robocars via Twitter
RT @DWalmroth: Weather's finally cooperating, looking forward to racing 1:10 scale autonomous cars outdoors again! @diyrobocars, @NVIDIAEm…
Apr 7
DIY Robocars via Twitter
RT @AIDRI_: I finally succeeded in optimizing the trajectory and speed of a car on a #racetrack. Next step: implement a 2d controller and…
Apr 7
DIY Robocars via Twitter
@jetdillo @circuitlaunch Actually the second *in person* event in a year. We do virtual races every month
Apr 2
DIY Robocars via Twitter
Update: we're moving it back one day to Sunday (the 4th) at 11:00am instead
Apr 2
DIY Robocars via Twitter
@GrantEMoe @circuitlaunch Update: we're doing it on Sunday (4th) at 11:00am instead
Apr 2
Laurie J. Troy liked Jasper Kueppers's profile
Apr 1
DIY Robocars via Twitter
RT @chr1sa: Maybe we should have a mini @DIYRobocars race in our lower school's playground https://t.co/xLFeua1R6X
Mar 29
DIY Robocars via Twitter
If anybody wants to join us for an informal outdoors hack/race we're going to be meeting at the @CircuitLaunch park… https://twitter.com/i/web/status/1375907409223249923
Mar 27
DIY Robocars via Twitter
RT @SmallpixelCar: Ready to reopen, innovation has to continue. Inside/outside, LiDAR/GPS, race/delivery https://t.co/jpmvttoHEd
Mar 26
DIY Drones via Twitter
RT @DAVGtech: By far best race yet! Congratulations to the winner @Heavy02011 🥇🏆🍾👏👏👏 @diyrobocars @donkey_car @NVIDIAEmbedded https://t.co/…
Mar 20
DIY Robocars via Twitter
RT @Heavy02011: #VirtualRaceLeague: @DIYRobocars Race #8 - #ParkingLotNerds ⁦@DAVGtech⁩ ⁦@DWalmroth⁩ ⁦@OttawaAVGroup⁩ - join us tomorrow h…
Mar 20
DIY Drones via Twitter
RT @mrpollo: 11 years ago, the pxIMU was announced to the world on @DIYDrones, and it changed the life of many (mine included). The followi…
Mar 18
DIY Drones via Twitter
RT @ishcahealth: This is awesome! ☘️ @DroneDJ @DIYDrones @WorkerDrones @DroneMedia_UK @dublinaviation https://twitter.com/media_ireland/status/1372077878536462336
Mar 18
More…