I'm having a problem getting the APM2 to work with the DJI ESCs and motors I just got.

I have the DJI 30amp 11.1V ESCs with the DJI 920KV motors. I have everything plugged in into the APM2 and when I plug the battery in all the ESCs/Motors give the abnormal input signal beeps and none of the LEDs turn on on the APM2. When I plug the APM2 into the computer via the USB (before I connect to the Mission Planner) and than plug in the battery I get the ready beeps. When I disconnect the USB (with the battery still plugged in) I get the abnormal input signal beeps again.

I know that the APM2 I have can work because I built a GAI 500x with the APM2 on it and it flew wonderfully.

Any thoughts?

UPDATE: I ran through the configuration in the Mission Planner and after I did that I was able to run the motors command in the CLI and it worked! I was even able to arm and throttle up the quad when it was plugged into both the computer and the battery. But I still get the abnormal input signal beeps and no APM2 lights with only the battery plugged in.

Views: 3063

Reply to This

Replies to This Discussion

Which version of the code are you using? Have you calibrated the ESCs with the autocalibration method?

I am running 2.5.5 quadcopter.

I heard that the DJI ESCs were different from others so I wasn't sure if I should run my normal calibration routine with them.

Not sure. I've never used them. Worth trying, however. In general, things won't work right until you calibrate the ESCs, as is the case with most multicopters. 

With the APM2 hooked into the computer and the battery I am able to spin up all the motors. Would this be possible if the ESCs weren't calibrated?

Problem (maybe) solved.

The DJI ESCs do not have a BEC inside of it so you cannot power the APM through the ESCs tri-cable (which is what was happening with the GAUI we had).

So we are getting a 5A BEC and soldering it to the power distribution plate that comes with the Flame Wheel. Hopefully it will work by putting the power into the unused pins next to the ESC tri-cables.

Jake your problem is probably that DJI escs are opto isolated EScs and contain no BEC. This is why your APM wont light up. The DJI's wont power the APM. You need to wire in a UBEC to a spare channel on the APM to power it for flight. UBECs are available everywhere. Good luck!
Wow!we were typing that at exactly the same time!!!

So how is it working for you?

I'm trying to do the same thing. I've got it powered up ok - but and experiencing violent flipping as soon as I hit the throttle.

I have a F450 flying with DJI ESC's and motors.  I'm powering via a hobbyking BEC, and didn't have to do any esc calibration to get the thing flying. Some rate Kp adjusting was needed with 10" props.

David, are all of your motors hooked up in the correct order?  Are your motors spinning in the right direction for the right props?  (best to check that with the props off).

Yeah - I checked that. All the props are spinning the right way (down wash).

Did the terminal > setup > motors thing. Just like in the sample wiki video; motors starting with front right and moving ccw all fire normally.

It's the craziest thing. This is the 4th multirotor I've built (first using APM) and I'm having a hell of a time.

I've going to change the BEC I'm using to power everything but I know that won't be the problem.

I'll shoot a video and post it - showing board orientation is correct and props are correct.

Reply to Discussion

RSS

© 2019   Created by Chris Anderson.   Powered by

Badges  |  Report an Issue  |  Terms of Service