Guys,

  I am a little confused why I can't get the quad rotor of my Quad Plane working. I have four Hacker motors installed on my fixed wing Anaconda with 4 Castle ESCs. 

As per the instructions I have the motors plugged into channel 5 thru 8 on the pixhawk. Channel 1 is aileron, channel 2 is elevator, channel 3 is throttle and 4 is rudder. 5 thru 8 are the quad rotors. The Red wire from the ESCs are cut due to each power lead from the ESCs goes into one PDB which is powered by a separate battery. 

I have two batteries. One plugs into the Power Module for the pixhawk which then goes into the Pusher Motor ESC. Of course the ESC is plugged into Channel 3 for the throttle and the power module is plugged into the pixhawk.  The other battery goes to the PDB for the quad rotor motors. 

I put Arduplane 3.6 on the pixhawk and after that was done I enabled Quadplane mode. I then refresh the params so I can see all of the Quadplane params. I then moved onto ESC calibration. I followed the instructions to enable q esc calibration. During the process I can not get the outputs on Channels 5-8 to change. My R/C remote is on Q_Stabilize and the plane is armed and I can't get the values to change. It is seeing the Input of the TX but it is doing no output. It holds at 1000 for each channel 5-8. 

When I plug in the pixhawk then plug in the quad motors they make their normal beeping sounds. When I arm the quad rotor and pusher motor they make the activating sound, but I can't get it to work with the throttle stick on Q_stabilized. 

You can however go to the Servo menu page and toggle each motor and they will make a chirp sound and barely spin. 

What am I missing? It seems to be a setting somewhere not allowing the Quad mode to fully activate. This has been a huge puzzle for me and I can not figure this issue out. 

Thanks for the help. 

Views: 912

Reply to This

Replies to This Discussion

Did you check the RCN functions for outputs 5 to 8? They need to be 33, 34, 35, 36 for motors 1 to 4 respectively.

Yes I have check this.

Just an update of what I tried to do problem solving....

Tried downgrading to previous 3.5 software. No luck. Tried hooking  in one of the signal lines from another quad copter to see if it is the ESCs and Motor I chose to use on my quad plane. No luck. I then took my X8+ 3DR Quad Copter and loaded APM Plane V3.6 into her and left channels 5-8 motors plugged in and tried it there. Still no luck. 

All outputs are just stuck at 1000 on the status page. I have turned off all arming also. I have also double and triple checked that R/C Functions are set right 33-36. 

There seems to be some setting somewhere that is not letting the quad rotor be controlled by the R/C remote it seems. I have done plenty of R/C Calibrations. 

Any ideas? 

Hi,

It looks like you solved your problem. What was the issue?

@Kevin  I also encountered the same problem, I would like to ask how to solve.

Hi, I have the same problem. Bix3 modified as per G Covey (tx for great article). Using a Pixhawk with rotors on Ch 5-9. Changed RC5-9 to 33-36.. Cannot do ESC calibration via Pixhawk. Can do them individually  from a separate rx transmitter so I know the motors and escs all work. Seems to work properly in regular flight mode but nothing in Q mode. Any hints would be greatly appreciated

Has anyone solved this? I have the same issue. Dead outputs for Q channels i havent tried to do the esc cal but i dont think its necessary. the servos arent even working... esc cal shouldnt affect servo output...

I would recommend posting your issue on the appropriate APM Plane release forum below. There are many active QuadPlane users (and developers) on the APM forums.

Arduplane Forums

Greg, I'm glad you posted, I'm hoping you can help!

I am indeed posting on the AP forum, and am trying to get my issue resolved. you seem to have quite a bit of experience working with Q_ parameters, perhaps you can help, i can use quite a bit of it!

What solves this issue??? Im working on vectored tilt rotor yaw but down have power to the motors/servos in anything other than MANUAL mode.....


Greg Covey said:

I would recommend posting your issue on the appropriate APM Plane release forum below. There are many active QuadPlane users (and developers) on the APM forums.

Arduplane Forums

Hi Pete,

Are you using a beta build from Tridge or are you making your own builds from master?

It sounds like your issue is something basic like either the quadplane feature is not enabled or your frame type is not set right. Have you posted your issue in the tilt-rotor thread in the Developers forum? This is where I see most of the activity on the tilt-rotor setups. I'll post the link below. I have only been using the QuadPlane setups and last summer used Tridge's initial tilt-wing build that had multiple issues...which he has since fixed. My tilt-rotor FireFLY6 planes use special firmware from BirdsEyeView Aerobotics.

Tiltrotor Support for APM Plane

Hey Greg, 

Yes, I'm using Tridge's Beta for Tiltrotor with Vectored Yaw Control.

I have Q_ enabled, and the frame type is set to 7 since its a Tri.

Just getting dead outputs and no input controls similar to what they mention above. I have been posting on the other forum but was hoping to grab your attention. Did you ever get Tridge's Tiltrotor Parameters to work in your build?

Thanks!

Reply to Discussion

RSS

© 2017   Created by Chris Anderson.   Powered by

Badges  |  Report an Issue  |  Terms of Service