Quad Plane Issues V3.6

Guys,

  I am a little confused why I can't get the quad rotor of my Quad Plane working. I have four Hacker motors installed on my fixed wing Anaconda with 4 Castle ESCs. 

As per the instructions I have the motors plugged into channel 5 thru 8 on the pixhawk. Channel 1 is aileron, channel 2 is elevator, channel 3 is throttle and 4 is rudder. 5 thru 8 are the quad rotors. The Red wire from the ESCs are cut due to each power lead from the ESCs goes into one PDB which is powered by a separate battery. 

I have two batteries. One plugs into the Power Module for the pixhawk which then goes into the Pusher Motor ESC. Of course the ESC is plugged into Channel 3 for the throttle and the power module is plugged into the pixhawk.  The other battery goes to the PDB for the quad rotor motors. 

I put Arduplane 3.6 on the pixhawk and after that was done I enabled Quadplane mode. I then refresh the params so I can see all of the Quadplane params. I then moved onto ESC calibration. I followed the instructions to enable q esc calibration. During the process I can not get the outputs on Channels 5-8 to change. My R/C remote is on Q_Stabilize and the plane is armed and I can't get the values to change. It is seeing the Input of the TX but it is doing no output. It holds at 1000 for each channel 5-8. 

When I plug in the pixhawk then plug in the quad motors they make their normal beeping sounds. When I arm the quad rotor and pusher motor they make the activating sound, but I can't get it to work with the throttle stick on Q_stabilized. 

You can however go to the Servo menu page and toggle each motor and they will make a chirp sound and barely spin. 

What am I missing? It seems to be a setting somewhere not allowing the Quad mode to fully activate. This has been a huge puzzle for me and I can not figure this issue out. 

Thanks for the help. 

You need to be a member of diydrones to add comments!

Join diydrones

Email me when people reply –

Replies

  • Hi, I have the same problem. Bix3 modified as per G Covey (tx for great article). Using a Pixhawk with rotors on Ch 5-9. Changed RC5-9 to 33-36.. Cannot do ESC calibration via Pixhawk. Can do them individually  from a separate rx transmitter so I know the motors and escs all work. Seems to work properly in regular flight mode but nothing in Q mode. Any hints would be greatly appreciated

  • @Kevin  I also encountered the same problem, I would like to ask how to solve.

  • Hi,

    It looks like you solved your problem. What was the issue?

  • Just an update of what I tried to do problem solving....

    Tried downgrading to previous 3.5 software. No luck. Tried hooking  in one of the signal lines from another quad copter to see if it is the ESCs and Motor I chose to use on my quad plane. No luck. I then took my X8+ 3DR Quad Copter and loaded APM Plane V3.6 into her and left channels 5-8 motors plugged in and tried it there. Still no luck. 

    All outputs are just stuck at 1000 on the status page. I have turned off all arming also. I have also double and triple checked that R/C Functions are set right 33-36. 

    There seems to be some setting somewhere that is not letting the quad rotor be controlled by the R/C remote it seems. I have done plenty of R/C Calibrations. 

    Any ideas? 

  • Did you check the RCN functions for outputs 5 to 8? They need to be 33, 34, 35, 36 for motors 1 to 4 respectively.

    • Yes I have check this.
This reply was deleted.

Activity

DIY Robocars via Twitter
RT @SmallpixelCar: Wrote a program to find the light positions at @circuitlaunch. Here is the hypothesis of the light locations updating ba…
yesterday
DIY Robocars via Twitter
RT @SmallpixelCar: Broke my @HokuyoUsa Lidar today. Luckily the non-cone localization, based on @a1k0n LightSLAM idea, works. It will help…
Thursday
DIY Robocars via Twitter
@gclue_akira CC @NVIDIAEmbedded
Wednesday
DIY Robocars via Twitter
RT @luxonis: OAK-D PoE Autonomous Vehicle (Courtesy of zonyl in our Discord: https://discord.gg/EPsZHkg9Nx) https://t.co/PNDewvJdrb
Wednesday
DIY Robocars via Twitter
RT @f1tenth: It is getting dark and rainy on the F1TENTH racetrack in the @LGSVLSimulator. Testing out the new flood lights for the racetra…
Wednesday
DIY Robocars via Twitter
RT @JoeSpeeds: Live Now! Alex of @IndyAChallenge winning @TU_Muenchen team talking about their racing strategy and open source @OpenRobotic…
Nov 20
DIY Robocars via Twitter
RT @DAVGtech: Live NOW! Alexander Wischnewski of Indy Autonomous Challenge winning TUM team talking racing @diyrobocars @Heavy02011 @Ottawa…
Nov 20
DIY Robocars via Twitter
Incredible training performance with Donkeycar https://www.youtube.com/watch?v=9yy7ASttw04
Nov 9
DIY Robocars via Twitter
RT @JoeSpeeds: Sat Nov 6 Virtual DonkeyCar (and other cars, too) Race. So bring any car? @diyrobocars @IndyAChallenge https://t.co/nZQTff5…
Oct 31
DIY Robocars via Twitter
RT @JoeSpeeds: @chr1sa awesomely scary to see in person as our $1M robot almost clipped the walls as it spun at 140mph. But it was also awe…
Oct 29
DIY Robocars via Twitter
RT @chr1sa: Hey, @a1k0n's amazing "localize by the ceiling lights" @diyrobocars made @hackaday! It's consistently been the fastest in our…
Oct 25
DIY Robocars via Twitter
RT @IMS: It’s only fitting that @BostonDynamics Spot is waving the green flag for today’s @IndyAChallenge! Watch LIVE 👉 https://t.co/NtKnO…
Oct 23
DIY Robocars via Twitter
RT @IndyAChallenge: Congratulations to @TU_Muenchen the winners of the historic @IndyAChallenge and $1M. The first autonomous racecar comp…
Oct 23
DIY Robocars via Twitter
RT @JoeSpeeds: 🏎@TU_Muenchen #ROS 2 @EclipseCyclone #DDS #Zenoh 137mph. Saturday 10am EDT @IndyAChallenge @Twitch http://indyautonomouschallenge.com/stream
Oct 23
DIY Robocars via Twitter
RT @DAVGtech: Another incident: https://t.co/G1pTxQug6B
Oct 23
DIY Robocars via Twitter
RT @DAVGtech: What a great way to connect why @diyrobocars community is so valuable and important! Have to start somewhere @IndyAChallenge…
Oct 23
More…