I have setup (mostly) a Pixhack, but I cannot get any form of RC detection. Have spent quite a few days trying to fix this, and I both hope and am worried I have missed something simple.

The Pixhack is calibrated for everything else (compass/gyro etc), using QGroundControl. I have tried APM Planner 2.0 and Mission Planner, but have the same issue. When attempting to calibrate the radio, I get an error message "0 RC channels detected". Mavlink inspector shows no RC packets. I have reflashed multiple times with differing firmwares to try and eliminate any firmware issues, and have tried powering via both battery and USB.

After flashing, I set airframe, calibrate sensors, and map RC channels 1-4 correctly, and 5 for mode switch. I go to RC calibration, and get the error above "0 rc channels detected".

The RC appears to all be working correctly. If I connect the output from the RX701 directly into the ESC, I can control individual motors. With the RX701 connected to the PPM encoder (v2 from UnmannedTech), the PPM encoder light flashing rate changes appropriately when I turn on RC transmitter.

I will be getting access to a multimeter soon so could test the PPM input/output? What should I be looking for? (could get access to an oscilloscope if really needed).

An oddity I discovered whilst trying to understand this, unsure if relevant:


I have connected to the autopilot with MAVProxy. When querying the RC_MAP_* parameters, I sometimes get 0 rather than the values that QGC sets/reads. If I set the values of RC_MAP_* with MAVProxy , QGC reads very large values. For instance, the mavproxy command 'param set RC_MAP_PITCH 2' causes QGC to read the value as 2^30.

Views: 915

Reply to This

Replies to This Discussion

 Ok, never used a PPM encoder, so this may not help....but, do you have multiple outs on your encoder? Or...on your rx, are you using a single out or one for each channel?

I ask, because I had the same issue with my setup. My tx/rx supports PPM, but Mission Planner showed no Radio activity on the  radio calibration and I got the same 0 RC channels error message, but once I switched to channel one out on the rx it worked fine.

Looks in your documentation if your Rx don't need a jumper or something like that (or the Pixhack)

The RX shouldn't require any jumpers - the documentation doesn't describe it, and I have all 8 channels connected to the PPM. The PPM had a jumper to solder to power the RX, but I have already done this.

Thanks for reply!

The PPM encoder takes in the 8 channels from the RX, and outputs to a single output cable that goes the Pixhack, but the Pixhack doesn't give a reading for any of the 8 channels.

Thank you, hopefully I won't have to recode it (seems a bit odd it needing recoding out of the box?) but will investigate.

Have you found a solution for this Jake?  I have also bought a Pixkack and am experiencing the same issue as you describe here.  I have a R-XSR sbus receiver.

Can it be this Inverted SBUS signal issue?  Does the Pixhack have a built in signal inverter or not?

Please advise.

Eric

Reply to Discussion

RSS

Groups

Season Two of the Trust Time Trial (T3) Contest 
A list of all T3 contests is here. The current round, the Vertical Horizontal one, is here

© 2018   Created by Chris Anderson.   Powered by

Badges  |  Report an Issue  |  Terms of Service