Hi all,

I have 3 planes with APM 2.5 units and one set of RFD900 modules.

In any plane I choose, I get slight jitter in the servos when I turn on the RFD900 radio.

So far I have installed a ferrite bead at the radio, added 0.1uf and 100uf cap at the radio and shielded the wires going to the radio.
I also tried running the radio from a different power source to no avail.

If I disconnect the tx and rx wires from APM but still have power applied to the radio then the jitter disappears so the noise seems to be coming through these wires.

Any other tricks to try? The radio is on a shielded lead about 30cm (12inch) from the APM2.5

Views: 1756

Reply to This

Replies to This Discussion

Are you saying you're shielding the wire between the APM and RFD900? If so, you don't need to really worry too much about that; what you're likely getting is currents induced in servo wires from radiation emitted from the radio's antenna; I've seen this myself when I had an RFD900, with 2 coaxial cables coming out of it to the antennas; those coaxial cables ran parallel near a servo wire (within <10cm) and caused severe servo juttering.

To fix it, simply move the RFD900 away from any servo leads; 15cm's distance should suffice; also try and have the antenna perpendicular to wherever wires are running, so that the servo wires sit in the middle or at the top/bottom of the antenna's radiation pattern (assuming you're using omnidirectional antennas).

I have moved it as much as I can. The jitter never goes away completely unless I disconnect from APM. I would wager that an optocoupler on the tx and rx lines would fix it. Yes the cable from APM to rfd is shielded.

Is this happening with pixhawk as well or only APM? 

My pixhawk is in the mail. So far I have only tried APM

Those radios have quite a distance. I had a similar problem and turned down the power on the radio a few dB. Not the perfect solution but it does work.

Hmm... this is not good... How do you turn the power down? in MP? 

Sorry for OOT: any one also experiencing gps glitch when using rfd 900?

In MP go to the "Initial Setup" tab and then with MP not connected select "Optional Hardware" and "3DR Radio". With the radio connected to your computer and the radio on your plane powered up click on the box at the top that says 'Load Settings'. Make sure you have the correct comm port and baud rate selected in the upper right before you do this but do not click the Connect button. You should see the settings for the two radios load in to the settings. In the right window which is is the 'Remote Version' lower the Tx Power setting. Click 'Save Settings' and you are done.

I've had that jitter too. Keep in mind it really isn't anything to worry about. But I did end up turning mine down a little. Yes in MP. Do not connect like you normally do. Instead click on 3dr radio. Then click on 'load settings' make sure you copter is powered on. it should load the settings for both the radios. The one you want to turn down in the remote. It's probably on 20 try turning it down to 14 see if that helps. You hit save settings to send it off to the radio in your copter. Don't  change anything else or it could get complicated :] 

Hi - I had this same issue with the 3DR 900mhz radio.  Depends on the servo whether or not the servo twitches due to the 900mhz 3DR radio some do - some don't. 

I found if I soldered a 33pf capacitor inside the servo between the incoming signal lead and ground I could filter out the glitch. 

Brian that's interesting. I will give that a go. Maybe time to pull out my oscilloscope. It's 100mhz so it won't see any 915mhz noise but it might give me a clue as to the PWM shape change with/without the capacitor.
Thanks for that. I decreased from 30 to 28Db. Jitter decreased substantially. Will try adding caps now.

Reply to Discussion


© 2019   Created by Chris Anderson.   Powered by

Badges  |  Report an Issue  |  Terms of Service