RFD900, RFD900+ - New long range radio modem

Hi All,

I would like to introduce you to a new radio modem that we developed for very long range datalinks!

http://rfdesign.com.au/RFD900.php

Some of the key features of the RFD900 are as follows:

  • Multi point and point to point link capability.
  • Long range >40km depending on antennas and GCS setup.
  • 2 x RP-SMA RF connectors, diversity switched.
  • 1 Watt (+30dBm) transmit power.
  • Transmit low pass filter.
  • > 20dB Low noise amplifier.
  • RX SAW filter.
  • Passive front end band pass filter.
  • Open source firmware / tools, field upgradeable, easy to configure.
  • Small (30 x 57 x 13 mm), light weight (14.5g).
  • Compatible with 3DR / Hope-RF radio modules.
  • License free use in Australia, Canada, USA, NZ.

 

These modems are designed to support long range applications, while being easy to use and affordable.  

These modems have been flying in various platforms and have demonstrated excellent performance in real applications. 

RFD900 modems are now available at: http://store.rfdesign.com.au

Support within APM planner and the radio configurator from Michael Oborne is already available.

It works seamlessly with APM planner, all radio Mavlink parameters are available.

Update, December 2014:  The RFD900+ with improved specifications is available now at:

http://store.rfdesign.com.au/rfd-900p-modem/

Seppo Saario

rfdesign.com.au

 

You need to be a member of diydrones to add comments!

Join diydrones

Email me when people reply –

Replies


  • How come you have ECC turn on ?

    I would turn it off


    Jeremy Stromsoe said:

    Raph,

    Wondering if this was ever narrowed down to a bad antenna or other source?  I'm having a very similar issue, see further down in this thread:

    http://diydrones.com/forum/topics/rfd900-new-long-range-radio-modem...

    Jeremy


    Raph said:

    Dear Seppo or anyone inclined to help,

    I've been struggling with this problem for a few weeks now; I have run out of ideas and turn to you for help. 

    Setup:
    APM 2.6 + external compass/gps running plane 2.78b
    -RFD 900 Telemetry Radios on both sides, running SiK 1.9. 3 DB antennas on the receiving side (tablet/PC size) and stock antennas on the plane.
    -1.3ghz for video (800mw)
    -ezuhf for control

    I've checked the noise levels with all my gear turned on, and I get 20-30 noise readings on local & remote (with about 90-110 value for RSSI)

    I cannot fly further than 150 meters without losing telemetry. I've tried changing my AIR_SPEED to 24 from 64, but does not help. I've also tried powering the local radio by USB and external BEC, same results. I have no issues with video or EZUHF; I can go as far as 35 minutes affords me without losing either.

    I am using two antennas on both RFD900 radios. I see some people are only using one? I haven't tried single antenna.

    Attached are pictures of the RSSI values, my configuration parameters & the plane layout. Any help, input or suggestions would be greatly appreciated.

    download?id=705844%3AUploadedFile%3A1657118&width=400


    download?id=705844%3AUploadedFile%3A1657119&width=400download?id=705844%3AUploadedFile%3A1657120&width=400

    Thank you!
    Raph

  • Seppo, could I use this antenna on the RFD 900 and still get 20+ miles or would this antenna harm the unit running it a full power? Im looking for the sleek form factor.

    https://www.readymaderc.com/store/index.php?main_page=product_info&...

  • Ivan,

    Did you ever find a solution to your range issues?  I'm having similar problems as seen in my post here.

    Jeremy



    Ivan R said:

    all sudden my RFD900 range has been drastrically reduced to a few hundred meters and I cant figure out why? I tried resetting all parameters to default, reflashing the firmware, checking all connection and no luck....what would be some reasons for this?

  • Raph,

    Wondering if this was ever narrowed down to a bad antenna or other source?  I'm having a very similar issue, see further down in this thread:

    http://diydrones.com/forum/topics/rfd900-new-long-range-radio-modem...

    Jeremy


    Raph said:

    Dear Seppo or anyone inclined to help,

    I've been struggling with this problem for a few weeks now; I have run out of ideas and turn to you for help. 

    Setup:
    APM 2.6 + external compass/gps running plane 2.78b
    -RFD 900 Telemetry Radios on both sides, running SiK 1.9. 3 DB antennas on the receiving side (tablet/PC size) and stock antennas on the plane.
    -1.3ghz for video (800mw)
    -ezuhf for control

    I've checked the noise levels with all my gear turned on, and I get 20-30 noise readings on local & remote (with about 90-110 value for RSSI)

    I cannot fly further than 150 meters without losing telemetry. I've tried changing my AIR_SPEED to 24 from 64, but does not help. I've also tried powering the local radio by USB and external BEC, same results. I have no issues with video or EZUHF; I can go as far as 35 minutes affords me without losing either.

    I am using two antennas on both RFD900 radios. I see some people are only using one? I haven't tried single antenna.

    Attached are pictures of the RSSI values, my configuration parameters & the plane layout. Any help, input or suggestions would be greatly appreciated.

    download?id=705844%3AUploadedFile%3A1657118&width=400


    download?id=705844%3AUploadedFile%3A1657119&width=400download?id=705844%3AUploadedFile%3A1657120&width=400

    Thank you!
    Raph

  • One thing I just noticed... both of my NODEIDs are set to 2.  Shouldn't one be NODEID=0 for the base node and one be NODEID=1 for the air side?  Could that be my problem?

  • Jamie, did you figure this out?  I'm also running MinimOSD and it works fine with the RFD900+.  You have to make a "Y" in the cable and send tx/rx wires to both the OSD and the RFD900.

    Jeremy

    Jamie Glover said:

    Seppo, is there a wiring diagram for this, utilizing Minim OSD with it? Im still hunting, but it looks as though I can only use either telem or osd, not both at the same time.. but Im betting thats incorrect. Any ideas where to find a similar setup. Im not trying to fry anything.

     

    Thanks

    Jamie

    PS, I did get the package. I had to track it in USPS after it got state side.

  • Additionally, here's what Mission Planner spit out for my settings for the ground side.  Sort of a duplicate of what I previously posted, but there are a few more details here:

    L/R RSSI: 204/205  L/R noise: 54/46 pkts: 838  txe=0 rxe=3 stx=0 srx=31989 ecc=0/0 temp=-270 dco=0 pwr=20

    See the image link above for more a screenshot.

  • Seppo, 

    Thank you very much for your reply.  I finally found some time to run this test, which I did in my enclosed garage here in San Diego, with no more than about 1m distance between the vehicle and antenna tracker.  Here's a quick pic of the plots, but to summarize, both noise and remnoise are running right around 50 counts and rssi and remrssi are steady (and nearly right on top of each other) at 190 counts.  Both my radios are running RFD SiK 1.12.  My apologies for not having a  spectrum analyzer laying around, but I could probably borrow one if that was necessary for this troubleshooting.  

    I'd love to try a flex 1 antenna on the plastic strip... I'll tell you what, if we sort this range issue out I'll buy 2!  

    The only thing that comes to mind to do next is crank up the power to 1W and see what kind of range I get from that, but really thought I'm about certain that isn't going to solve anything given I can only get 1000ft without quality issues.  Any other ideas to try Seppo?  I think given the range that others are reporting this is a bizarre problem.  Its not as if I have an issue connecting in the first place... Everything works EXCEPT the range.  Anyhow thanks all for the responses, pretty anxious to fly more than 1000ft!

    Jeremy



    Seppo said:

    Hi Jeremy,

    Following on from Paul, if you check the signal quality in mission planner in the tuning page.  RSSI, Remote RSSI, Noise and Remote Noise are the parameters of most interest.

    Generally noise is around 40-60 counts, and when both radios are set to 20dBm, in reasonalble (say 0.5m) away from each other, with dipoles, or monopoles, you should see around 205 to 217 on both modems for RSSI.

    If both modems are showing similar values, then the hardware is OK.

    If one is showing something significantly less, say, 150 to 180, while the other is at 217, then there is a modem issue, which we will sort out for you.

    The biquad looks pretty nice, It will be interesting to hear how that works on the tracker..

    On the copter side, to get the best results there, it is better to use a dipole (a little big I know), or, a flex 1 antenna on a plastic strip.  The monopole antennas, both straight and 90 deg versions are designed to work with a ground plane.

    When mounted straight onto the modem, the performance is degraded, but, certainly not to the level you are seeing now.

    With best regards,

    Seppo

  • I should mention as well that a spectrum analyzer I have is indicating a noise floor of -105dB in the 915-928mhz range, which is pretty close to what the 3DR is reporting.

    Allan Matthew said:

    Seppo-

    I'm also running into range issues with two RFD900x's purchased from Aero Systems West, but I think my issue is related to noise.  I'm running at txpower=20 on both sides of the link, and I get the following from an ATI7:

    L/R RSSI: 238/238  L/R noise: 106/101 pkts: 189  txe=0 rxe=13 stx=0 srx=0 ecc=0/0 temp=28 dco=0

    I see similar results (noise >90 anyway) both indoor and outdoor, and in the same location a 3DR radio will report noise of 30-60.  The radios are running:

    ATI
    RFD SiK 2.53 on RFD900xR1.1
    RTI
    RFD SiK 2.53 on RFD900xR1.1

    Thanks in advance,

    -Allan

  • Seppo-

    I'm also running into range issues with two RFD900x's purchased from Aero Systems West, but I think my issue is related to noise.  I'm running at txpower=20 on both sides of the link, and I get the following from an ATI7:

    L/R RSSI: 238/238  L/R noise: 106/101 pkts: 189  txe=0 rxe=13 stx=0 srx=0 ecc=0/0 temp=28 dco=0

    I see similar results (noise >90 anyway) both indoor and outdoor, and in the same location a 3DR radio will report noise of 30-60.  The radios are running:

    ATI
    RFD SiK 2.53 on RFD900xR1.1
    RTI
    RFD SiK 2.53 on RFD900xR1.1

    Thanks in advance,

    -Allan

This reply was deleted.

Activity

DIY Robocars via Twitter
May 15
DIY Robocars via Twitter
May 14
DIY Robocars via Twitter
May 13
DIY Robocars via Twitter
RT @f1tenth: Say hi to our newest #F1TENTH creation for @ieee_ras_icra next week in Philly. It’s going to be huge! 😎 🔥 @AutowareFdn @PennEn…
May 13
DIY Robocars via Twitter
May 11
DIY Robocars via Twitter
May 8
DIY Robocars via Twitter
RT @SmallpixelCar: Noticed my car zigzagged in last run. It turned out to be the grass stuck in the wheel and made the odometry less accura…
May 8
DIY Robocars via Twitter
RT @SmallpixelCar: Test my car. RTK GPS worked great. Thanks @emlid for their support. https://t.co/EkQ6qmjmWR
May 8
DIY Drones via Twitter
RT @chr1sa: @kane That's @diydrones circa 2009. Still have a box of those Canon cameras that we used to strap into planes, just like this.…
May 3
DIY Robocars via Twitter
RT @chr1sa: Our next @diyrobocars race is going to be outside at a real RC racetrack in Fremont on May 28. Fully autonomous racing, head-to…
Apr 30
DIY Robocars via Twitter
RT @f1tenth: Our Spring 2022 F1TENTH course @PennEngineers is coming to an end with a head-to-head race as a big finale. So proud of our st…
Apr 26
DIY Robocars via Twitter
RT @DanielChiaJH: I wrote a thing! Throughout the development of my @diyrobocars car I've been using @foxglovedev Studio to visualize and d…
Apr 23
DIY Robocars via Twitter
RT @SmallpixelCar: My new car for high speed. Low body, everything ( @NVIDIAEmbedded Jetson Xavier NX, @emlid RTK GPS, IMC) under the deck…
Apr 23
DIY Robocars via Twitter
Apr 21
DIY Robocars via Twitter
RT @f1tenth: F1TENTH Race training setup @PennEngineers for our upcoming ICRA2022 @ieee_ras_icra competition. @OpenRoboticsOrg @IndyAChalle…
Apr 21
DIY Robocars via Twitter
RT @fatcatFABLAB: Proud to be hosting a restarted DIY Robocars NYC Meetup April 26. Come by if you want to talk about and race self-driving…
Apr 17
More…