RFD900 Telemetry will not connect in Mission Planner. All settings tried.

Edit: Fix in the comments below

Hi, I've been trying for a few days now and can't figure out these radios. I am using the PX4 platform and when I configure the modems with either the 3DR config tool or the RFD900 Modem tool, the radios seem to connect but never works in Mission Planner or Qground control. I get a time out error, failed to enter command mode or Invalid parameters. I have the Arduplane 2.74 software loaded at the moment.

Some people say they simply use the Mission Planner to upload the firmware and connect without problems.

I have tried this and the radios connect at first with default settings and the terminal has normal text messages showing from the radio. But after I choose the copy required items to remote, the radios no longer allow me to arrange the node ID options and the link is broken with a red and green light both flashing on the radio connected to the PX4. The radio connected via USB serving as a base-node only has a green light flashing.  When I try to load settings via MP or the 3DR tool, the modem settings no longer match after clicking the save settings button. I also get random garbly text from the terminal view:


If I turn off the client radio(the non-base node), the scrambled messages stop, but no commands work or anything. The modems appear to respond to terminal commands independantly and while linked together after a fresh firmware flash. But after trying to get things working in Mission Planner, they don't respond to terminal commands unless only 1 is powered on, or the link is not present or attempting to be present.

This is using the Sik on 1.5 RFD900 Firmware. When I use the supplied firmware options v1.2 and v2.2

from the official RFD900 website, I get similar results. The connection initially works from viewing the

LED light statuses but once I try to connect with MP or edit any settings with the integrated radio setup

options, it wont work. I matched the baudrates, net Id's and so on. I do NOT have the USB connected to the Autopilot. But just to add on, the PX4 communicates fine when under USB.

Note: I cannot configure the Node ID's using the 3DR provided firmware. The option does not exist but

somehow the radios manage to connect.

Additionally, I end up having to reflash the firmware because I can no longer load the settings with any modem config tool.

The images I have attached show how the radios look after a flashing the firmware and loading settings.

The second image shows what happens after I copy items to remote and save settings and reload. I do not try to connect the MP flight data until after I attempt to change the settings with the 3DR configuration option. Although I have tried to before and after during my multiple flashings of the firmware, both with the 3DR provided RFD900 firmware and the RFDesign firmware.

There is one last thing. ONLY when I use the v2.2 Sik Firmware from RFDesign's website, if I try to connect via Mission Planner, it will hang for a few seconds, then start to connect. I see the connecting progress/status messages changing a few times and then it just stops in the middle of connecting. Only a few heartbeats and packets get through and then everything stops responding and I have to disconnect.

I'm lost here. Does anyone have any pointers?

Views: 12543

Reply to This

Replies to This Discussion

why is one of the radios setup for ECC, and the other is not?     set both radios to same.       I typically turn off ECC and OP RESEND, as these are only useful in a scenario with high amouts of error/loss, and if the radios are within a km of each other they dont usually need this.

secondly, remember that when changing *any* settings on the remote radio, you have to have a link to it from the local radio first.... so this means you  need to 1 - change the local radio settings to match the remote radio ( then you should get a link ); 2-  then change the REMOTE settings to match what you want them to be ( you loose link wen you save these ) ; 3 -- then you change the local radio settings to match the remote radio ( to re-get link with the new settings).    Any other way and you'll fail. 

Yes I have tried this. I check the settings in the 3DR Radio Config tool and within the MP client it's self and they seem to match. The radio's both have a solid green light and the red lights flicker at non constant intervals(assuming they are talking to each other just fine).

I click the connect button and it just times out. I get a no heartbeat packets received error as usual. I'm totally lost :(

This generally sounds to me like it's not a problem with the radio/s.... just an issues with getting your PC and APM to communicate properly.


solid green light  - means the two radio/s are in-sync, and working properly

red lights flicker - means data is being transferred successfully between them

"the scrambled messages"   - this generally means the modems are either sending binary data ( like mavlink ) , or the baud rate is set wrong..?

one of your screen captures provided shows 115200 , which is incorrect...

When you "connect" , are you using the correct BAUD rate?      ( it's 115200 for USB, but 57600 for radio ) .


Yea don't mind that last screenshot. I normally have it setup under 57600. No matter what speeds I choose, I get the same problem.

I do have a solid green light on both radios and their red lights are flickering. The radio connected to the Autopilot having the brighter flickering red light compared to the one connected to the PC.

Does the order in which the radios are connected matter? For example, I use the radio set with the node ID=0 as the one connected to the PC. I have tried them both ways though and didn't have any success.

Sometimes when I try to connect via the external 3DR Radio config tool, I will get this error:

************** Exception Text **************
System.ArgumentException: Requested value '[1] 145' was not found.
   at System.Enum.Parse(Type enumType, String value, Boolean ignoreCase)
   at ArdupilotMega._3DRradio.BUT_getcurrent_Click(Object sender, EventArgs e)
   at System.Windows.Forms.Control.OnClick(EventArgs e)
   at System.Windows.Forms.Button.OnClick(EventArgs e)
   at ArdupilotMega.Controls.MyButton.OnClick(EventArgs e)
   at System.Windows.Forms.Button.OnMouseUp(MouseEventArgs mevent)
   at ArdupilotMega.Controls.MyButton.OnMouseUp(MouseEventArgs mevent)
   at System.Windows.Forms.Control.WmMouseUp(Message& m, MouseButtons button, Int32 clicks)
   at System.Windows.Forms.Control.WndProc(Message& m)
   at System.Windows.Forms.ButtonBase.WndProc(Message& m)
   at System.Windows.Forms.Button.WndProc(Message& m)
   at System.Windows.Forms.Control.ControlNativeWindow.OnMessage(Message& m)
   at System.Windows.Forms.Control.ControlNativeWindow.WndProc(Message& m)
   at System.Windows.Forms.NativeWindow.Callback(IntPtr hWnd, Int32 msg, IntPtr wparam, IntPtr lparam)

I found a fix. It is an impossible fix but somehow it works. So basically, I'm pretty certain the v2.1 and v2.2 are  busted and don't work with the PX4. When I flash the V2.x firmwares, they allow me to configure the Node ID's and I assume they connect from the green lights being solid on both ends. However the 3DR firmware does not give me the option to configure the Node ID's/destinations. The option is simply greyed out and cannot be clicked on.

So after trying for days I randomly got lucky by noticing If I downgraded to 3DR 1.5 firmware from v2.x firmware in the Mission Planner, the node configuration dropdown menus were still showing as if I could configure them. Please note, if I were to restart mission planner and load/read the radio settings, then the node config options would be greyed out. No good.

So if I leave the program open after a fresh downgrade, it would allow me to save the node settings even after I clicked on load settings. But again if I were to close Mission Planner or reload the radio config page , the node options would not be editable. I had to do this with both radios. After this, the Mission Planner would finally allow me to connect.

As far as I know, I am not at fault for this trouble. Has anyone else encounter this problem and solution?

I guess I'm fine for now but this is really disappointing. I want to be able to use the Multipoint connection ability with the v2.x firmwares.


did you find the solution for your problem, Now I'm at the same situation.

Thanks any way.

I'm stuck in same situation now as well, Damn I spend more time researching, and fiddling with this stuff than I spend actually working on the plane, not to mention flying. I guess I'll downgrade from 2.5 to 1.9 and see how it goes.

I had this problem before, you should downgrade FW to 1.x version. The key point is that you have to make both transceivers' green light solid and red light stay flashing, at that stage then you can establish connection. 100% will connect.

I am having a little different problem. I can connect but it is very slow and then, when connection is finished the motion in MP is really slow again. I lost a lot of packets I have aprox. 30-40% of link health.

I am trying to connect at 10 meters of the plane.

Setting of my radios: (using RFD900ModemTools.exe)

RFD SiK 1.13 on RFD900P

Baud Rate: 57600

Air Speed: 64

Net ID: 15

Tx Power: 20

Node ID: 2 (but in the SW I can't change it)

Node Destination: 65535 (but in the SW I can't change it)

Min Freq: 868000 (because I am in Europe, and I bought RFD868, however its the same module)

Max Freq: 869000 

Number of chanels: 50

Duty Cycle: 100

Node Count: 3 (but in the SW I can't change it)

ECC, Op Resend, RTSCTS: disabled

Mavlink: Enabled.

The other module has exactly the same parameters.

I tried with ECC adn Op Resend and It doesn't work. I need both disabled to "work" bad.

Have you any ideas about my problem?

Thank you all!

Michael Lin  Im also having problem with my RFD900 as GC and SiK1.9 in the plane. Both had solid green light but no blinking red why is no blinking red? How to get them working? Thanks

Hi Tonimas

I have exactly the same model of your rfd868+

Did you find a solution for the slow connectivity with packet losses ?

I downgrade to 1.9 firmware and definetely is better, but occasionally big quantities of packet loss are still present

So I am trying to find a better solution

can we do such a procedure for the microhard nano series n920


has any body the experience of working with such hardware?

any help would be appreciated

thank you so much

Reply to Discussion


© 2020   Created by Chris Anderson.   Powered by

Badges  |  Report an Issue  |  Terms of Service