Hi All. Newbie here. A week ago I received an Arducopter Quad from 3DR and nothing has worked at all like it's supposed to.  I went for the soft option of having it assembled for me so all i had to do was put on the legs and rotors, bind my RC gear and it should've been good to go.  I followed all the instructions on the Wiki and didn't actually make it very far.  When I try to calibrate the ESCs they make the musical tone first, then beep twice (all four ESCs) without any kind of change, incessantly.  Tried both methods of calibration and same result.  The RC gear is working (Spektrum DX8) as on the MP software it all behaves as it should.

I asked for help from 3DR and the first suggestion was to configure the 3DR radio on the MP.  When I attempt this (load settings), it says "failed to enter command mode."

Surely this shouldn't be this hard - I've read all the solutions to what seems to be a pretty common problem and tried them, but no dice.  Reversing the throttle channel didn't make any difference.  I did see a reference somewhere to "JP1" needing to be in - I can see the JP1 slot on top of the APM and it is empty. I didn't get a jumper pin with the kit, so haven't tried that.  I did try bridging with a screwdriver but made no difference.

Any advice would be appreciated as I am feeling disillusioned with the whole experience so far.  I was hoping to use this chopper to scare birds off my grapes, but it looks like I won't get it up and running in time to test the theory. :(

Views: 478

Reply to This

Replies to This Discussion

Your being discouraged is understandable. You'll get this straightened out in time to scare the hell out of those birds. Please don't be too rough on them though, as they need to eat too! There are a few interdependent things that need to come together to get this working, and we all suffer from the same at first. My experience , however, is with fixed wing and APM. My first experiences exacted a certain amount of cussing before it started to become clear as to what needed to be done. Others here should be able to guide you in the right direction with your new multirotor.

Hi Tim - I hope you're right and I can get running ASAP. Itching to show the birds who's boss with the chopper, though. Normally, we shoot the birds, so this seems like a step in the right direction :)

Sorry to hear of your 'learning pains' but it comes with the turf.

Are you running the DX8 in ACRO mode? (Airplane)

Which APM are you running? (I suspect 2.5)

JP1 should not have been used in an RTF aircraft if you have the latest APM (with the Power Module); you do not need JP1.

We will (hope) assume the aircraft was tested by 3DR prior to shipping and there are no wiring issues.

Where the props on the motors? (you said 'rotors' and legs; again I assume they were not).

That is enough questions for now.


What kind battery are you using? Did your quad come with 3DR power module installed? Also who built the Quad? Calibrating ESC can be an issue and takes a bit to work.

Hi Doug - Yes, the DX8 is in Acro mode (aeroplane).  Yes, I am running APM 2.5. I get the feeling this machine wasn't tested by 3DR prior to shipping, but I only feel that way because I was under the (false) impression that I'd just plug a battery in and I'd be in the air.  I've now had a second email from 3DR but they keep asking me about calibrating the 3DR radio in the MP.  I can't get past "load settings" on that page, though, which suggests that there is something not communicating which 3DR are expecting should be communicating.

The props were not on the motors.

Thx for your help.


Hi Richard - I am using a Turnigy Nanotech 3300mAh 6S Lipo.  The quad came with everything installed  except legs and props.  The power module - do you mean the distribution board that the ESCs plug in to? It was all built already - APM, PDB, 3DR telemetry, GPS and Spektrum receiver also installed (but not bound to transmitter which i took as a hint that the system hadn't been tested.)  It was built by 3DR (its first scan by FedEx enroute to me was in Tijuana, Mexico.)

Wow, 6S is way to much voltage. Your quad can use either 3S or 4S. I use a 4S and it flys like a rocket. Hopefully you haven't fried anything. I recommend a 3S 5000mAh. The PIDS are set for the 3S and the 5000mAh will give you about 15 minutes of flight.

The power module I'm talking about is something new 3DR is now using. It bypass the normal BEC off one of your ESC. It's a separate BEC that also monitors your battery.
Here is a link to the PM.

Hey Richard - that's great. At least I have something simple to try.  If I did fry the power module, that should have protected everything else I guess.  I should probably get a spare one in case.  I'll get some new batteries on the way ASAP.  I was unaware of the implications of using a higher capacity battery.  Will let you know how I go.  Cheers.

Hi Richard.  I've made some progress with the new 3S battery.  I'm pretty sure i've calibrated the ESCs successfully now.  Sometimes when i connect the LiPo all the ESCs beep incessantly, other times (going through exactly the same sequence) the quad just sits there without making any beeps (after the startup ones.)  I think the problem I have now is that I'm unable to arm the APM.  When I hold the throttle stick down and right for 4s nothing happens.  But it seems a bit weird that it's not being consistent in the tones it makes.

I don't know if it's related or not, but it also appears that my yaw and roll channels have been reversed on the RC.  I'm positive that last time i calibrated the RC it was all correct.  I've also tried arming the APM by holding down and left (since channels are backwards.)

I can also still not calibrate the 3DR radio - "failed to enter command mode."

I'm getting the feeling that i've dived in the deep end...

Depending on what type of radio you have you might be able to reverse the channels that are backwards. The beeping comes from the ESCs they tell how many cells are on the battery. 3 beeps 3 cells and 4 beeps 4 cells. The ESCs also beep when they are being calibrated. If your radio can't reverse the channels you can do it under the advance PID screen.

Reply to Discussion


© 2018   Created by Chris Anderson.   Powered by

Badges  |  Report an Issue  |  Terms of Service