RTL AND CRASH AC3.1.2

Hello,

Today I was flying my quadcopter with arducopter 3.1.2 and APM 2.6 with Ublox GPS, vibration levels where excellent between 0.4 and -0.4 on X and Y and 0.4 -0.4 around 9.8 on Z axis, alt hold and loitter where working perfectly, so I decided to move tohttp://youtu.be/zY9FS2ryhVU RTL so I flew some meters away and activated that function, the quad flew perfectly to home location, hover for 5 seconds and when it was going to land it suddenly shut down the engines and my quad felt from 15 meters to the cold ground.

 

I am not using sonar and it is disabled, please find attached logs

3691099368?profile=original

3691099516?profile=original

2014-02-19 15-23-02.tlog

2014-02-19 15-23-02.rlog

2014-02-19 15-24.log

You need to be a member of diydrones to add comments!

Join diydrones

Email me when people reply –

Replies

  • Hi Daniel,

    Can you take a picture of your APM wiring in the copter? I suspect that in flight shut down could be what I have experienced three times on different units. All of them due to the fact that I did not read the assembly and connection instructions on the wiki.

    Basically, I did not supply 5V dc into the OUTPUT side of the APM with  either a BEC on the ESC or seperate BEC.

    It can fly for a while without mishap but then suddenly, no power and the APM resets. You might get a failsafe or RTL as the voltage passes down to below some threshold but its short lived....I have even experienced the modes changing in flight as the spectrum receiver begins to brown out. (i personally do not use spectrum for this reason)

    Hope all is going well as I only read this thread late.

    Cheers-Choppy

  • Daniel,

    I'm not an expert log reader like they other great developer guys, but I have had a lot of crashes over the last couple of years, and am starting to use the logs more and more for crash forensics.

    In any case, I have taken a look at your logs and can see that it doesn't seem to be related to my past situations where it was obvious that I had a FAILSAFE and then the APM board DISARMED my copter in mid flight (for various past reasons).

    I did not see (I could be wrong) that you experienced a FAILSAFE event, or an APM board brownout.  I've never run at the 22 volt level and did see from the logs that the APM board was being driven at 5.5 volts.  Since I could see the current logs, I thought you might not be using the "stock" 3DR Power Module to provide the APM board voltage.  I could be wrong.  But if I'm right, you might want to check with the developers (if you don't already know), and make sure that your Power scheme is okay.  As you might know (and I certainly know now), all kinds of crazy things happen with power schemes that don't feed the little picky "chip creatures" the way they like.

    Also, I looked at your throttle raw (channel 3) to see if for some reason the TX throttle may accidentally been dropped, but it shows that you had a steady request for a hovering throttle, but for some reason, the APM board ("throttle" and "servo 3 out" logs) went south, and so did your Quadcopter...   I could be also be inferring this wrong, but I've used these logs quite a bit in my crash investigations.  By the way, having to read the logs is not something that I'm looking forward to getting better at..  or having to do much in the future!...   if you now what I mean.  : )

    It did not show that after the RTL function put you into a hover, that you might have switched to LAND mode, etc.  I checked this, because one time I feel from the air after a RTL when I put it in LAND mode, and inadvertedly reduced my throttle to zero prematurely....   and it fell to the ground like a rock... 

    Also, I noticed right before it fell, it seemed like your altitude was off by 30 meters, because when (form you AVI video) compared to the logs..   it looked like when you hit the ground...   it thought you were still at 30 meters.

    I don't know if this is in any way helpful, but I thought I might take the time to give you a few thoughts, before the experts get a chance to provide you with some "real" help.

     

    Hope you find the "smoking gun" soon.  I know who frustrating this can be.  Look at the bright side....  At least you aren't "in your quadcopter"!

     

    Mike Governale

    • Hello Mike,

      Thanks for this step by step analysis and for your time, I haven't found the cause of the zero throttle on RTL, however I have already return from dead my quad, and I am planning to test again the RTL function tomorrow, I am kind of scare because it takes a lot of time to build from scratch this birds, also this is my last carbon fiber arm so I must not fail or it will take a long to fly again. I have been thinking the posible cause related directly with RTL algorithm, I will reduce the landing speed parameter to 30cm/s and will set the RTL_ALT to 2m in case it crash it won't be too damaged.  I will let you know the results of tomorrow fligth.

      thanks

      • Hi Daniel!

        Agree with Mike!

        Check your power supply. All data stops at the same time in air... 

This reply was deleted.

Activity

DIY Robocars via Twitter
RT @a1k0n: Did I get rid of hand-tuned parameters? Yes. Am I still hand-tuning more parameters? Also yes. I have a few knobs to address the…
yesterday
DIY Robocars via Twitter
RT @a1k0n: I'm not going to spoil it, but (after charging the battery) this works way better than it has any right to. The car is now faste…
yesterday
DIY Robocars via Twitter
RT @a1k0n: Decided to just see what happens if I run the sim-trained neural net on the car, with some safety rails around max throttle slew…
yesterday
DIY Robocars via Twitter
Saturday
DIY Robocars via Twitter
RT @SmallpixelCar: @a1k0n @diyrobocars I learned from this. This is my speed profile. Looks like I am too conservative on the right side of…
Saturday
DIY Robocars via Twitter
RT @a1k0n: @SmallpixelCar @diyrobocars Dot color is speed; brighter is faster. Yeah, it has less room to explore in the tighter part, and t…
Saturday
DIY Robocars via Twitter
RT @a1k0n: I'm gonna try to do proper offline reinforcement learning for @diyrobocars and throw away all my manual parameter tuning for the…
Friday
DIY Robocars via Twitter
RT @circuitlaunch: DIY Robocars & Brazilian BBQ - Sat 10/1. Our track combines hairpin curves with an intersection for max danger. Take tha…
Thursday
DIY Robocars via Twitter
RT @SmallpixelCar: Had an great test today on @RAMS_RC_Club track. However the car starts to drift at 40mph. Some experts recommended to ch…
Sep 11
DIY Robocars via Twitter
RT @gclue_akira: 世界最速 チームtamiyaのaiカー https://t.co/1Qq2zOeftG
Sep 10
DIY Robocars via Twitter
RT @DanielChiaJH: Always a good time working on my @diyrobocars car at @circuitlaunch. Still got some work to do if I’m to beat @a1k0n howe…
Sep 10
DIY Robocars via Twitter
RT @SmallpixelCar: My new speed profile for @RAMS_RC_Club track https://t.co/RtLb7TcgIJ
Sep 10
DIY Robocars via Twitter
RT @SmallpixelCar: Practiced at @RAMS_RC_Club today with my new @ARRMARC car https://t.co/AEu2hCx89T
Aug 28
DIY Robocars via Twitter
Aug 24
DIY Robocars via Twitter
RT @gclue_akira: 柏の葉で走行させてるjetracerの中身 #instantNeRF #jetracer https://t.co/giVvuE4hP7
Jul 4
DIY Robocars via Twitter
Cool web-based self-driving simulator. Click save when the AI does the right thing https://github.com/pncsoares/self-driving-car
Jul 4
More…