Hi all,

I'm getting a very odd behaviour in my Skywalker's (with Pixhawk and APM:Plane 3.3.0) RUDDER . While in Manual Mode it responds correctly to the transmitter's input, in other modes managed by APM (Stabilize, FBWA, etc.) not only does it move in the wrong direction but it also bounces along the movement. The video explains this oddity better than words:

https://drive.google.com/file/d/0B9G60cFGY26fSEJSZW9GWE1Qbjg/view?usp=sharing

Do you guys have any clue on what's going on?

Thanks very much!

Robert

You need to be a member of diydrones to add comments!

Join diydrones

Email me when people reply –

Replies

  • Hi Robert,

    in 'Manual' all Tx inputs go directly to the servos. You are supposed to setup the correct direction of the servos in your TX. You must have correct input signals in 'Radio Calibration' and/or 'Fail Safe' screen.

    After that you switch to 'Stabilize' and correct the direction of the servos by reversing the direction in MP. Remember when rotating nose down the elevator has to go up and so on. You can look at the outputs at the 'Fail Safe' screen as well. Check the artifical horizon and the 'Fail safe' behaviour as well !

This reply was deleted.

Activity

xemone liked Max Gilson's profile
Aug 31
nick rymer left a comment on ArduCopter User Group
"I recently switched laptops and now have Windows 10. I installed Mission Planner on my laptop and plugged a mRo SiK Telemetry Radio into the USB port. The radio is not recognized on the com ports but is instead on the "Other Devices" tab in Device…"
Aug 20
More…